All of lore.kernel.org
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@kernel.org>
To: "Luck, Tony" <tony.luck@intel.com>
Cc: linux-kernel@vger.kernel.org, Borislav Petkov <bp@alien8.de>,
	the arch/x86 maintainers <x86@kernel.org>
Subject: Re: [GIT PULL] x86/mce fix (ready for 3.6 merge window)
Date: Wed, 11 Jul 2012 10:04:46 +0200	[thread overview]
Message-ID: <20120711080446.GA17713@gmail.com> (raw)
In-Reply-To: <4ffc6b7b63006ca92@agluck-desktop.sc.intel.com>


* Luck, Tony <tony.luck@intel.com> wrote:

> The following changes since commit 6887a4131da3adaab011613776d865f4bcfb5678:
> 
>   Linux 3.5-rc5 (2012-06-30 16:08:57 -0700)
> 
> are available in the git repository at:
> 
>   git://git.kernel.org/pub/scm/linux/kernel/git/ras/ras.git tags/please-pull-mce-ripvfix
> 
> for you to fetch changes up to b99c2fc9366d4e32b8d087cd28f6dbf5f7932dae:
> 
>   x86/mce: Need to let kill_proc() send signal to doomed process (2012-07-10 10:18:29 -0700)
> 
> ----------------------------------------------------------------
> Fix application level machine check recovery
> 
> ----------------------------------------------------------------
> Tony Luck (1):
>       x86/mce: Need to let kill_proc() send signal to doomed process
> 
>  arch/x86/kernel/cpu/mcheck/mce.c |  6 ++++--
>  include/linux/mm.h               |  1 +
>  mm/memory-failure.c              | 10 ++++++----
>  3 files changed, 11 insertions(+), 6 deletions(-)

A couple of commit log details:

 - If it's for v3.6 then the Cc: stable backport is not 
   justified. Either it's for tip:x86/urgent and then we'll 
   merge it straight away, or for tip:x86/mce for v3.6 and then 
   there's no Cc: stable tag.

 - This reference to a commit is a bit unusual:

In commit dad1743e5993f19b3d7e7bd0fb35dc45b5326626
x86/mce: Only restart instruction after machine check recovery if it is safe

   the canonical format is something like:

  In commit dad1743e5993f1 ("x86/mce: Only restart instruction 
  after machine check recovery if it is safe") ...

 - We tend to use such an ordering of tags:

  Signed-off-by: Tony Luck <tony.luck@intel.com>
  Acked-by: Borislav Petkov <borislav.petkov@amd.com>
  Cc: stable@kernel.org    # 3.4+

  I.e. Tested-by and Reported-by tags first (if any), then 
  author SOB, then SOB chain (if any), then Reviewed-by
  and Acked-by, then stable tags, then Cc:s.

  (I fix this up silently for email space patches, for Git pulls
   I cannot do that.)

 - The title is suboptimal:

  x86/mce: Need to let kill_proc() send signal to doomed process

   In titles we prefer proper sentences, starting with a verb, 
   so something like this would do:

  x86/mce: Allow kill_proc() to send signals to doomed process

   Or rather, use a good title that talks about what the change 
   is really about:

  x86/mce: Fix siginfo_t->si_addr value for non-recoverable memory faults

 - (Spelling nitpick: it's not "et. al." but "et al.".)

 - Style nit, this:

       if (mi->restartable == 0)

   is better written as:

       if (!mi->restartable)

   because mi->restartable's role here is not really an integer 
   value, but a boolean in essence.

 - The 'doit' flag was significantly misnamed when kill_procs() 
   was written and now it spreads further, it's a totally opaque 
   name that tells nothing about the role of the flag.

   How about 'force'?

Thanks,

	Ingo

  reply	other threads:[~2012-07-11  8:05 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-07-10 17:50 [GIT PULL] x86/mce fix (ready for 3.6 merge window) Luck, Tony
2012-07-11  8:04 ` Ingo Molnar [this message]
2012-07-11  8:31   ` Borislav Petkov
2012-07-11 16:26   ` Tony Luck
2012-07-11 17:45     ` [GIT PULL v2] " Luck, Tony
2012-07-11 20:53       ` Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20120711080446.GA17713@gmail.com \
    --to=mingo@kernel.org \
    --cc=bp@alien8.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.