From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from eggs.gnu.org ([208.118.235.92]:43206) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1UcA5X-0002rK-By for qemu-devel@nongnu.org; Tue, 14 May 2013 03:56:02 -0400 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71) (envelope-from ) id 1UcA5U-0000Ou-Tk for qemu-devel@nongnu.org; Tue, 14 May 2013 03:55:59 -0400 Received: from mx1.redhat.com ([209.132.183.28]:14254) by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1UcA5U-0000Oi-K7 for qemu-devel@nongnu.org; Tue, 14 May 2013 03:55:56 -0400 Date: Tue, 14 May 2013 10:55:51 +0300 From: "Michael S. Tsirkin" Message-ID: <20130514075551.GD4368@redhat.com> References: <87af80d75efe782e9edb47f214e0521f50a9cf56.1368474222.git.mst@redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: Subject: Re: [Qemu-devel] [PATCH RFC 08/13] range: add Range structure List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , To: Peter Maydell Cc: seabios@seabios.org, lersek@redhat.com, qemu-devel@nongnu.org, Anthony Liguori On Mon, May 13, 2013 at 09:20:08PM +0100, Peter Maydell wrote: > On 13 May 2013 21:01, Michael S. Tsirkin wrote: > > Sometimes we need to pass ranges around, add a > > handy structure for this purpose. > > > > Signed-off-by: Michael S. Tsirkin > > --- > > include/qemu/range.h | 22 ++++++++++++++++++++++ > > 1 file changed, 22 insertions(+) > > > > diff --git a/include/qemu/range.h b/include/qemu/range.h > > index 3502372..4bcd346 100644 > > --- a/include/qemu/range.h > > +++ b/include/qemu/range.h > > @@ -1,6 +1,28 @@ > > #ifndef QEMU_RANGE_H > > #define QEMU_RANGE_H > > > > +#include > > + > > +/* > > + * Operations on 64 address ranges. > > missing "bit" ? > > > + * Notes: > > + * - ranges must not wrap around 0, but can include the last byte ~0x0LL. > > + * - this can not represent a full 0 to ~0x0LL range. > > + */ > > + > > +/* A structure representing a range of addresses. */ > > +struct Range { > > + uint64_t begin; /* First byte of the range, or 0 if empty. */ > > + uint64_t end; /* 1 + the last byte. 0 if range empty or ends at ~0x0LL. */ > > +}; > > +typedef struct Range Range; > > + > > +/* verify that range is not empty and does not overlap */ > > Doesn't overlap what? I meant wrap around there. > Why isn't an empty range valid? > The struct definition above says it's OK. Yes it's a bad name. Should be range_non_empty or something. > > +{ > > + return range->begin + 1 <= range->end; > > +} > > I note that memory.c defines its own concept of an AddrRange. > > thanks > -- PMM Good point, maybe I'll reuse that or just use two 64 bit fields explicitly. -- MST