All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kevin Wolf <kwolf@redhat.com>
To: "Benoît Canet" <benoit.canet@irqsave.net>
Cc: "Benoît Canet" <benoit@irqsave.net>,
	qemu-devel@nongnu.org, stefanha@redhat.com, mreitz@redhat.com
Subject: Re: [Qemu-devel] [PATCH V15 05/13] quorum: Add quorum_aio_readv.
Date: Tue, 4 Feb 2014 15:15:49 +0100	[thread overview]
Message-ID: <20140204141549.GL3384@dhcp-200-207.str.redhat.com> (raw)
In-Reply-To: <1391464280-25627-6-git-send-email-benoit.canet@irqsave.net>

Am 03.02.2014 um 22:51 hat Benoît Canet geschrieben:
> From: Benoît Canet <benoit@irqsave.net>
> 
> Signed-off-by: Benoit Canet <benoit@irqsave.net>
> Reviewed-by: Max Reitz <mreitz@redhat.com>
> ---
>  block/quorum.c | 38 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 38 insertions(+)
> 
> diff --git a/block/quorum.c b/block/quorum.c
> index 81bffdd..699b512 100644
> --- a/block/quorum.c
> +++ b/block/quorum.c
> @@ -86,10 +86,19 @@ static void quorum_aio_finalize(QuorumAIOCB *acb)
>      BDRVQuorumState *s = acb->bqs;
>      int ret = 0;
>  
> +    for (i = 0; i < s->total; i++) {
> +        qemu_vfree(acb->aios[i].buf);
> +        acb->aios[i].buf = NULL;
> +        acb->aios[i].ret = 0;

You free acb->aios anyway, no point in clearing the fields.

> +    }
> +
>      acb->common.cb(acb->common.opaque, ret);
>      if (acb->finished) {
>          *acb->finished = true;
>      }
> +    for (i = 0; acb->is_read && i < s->total; i++) {

As Max noted, pulling acb->is_read into the for loop condition is
clever. Code being unnecessarily clever is usually bad.

> +        qemu_iovec_destroy(&acb->aios[i].qiov);
> +    }

Any reason to have two separate for loops? I can't see one why the qiov
should be any longer valid than the data in it. I also can't see the
reason for the different conditions, other than qemu_vfree() being a
no-op for writes.

Keep it simple:

if (acb->is_read) {
    for (i = 0; i < s->total; i++) {
        qemu_vfree(acb->aios[i].buf);
        qemu_iovec_destroy(&acb->aios[i].qiov);
    }
}

It's shorter, less clever and more readable than your version.

>      g_free(acb->aios);
>      qemu_aio_release(acb);
>  }
> @@ -145,6 +154,34 @@ static void quorum_aio_cb(void *opaque, int ret)
>      quorum_aio_finalize(acb);
>  }
>  
> +static BlockDriverAIOCB *quorum_aio_readv(BlockDriverState *bs,
> +                                         int64_t sector_num,
> +                                         QEMUIOVector *qiov,
> +                                         int nb_sectors,
> +                                         BlockDriverCompletionFunc *cb,
> +                                         void *opaque)
> +{
> +    BDRVQuorumState *s = bs->opaque;
> +    QuorumAIOCB *acb = quorum_aio_get(s, bs, qiov, sector_num,
> +                                      nb_sectors, cb, opaque);
> +    int i;
> +
> +    acb->is_read = true;
> +
> +    for (i = 0; i < s->total; i++) {
> +        acb->aios[i].buf = qemu_blockalign(bs->file, qiov->size);

Shouldn't this be s->bs[i] instead of bs->file?

> +        qemu_iovec_init(&acb->aios[i].qiov, qiov->niov);
> +        qemu_iovec_clone(&acb->aios[i].qiov, qiov, acb->aios[i].buf);
> +    }
> +
> +    for (i = 0; i < s->total; i++) {
> +        bdrv_aio_readv(s->bs[i], sector_num, qiov, nb_sectors,
> +                       quorum_aio_cb, &acb->aios[i]);
> +    }
> +
> +    return &acb->common;
> +}
> +
>  static BlockDriverAIOCB *quorum_aio_writev(BlockDriverState *bs,
>                                            int64_t sector_num,
>                                            QEMUIOVector *qiov,
> @@ -172,6 +209,7 @@ static BlockDriver bdrv_quorum = {
>  
>      .instance_size      = sizeof(BDRVQuorumState),
>  
> +    .bdrv_aio_readv     = quorum_aio_readv,
>      .bdrv_aio_writev    = quorum_aio_writev,
>  };

Kevin

  reply	other threads:[~2014-02-04 14:16 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-02-03 21:51 [Qemu-devel] [PATCH V15 00/13] Quorum block filter Benoît Canet
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 01/13] quorum: Create quorum.c, add QuorumSingleAIOCB and QuorumAIOCB Benoît Canet
2014-02-04 12:57   ` Kevin Wolf
2014-02-05 13:29     ` Benoît Canet
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 02/13] quorum: Create BDRVQuorumState and BlkDriver and do init Benoît Canet
2014-02-04 13:08   ` Kevin Wolf
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 03/13] quorum: Add quorum_aio_writev and its dependencies Benoît Canet
2014-02-04 13:57   ` Kevin Wolf
2014-02-05 14:14     ` Benoît Canet
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 04/13] blkverify: Extract qemu_iovec_clone() and qemu_iovec_compare() from blkverify Benoît Canet
2014-02-04 14:04   ` Kevin Wolf
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 05/13] quorum: Add quorum_aio_readv Benoît Canet
2014-02-04 14:15   ` Kevin Wolf [this message]
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 06/13] quorum: Add quorum mechanism Benoît Canet
2014-02-04 15:40   ` Kevin Wolf
2014-02-05 15:14     ` Benoît Canet
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 07/13] quorum: Add quorum_getlength() Benoît Canet
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 08/13] quorum: Add quorum_invalidate_cache() Benoît Canet
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 09/13] quorum: Add quorum_co_get_block_status Benoît Canet
2014-02-04 15:49   ` Kevin Wolf
2014-02-05 16:28     ` Benoît Canet
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 10/13] quorum: Add quorum_co_flush() Benoît Canet
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 11/13] quorum: Implement recursive .bdrv_recurse_is_first_non_filter in quorum Benoît Canet
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 12/13] quorum: Add quorum_open() and quorum_close() Benoît Canet
2014-02-04 16:08   ` Kevin Wolf
2014-02-05 16:11     ` Benoît Canet
2014-02-03 21:51 ` [Qemu-devel] [PATCH V15 13/13] quorum: Add unit test Benoît Canet
2014-02-04 16:13   ` Kevin Wolf
2014-02-04 21:53     ` Benoît Canet

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140204141549.GL3384@dhcp-200-207.str.redhat.com \
    --to=kwolf@redhat.com \
    --cc=benoit.canet@irqsave.net \
    --cc=benoit@irqsave.net \
    --cc=mreitz@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=stefanha@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.