From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1161161AbaDPNll (ORCPT ); Wed, 16 Apr 2014 09:41:41 -0400 Received: from cam-admin0.cambridge.arm.com ([217.140.96.50]:36529 "EHLO cam-admin0.cambridge.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1161094AbaDPNlj (ORCPT ); Wed, 16 Apr 2014 09:41:39 -0400 Date: Wed, 16 Apr 2014 14:27:16 +0100 From: Will Deacon To: AKASHI Takahiro Cc: "viro@zeniv.linux.org.uk" , "eparis@redhat.com" , "rgb@redhat.com" , Catalin Marinas , "dsaxena@linaro.org" , "arndb@arndb.de" , "linux-arm-kernel@lists.infradead.org" , "linaro-kernel@lists.linaro.org" , "linux-kernel@vger.kernel.org" , "linux-audit@redhat.com" Subject: Re: [PATCH v5 2/4] arm64: split syscall_trace() into separate functions for enter/exit Message-ID: <20140416132716.GA1001@arm.com> References: <1394705491-12343-1-git-send-email-takahiro.akashi@linaro.org> <1394861948-28712-1-git-send-email-takahiro.akashi@linaro.org> <1394861948-28712-3-git-send-email-takahiro.akashi@linaro.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1394861948-28712-3-git-send-email-takahiro.akashi@linaro.org> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Akashi, On Sat, Mar 15, 2014 at 05:39:06AM +0000, AKASHI Takahiro wrote: > As done in arm, this change makes it easy to confirm we invoke syscall > related hooks, including syscall tracepoint, audit and seccomp which would > be implemented later, in correct order. That is, undoing operations in the > opposite order on exit that they were done on entry. > > Signed-off-by: AKASHI Takahiro [...] > +static void tracehook_report_syscall(struct pt_regs *regs, > + enum ptrace_syscall_dir dir) > { > + int scrach; s/scrach/scratch/ Although, I'd rather have a variable with a more meaningful name. How about regno? With that, Acked-by: Will Deacon Cheers, Will From mboxrd@z Thu Jan 1 00:00:00 1970 From: Will Deacon Subject: Re: [PATCH v5 2/4] arm64: split syscall_trace() into separate functions for enter/exit Date: Wed, 16 Apr 2014 14:27:16 +0100 Message-ID: <20140416132716.GA1001@arm.com> References: <1394705491-12343-1-git-send-email-takahiro.akashi@linaro.org> <1394861948-28712-1-git-send-email-takahiro.akashi@linaro.org> <1394861948-28712-3-git-send-email-takahiro.akashi@linaro.org> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Content-Disposition: inline In-Reply-To: <1394861948-28712-3-git-send-email-takahiro.akashi@linaro.org> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: "linux-arm-kernel" Errors-To: linux-arm-kernel-bounces+linux-arm-kernel=m.gmane.org@lists.infradead.org To: AKASHI Takahiro Cc: "linaro-kernel@lists.linaro.org" , "rgb@redhat.com" , Catalin Marinas , "arndb@arndb.de" , "eparis@redhat.com" , "linux-kernel@vger.kernel.org" , "dsaxena@linaro.org" , "viro@zeniv.linux.org.uk" , "linux-audit@redhat.com" , "linux-arm-kernel@lists.infradead.org" List-Id: linux-audit@redhat.com Hi Akashi, On Sat, Mar 15, 2014 at 05:39:06AM +0000, AKASHI Takahiro wrote: > As done in arm, this change makes it easy to confirm we invoke syscall > related hooks, including syscall tracepoint, audit and seccomp which would > be implemented later, in correct order. That is, undoing operations in the > opposite order on exit that they were done on entry. > > Signed-off-by: AKASHI Takahiro [...] > +static void tracehook_report_syscall(struct pt_regs *regs, > + enum ptrace_syscall_dir dir) > { > + int scrach; s/scrach/scratch/ Although, I'd rather have a variable with a more meaningful name. How about regno? With that, Acked-by: Will Deacon Cheers, Will From mboxrd@z Thu Jan 1 00:00:00 1970 From: will.deacon@arm.com (Will Deacon) Date: Wed, 16 Apr 2014 14:27:16 +0100 Subject: [PATCH v5 2/4] arm64: split syscall_trace() into separate functions for enter/exit In-Reply-To: <1394861948-28712-3-git-send-email-takahiro.akashi@linaro.org> References: <1394705491-12343-1-git-send-email-takahiro.akashi@linaro.org> <1394861948-28712-1-git-send-email-takahiro.akashi@linaro.org> <1394861948-28712-3-git-send-email-takahiro.akashi@linaro.org> Message-ID: <20140416132716.GA1001@arm.com> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org Hi Akashi, On Sat, Mar 15, 2014 at 05:39:06AM +0000, AKASHI Takahiro wrote: > As done in arm, this change makes it easy to confirm we invoke syscall > related hooks, including syscall tracepoint, audit and seccomp which would > be implemented later, in correct order. That is, undoing operations in the > opposite order on exit that they were done on entry. > > Signed-off-by: AKASHI Takahiro [...] > +static void tracehook_report_syscall(struct pt_regs *regs, > + enum ptrace_syscall_dir dir) > { > + int scrach; s/scrach/scratch/ Although, I'd rather have a variable with a more meaningful name. How about regno? With that, Acked-by: Will Deacon Cheers, Will