All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jonathan Nieder <jrnieder@gmail.com>
To: Jeremiah Mahler <jmmahler@gmail.com>
Cc: "Torsten Bögershausen" <tboegi@web.de>, git@vger.kernel.org
Subject: Re: [PATCH v3 4/5] dir.c: rename to name_compare()
Date: Wed, 18 Jun 2014 12:09:56 -0700	[thread overview]
Message-ID: <20140618190956.GU8557@google.com> (raw)
In-Reply-To: <1403117117-10384-5-git-send-email-jmmahler@gmail.com>

Jeremiah Mahler wrote:

>     This is a case where cache_name_compare() was used even though it had
>     nothing to do with a cache.  The new name makes it clear that no cache
>     is involved.

That's a perfect sort of thing to put in the commit message. ;-)

Unlike patches 2 and 3, this could make sense to me as a separate
patch from 1/5.  Except... how does git work at all with patch 1 and
without this patch?  I thought that patch removed the public
cache_name_compare function.

Would it make sense to delay the removal of cache_name_compare until a
patch at the end of the series?

The patch is small enough that squashing into patch 1 seems fine, too.

[...]
> Rename the call to cache_name_compare() to name_compare().

It's not actually renaming but calling a different function, right?
So I'd say something like

	read_directory: use name_compare instead of cache_name_compare

	This is a case where cache_name_compare() was used even though it had
	nothing to do with a cache.  The new name makes it clear that no cache
	is involved.

	No functional change intended.

Thanks,
Jonathan

  reply	other threads:[~2014-06-18 19:10 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-06-18 18:45 [PATCH v3 0/5] cleanup duplicate name_compare() functions Jeremiah Mahler
2014-06-18 18:45 ` [PATCH v3 1/5] cache: rename cache_name_compare() to name_compare() Jeremiah Mahler
2014-06-18 19:11   ` Jonathan Nieder
2014-06-18 18:45 ` [PATCH v3 2/5] tree-walk.c: remove name_compare() function Jeremiah Mahler
2014-06-18 19:03   ` Jonathan Nieder
2014-06-19  8:04     ` Jeremiah Mahler
2014-06-18 18:45 ` [PATCH v3 3/5] unpack-trees.c: " Jeremiah Mahler
2014-06-18 19:04   ` Jonathan Nieder
2014-06-18 18:45 ` [PATCH v3 4/5] dir.c: rename to name_compare() Jeremiah Mahler
2014-06-18 19:09   ` Jonathan Nieder [this message]
2014-06-18 18:45 ` [PATCH v3 5/5] name-hash.c: " Jeremiah Mahler
2014-06-18 19:10   ` Jonathan Nieder
2014-06-18 19:14 ` [PATCH v3 0/5] cleanup duplicate name_compare() functions Jonathan Nieder
2014-06-19  8:04   ` Jeremiah Mahler
2014-06-19  8:54     ` Jeff King

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140618190956.GU8557@google.com \
    --to=jrnieder@gmail.com \
    --cc=git@vger.kernel.org \
    --cc=jmmahler@gmail.com \
    --cc=tboegi@web.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.