From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH 07/53] drm/i915/bdw: New file for Logical Ring Contexts and Execlists Date: Wed, 18 Jun 2014 22:17:15 +0200 Message-ID: <20140618201715.GX5821@phenom.ffwll.local> References: <1402673891-14618-1-git-send-email-oscar.mateo@intel.com> <1402673891-14618-8-git-send-email-oscar.mateo@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Return-path: Received: from mail-wg0-f48.google.com (mail-wg0-f48.google.com [74.125.82.48]) by gabe.freedesktop.org (Postfix) with ESMTP id C49C96E786 for ; Wed, 18 Jun 2014 13:17:22 -0700 (PDT) Received: by mail-wg0-f48.google.com with SMTP id n12so1374660wgh.19 for ; Wed, 18 Jun 2014 13:17:22 -0700 (PDT) Content-Disposition: inline In-Reply-To: <1402673891-14618-8-git-send-email-oscar.mateo@intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: intel-gfx-bounces@lists.freedesktop.org Sender: "Intel-gfx" To: oscar.mateo@intel.com Cc: intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Fri, Jun 13, 2014 at 04:37:25PM +0100, oscar.mateo@intel.com wrote: > From: Oscar Mateo > = > Some legacy HW context code assumptions don't make sense for this new > submission method, so we will place this stuff in a separate file. > = > Note for reviewers: I've carefully considered the best name for this file > and this was my best option (other possibilities were intel_lr_context.c > or intel_execlist.c). I am open to a certain bikeshedding on this matter, > anyway. Regarding splitting execlists and logical ring contexts, it is > probably not worth it for the moment. > = > v2: Change to intel_lrc.c > = > Signed-off-by: Oscar Mateo > --- > drivers/gpu/drm/i915/Makefile | 1 + > drivers/gpu/drm/i915/intel_lrc.c | 42 ++++++++++++++++++++++++++++++++++= ++++++ > 2 files changed, 43 insertions(+) > create mode 100644 drivers/gpu/drm/i915/intel_lrc.c > = > diff --git a/drivers/gpu/drm/i915/Makefile b/drivers/gpu/drm/i915/Makefile > index cad1683..9fee2a0 100644 > --- a/drivers/gpu/drm/i915/Makefile > +++ b/drivers/gpu/drm/i915/Makefile > @@ -31,6 +31,7 @@ i915-y +=3D i915_cmd_parser.o \ > i915_gpu_error.o \ > i915_irq.o \ > i915_trace_points.o \ > + intel_lrc.o \ > intel_ringbuffer.o \ > intel_uncore.o > = > diff --git a/drivers/gpu/drm/i915/intel_lrc.c b/drivers/gpu/drm/i915/inte= l_lrc.c > new file mode 100644 > index 0000000..49bb6fc > --- /dev/null > +++ b/drivers/gpu/drm/i915/intel_lrc.c > @@ -0,0 +1,42 @@ > +/* > + * Copyright =A9 2014 Intel Corporation > + * > + * Permission is hereby granted, free of charge, to any person obtaining= a > + * copy of this software and associated documentation files (the "Softwa= re"), > + * to deal in the Software without restriction, including without limita= tion > + * the rights to use, copy, modify, merge, publish, distribute, sublicen= se, > + * and/or sell copies of the Software, and to permit persons to whom the > + * Software is furnished to do so, subject to the following conditions: > + * > + * The above copyright notice and this permission notice (including the = next > + * paragraph) shall be included in all copies or substantial portions of= the > + * Software. > + * > + * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRE= SS OR > + * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILI= TY, > + * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SH= ALL > + * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR = OTHER > + * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISI= NG > + * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER D= EALINGS > + * IN THE SOFTWARE. > + * > + * Authors: > + * Ben Widawsky > + * Michel Thierry > + * Thomas Daniel > + * Oscar Mateo > + * > + */ > + > +/* Overview comments should be kerneldoc DOC: sections and pulled into our driver doc. Brad knows how to do this, see i915_cmd_parser.c. Just in case a patch later on doesn't do this ;-) -Daniel > + * GEN8 brings an expansion of the HW contexts: "Logical Ring Contexts". > + * These expanded contexts enable a number of new abilities, especially > + * "Execlists" (also implemented in this file). > + * > + * Execlists are the new method by which, on gen8+ hardware, workloads a= re > + * submitted for execution (as opposed to the legacy, ringbuffer-based, = method). > + */ > + > +#include > +#include > +#include "i915_drv.h" > -- = > 1.9.0 > = > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/intel-gfx -- = Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch