From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from eggs.gnu.org ([2001:4830:134:3::10]:58312) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1XGZiQ-0002Xd-2q for qemu-devel@nongnu.org; Sun, 10 Aug 2014 16:27:47 -0400 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71) (envelope-from ) id 1XGZiK-00039J-VA for qemu-devel@nongnu.org; Sun, 10 Aug 2014 16:27:42 -0400 Received: from mx1.redhat.com ([209.132.183.28]:23669) by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1XGZiK-000399-Nl for qemu-devel@nongnu.org; Sun, 10 Aug 2014 16:27:36 -0400 Date: Sun, 10 Aug 2014 22:27:59 +0200 From: "Michael S. Tsirkin" Message-ID: <20140810202759.GA5199@redhat.com> References: <1407307835-9692-1-git-send-email-tiejun.chen@intel.com> <1407307835-9692-4-git-send-email-tiejun.chen@intel.com> <20140806094509.GB22307@redhat.com> <53E2009E.4080107@intel.com> <20140806210714.GD22307@redhat.com> <53E2D921.8040501@intel.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <53E2D921.8040501@intel.com> Subject: Re: [Qemu-devel] [v4][PATCH 3/5] I440FX_PCI_DEVICE: add pci_type to index List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , To: "Chen, Tiejun" Cc: pbonzini@redhat.com, xen-devel@lists.xensource.com, qemu-devel@nongnu.org, stefano.stabellini@eu.citrix.com On Thu, Aug 07, 2014 at 09:40:49AM +0800, Chen, Tiejun wrote: > > > On 2014/8/7 5:07, Michael S. Tsirkin wrote: > >On Wed, Aug 06, 2014 at 06:17:02PM +0800, Chen, Tiejun wrote: > >>On 2014/8/6 17:45, Michael S. Tsirkin wrote: > >>>On Wed, Aug 06, 2014 at 02:50:33PM +0800, Tiejun Chen wrote: > >>>>We need to use this index to reuse this macro later > >>>> > >>>>Signed-off-by: Tiejun Chen > >>> > >>>Which index? > >>>Most users don't need to change. > >>>Just open-code OBJECT_CHECK where necessary, or add > >>>a new wrapper. > >> > >>Okay so what about this? > >> > >> hw:pci-host:piix: define I440FX_PCI_DEVICE_FROM_TYPE > >> > >> We need to introduce I440FX_PCI_DEVICE_FROM_TYPE to get > >> object with type, then we can reuse i440fx_init() simply. > >> > >> Signed-off-by: Tiejun Chen > >> > >>diff --git a/hw/pci-host/piix.c b/hw/pci-host/piix.c > >>index 0cd82b8..8c74653 100644 > >>--- a/hw/pci-host/piix.c > >>+++ b/hw/pci-host/piix.c > >>@@ -93,6 +93,9 @@ typedef struct PIIX3State { > >> #define I440FX_PCI_DEVICE(obj) \ > >> OBJECT_CHECK(PCII440FXState, (obj), TYPE_I440FX_PCI_DEVICE) > >> > >>+#define I440FX_PCI_DEVICE_FROM_TYPE(obj, type) \ > >>+ OBJECT_CHECK(PCII440FXState, (obj), type) > > > >This is just wrong. If you are casting to PCII440FXState, > > Why? We will have two different QOM typenames of PCII440FXStates. > > >there is no reason not to use TYPE_I440FX_PCI_DEVICE. > > As you know we already have this original, > > static const TypeInfo i440fx_info = { > .name = TYPE_I440FX_PCI_DEVICE, > .parent = TYPE_PCI_DEVICE, > .instance_size = sizeof(PCII440FXState), > .class_init = i440fx_class_init, > }; > > and in patch #4, we will register that new host bridge to IGD passthrough: > > static const TypeInfo xen_igd_passthrough_i440fx_info = { > .name = TYPE_XEN_IGD_PASSTHROUGH_I440FX_PCI_DEVICE, > .parent = TYPE_PCI_DEVICE, > .instance_size = sizeof(PCII440FXState), > .class_init = xen_igd_passthrough_i440fx_class_init, > }; My idea is to inherit TYPE_I440FX_PCI_DEVICE instead. Then you can reuse regular piix code which casts to TYPE_I440FX_PCI_DEVICE because TYPE_XEN_IGD_PASSTHROUGH_I440FX_PCI_DEVICE would be a subclass of TYPE_I440FX_PCI_DEVICE. > After that, we have two different QOM typenames of PCII440FXStates, > TYPE_I440FX_PCI_DEVICE and TYPE_XEN_IGD_PASSTHROUGH_I440FX_PCI_DEVICE, > right? So if you think we still should use this original, > > #define I440FX_PCI_DEVICE(obj) \ > OBJECT_CHECK(PCII440FXState, (obj), TYPE_I440FX_PCI_DEVICE) > > I really don't understand how to distinguish TYPE_I440FX_PCI_DEVICE and > TYPE_XEN_IGD_PASSTHROUGH_I440FX_PCI_DEVICE just with I440FX_PCI_DEVICE(obj). > > This should involve two places: > > #1: static int i440fx_initfn(PCIDevice *dev) > { > PCII440FXState *d = I440FX_PCI_DEVICE(dev); > ... > > #2: PCIBus *i440fx_init(const char *host_type, const char *pci_type, > PCII440FXState **pi440fx_state, > int *piix3_devfn, > ISABus **isa_bus, qemu_irq *pic, > MemoryRegion *address_space_mem, > MemoryRegion *address_space_io, > ram_addr_t ram_size, > ram_addr_t below_4g_mem_size, > ram_addr_t above_4g_mem_size, > MemoryRegion *pci_address_space, > MemoryRegion *ram_memory) > { > ... > PCIDevice *d; > ... > *pi440fx_state = I440FX_PCI_DEVICE(d); > ... > > So if you think I'm wrong please show me how to do just with > I440FX_PCI_DEVICE() to work all scenarios from your point of view, then I'd > like to followup yours to validate. > > Thanks > Tiejun See above. > > > >>+ > >> struct PCII440FXState { > >> /*< private >*/ > >> PCIDevice parent_obj; > >>@@ -333,7 +336,7 @@ PCIBus *i440fx_init(const char *host_type, const char > >>*pci_type, > >> qdev_init_nofail(dev); > >> > >> d = pci_create_simple(b, 0, pci_type); > >>- *pi440fx_state = I440FX_PCI_DEVICE(d); > >>+ *pi440fx_state = I440FX_PCI_DEVICE_FROM_TYPE(d, pci_type); > >> f = *pi440fx_state; > >> f->system_memory = address_space_mem; > >> f->pci_address_space = pci_address_space; > >> > >> > >>Thanks > >>Tiejun > >> > >>> > >>>>--- > >>>> hw/pci-host/piix.c | 10 +++++----- > >>>> 1 file changed, 5 insertions(+), 5 deletions(-) > >>>> > >>>>v4: > >>>> > >>>>* New patch to extend I440FX_PCI_DEVICE > >>>> > >>>>diff --git a/hw/pci-host/piix.c b/hw/pci-host/piix.c > >>>>index 0cd82b8..4330599 100644 > >>>>--- a/hw/pci-host/piix.c > >>>>+++ b/hw/pci-host/piix.c > >>>>@@ -90,8 +90,8 @@ typedef struct PIIX3State { > >>>> MemoryRegion rcr_mem; > >>>> } PIIX3State; > >>>> > >>>>-#define I440FX_PCI_DEVICE(obj) \ > >>>>- OBJECT_CHECK(PCII440FXState, (obj), TYPE_I440FX_PCI_DEVICE) > >>>>+#define I440FX_PCI_DEVICE(obj, type) \ > >>>>+ OBJECT_CHECK(PCII440FXState, (obj), type) > >>>> > >>>> struct PCII440FXState { > >>>> /*< private >*/ > >>>>@@ -155,7 +155,7 @@ static void i440fx_set_smm(int val, void *arg) > >>>> static void i440fx_write_config(PCIDevice *dev, > >>>> uint32_t address, uint32_t val, int len) > >>>> { > >>>>- PCII440FXState *d = I440FX_PCI_DEVICE(dev); > >>>>+ PCII440FXState *d = I440FX_PCI_DEVICE(dev, TYPE_I440FX_PCI_DEVICE); > >>>> > >>>> /* XXX: implement SMRAM.D_LOCK */ > >>>> pci_default_write_config(dev, address, val, len); > >>>>@@ -295,7 +295,7 @@ static void i440fx_pcihost_realize(DeviceState *dev, Error **errp) > >>>> > >>>> static int i440fx_initfn(PCIDevice *dev) > >>>> { > >>>>- PCII440FXState *d = I440FX_PCI_DEVICE(dev); > >>>>+ PCII440FXState *d = I440FX_PCI_DEVICE(dev, TYPE_I440FX_PCI_DEVICE); > >>>> > >>>> dev->config[I440FX_SMRAM] = 0x02; > >>>> > >>>>@@ -333,7 +333,7 @@ PCIBus *i440fx_init(const char *host_type, const char *pci_type, > >>>> qdev_init_nofail(dev); > >>>> > >>>> d = pci_create_simple(b, 0, pci_type); > >>>>- *pi440fx_state = I440FX_PCI_DEVICE(d); > >>>>+ *pi440fx_state = I440FX_PCI_DEVICE(d, pci_type); > >>>> f = *pi440fx_state; > >>>> f->system_memory = address_space_mem; > >>>> f->pci_address_space = pci_address_space; > >>>>-- > >>>>1.9.1 > >>> > >>> > > From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Michael S. Tsirkin" Subject: Re: [v4][PATCH 3/5] I440FX_PCI_DEVICE: add pci_type to index Date: Sun, 10 Aug 2014 22:27:59 +0200 Message-ID: <20140810202759.GA5199@redhat.com> References: <1407307835-9692-1-git-send-email-tiejun.chen@intel.com> <1407307835-9692-4-git-send-email-tiejun.chen@intel.com> <20140806094509.GB22307@redhat.com> <53E2009E.4080107@intel.com> <20140806210714.GD22307@redhat.com> <53E2D921.8040501@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Return-path: Content-Disposition: inline In-Reply-To: <53E2D921.8040501@intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: qemu-devel-bounces+gceq-qemu-devel=gmane.org@nongnu.org Sender: qemu-devel-bounces+gceq-qemu-devel=gmane.org@nongnu.org To: "Chen, Tiejun" Cc: pbonzini@redhat.com, xen-devel@lists.xensource.com, qemu-devel@nongnu.org, stefano.stabellini@eu.citrix.com List-Id: xen-devel@lists.xenproject.org On Thu, Aug 07, 2014 at 09:40:49AM +0800, Chen, Tiejun wrote: > > > On 2014/8/7 5:07, Michael S. Tsirkin wrote: > >On Wed, Aug 06, 2014 at 06:17:02PM +0800, Chen, Tiejun wrote: > >>On 2014/8/6 17:45, Michael S. Tsirkin wrote: > >>>On Wed, Aug 06, 2014 at 02:50:33PM +0800, Tiejun Chen wrote: > >>>>We need to use this index to reuse this macro later > >>>> > >>>>Signed-off-by: Tiejun Chen > >>> > >>>Which index? > >>>Most users don't need to change. > >>>Just open-code OBJECT_CHECK where necessary, or add > >>>a new wrapper. > >> > >>Okay so what about this? > >> > >> hw:pci-host:piix: define I440FX_PCI_DEVICE_FROM_TYPE > >> > >> We need to introduce I440FX_PCI_DEVICE_FROM_TYPE to get > >> object with type, then we can reuse i440fx_init() simply. > >> > >> Signed-off-by: Tiejun Chen > >> > >>diff --git a/hw/pci-host/piix.c b/hw/pci-host/piix.c > >>index 0cd82b8..8c74653 100644 > >>--- a/hw/pci-host/piix.c > >>+++ b/hw/pci-host/piix.c > >>@@ -93,6 +93,9 @@ typedef struct PIIX3State { > >> #define I440FX_PCI_DEVICE(obj) \ > >> OBJECT_CHECK(PCII440FXState, (obj), TYPE_I440FX_PCI_DEVICE) > >> > >>+#define I440FX_PCI_DEVICE_FROM_TYPE(obj, type) \ > >>+ OBJECT_CHECK(PCII440FXState, (obj), type) > > > >This is just wrong. If you are casting to PCII440FXState, > > Why? We will have two different QOM typenames of PCII440FXStates. > > >there is no reason not to use TYPE_I440FX_PCI_DEVICE. > > As you know we already have this original, > > static const TypeInfo i440fx_info = { > .name = TYPE_I440FX_PCI_DEVICE, > .parent = TYPE_PCI_DEVICE, > .instance_size = sizeof(PCII440FXState), > .class_init = i440fx_class_init, > }; > > and in patch #4, we will register that new host bridge to IGD passthrough: > > static const TypeInfo xen_igd_passthrough_i440fx_info = { > .name = TYPE_XEN_IGD_PASSTHROUGH_I440FX_PCI_DEVICE, > .parent = TYPE_PCI_DEVICE, > .instance_size = sizeof(PCII440FXState), > .class_init = xen_igd_passthrough_i440fx_class_init, > }; My idea is to inherit TYPE_I440FX_PCI_DEVICE instead. Then you can reuse regular piix code which casts to TYPE_I440FX_PCI_DEVICE because TYPE_XEN_IGD_PASSTHROUGH_I440FX_PCI_DEVICE would be a subclass of TYPE_I440FX_PCI_DEVICE. > After that, we have two different QOM typenames of PCII440FXStates, > TYPE_I440FX_PCI_DEVICE and TYPE_XEN_IGD_PASSTHROUGH_I440FX_PCI_DEVICE, > right? So if you think we still should use this original, > > #define I440FX_PCI_DEVICE(obj) \ > OBJECT_CHECK(PCII440FXState, (obj), TYPE_I440FX_PCI_DEVICE) > > I really don't understand how to distinguish TYPE_I440FX_PCI_DEVICE and > TYPE_XEN_IGD_PASSTHROUGH_I440FX_PCI_DEVICE just with I440FX_PCI_DEVICE(obj). > > This should involve two places: > > #1: static int i440fx_initfn(PCIDevice *dev) > { > PCII440FXState *d = I440FX_PCI_DEVICE(dev); > ... > > #2: PCIBus *i440fx_init(const char *host_type, const char *pci_type, > PCII440FXState **pi440fx_state, > int *piix3_devfn, > ISABus **isa_bus, qemu_irq *pic, > MemoryRegion *address_space_mem, > MemoryRegion *address_space_io, > ram_addr_t ram_size, > ram_addr_t below_4g_mem_size, > ram_addr_t above_4g_mem_size, > MemoryRegion *pci_address_space, > MemoryRegion *ram_memory) > { > ... > PCIDevice *d; > ... > *pi440fx_state = I440FX_PCI_DEVICE(d); > ... > > So if you think I'm wrong please show me how to do just with > I440FX_PCI_DEVICE() to work all scenarios from your point of view, then I'd > like to followup yours to validate. > > Thanks > Tiejun See above. > > > >>+ > >> struct PCII440FXState { > >> /*< private >*/ > >> PCIDevice parent_obj; > >>@@ -333,7 +336,7 @@ PCIBus *i440fx_init(const char *host_type, const char > >>*pci_type, > >> qdev_init_nofail(dev); > >> > >> d = pci_create_simple(b, 0, pci_type); > >>- *pi440fx_state = I440FX_PCI_DEVICE(d); > >>+ *pi440fx_state = I440FX_PCI_DEVICE_FROM_TYPE(d, pci_type); > >> f = *pi440fx_state; > >> f->system_memory = address_space_mem; > >> f->pci_address_space = pci_address_space; > >> > >> > >>Thanks > >>Tiejun > >> > >>> > >>>>--- > >>>> hw/pci-host/piix.c | 10 +++++----- > >>>> 1 file changed, 5 insertions(+), 5 deletions(-) > >>>> > >>>>v4: > >>>> > >>>>* New patch to extend I440FX_PCI_DEVICE > >>>> > >>>>diff --git a/hw/pci-host/piix.c b/hw/pci-host/piix.c > >>>>index 0cd82b8..4330599 100644 > >>>>--- a/hw/pci-host/piix.c > >>>>+++ b/hw/pci-host/piix.c > >>>>@@ -90,8 +90,8 @@ typedef struct PIIX3State { > >>>> MemoryRegion rcr_mem; > >>>> } PIIX3State; > >>>> > >>>>-#define I440FX_PCI_DEVICE(obj) \ > >>>>- OBJECT_CHECK(PCII440FXState, (obj), TYPE_I440FX_PCI_DEVICE) > >>>>+#define I440FX_PCI_DEVICE(obj, type) \ > >>>>+ OBJECT_CHECK(PCII440FXState, (obj), type) > >>>> > >>>> struct PCII440FXState { > >>>> /*< private >*/ > >>>>@@ -155,7 +155,7 @@ static void i440fx_set_smm(int val, void *arg) > >>>> static void i440fx_write_config(PCIDevice *dev, > >>>> uint32_t address, uint32_t val, int len) > >>>> { > >>>>- PCII440FXState *d = I440FX_PCI_DEVICE(dev); > >>>>+ PCII440FXState *d = I440FX_PCI_DEVICE(dev, TYPE_I440FX_PCI_DEVICE); > >>>> > >>>> /* XXX: implement SMRAM.D_LOCK */ > >>>> pci_default_write_config(dev, address, val, len); > >>>>@@ -295,7 +295,7 @@ static void i440fx_pcihost_realize(DeviceState *dev, Error **errp) > >>>> > >>>> static int i440fx_initfn(PCIDevice *dev) > >>>> { > >>>>- PCII440FXState *d = I440FX_PCI_DEVICE(dev); > >>>>+ PCII440FXState *d = I440FX_PCI_DEVICE(dev, TYPE_I440FX_PCI_DEVICE); > >>>> > >>>> dev->config[I440FX_SMRAM] = 0x02; > >>>> > >>>>@@ -333,7 +333,7 @@ PCIBus *i440fx_init(const char *host_type, const char *pci_type, > >>>> qdev_init_nofail(dev); > >>>> > >>>> d = pci_create_simple(b, 0, pci_type); > >>>>- *pi440fx_state = I440FX_PCI_DEVICE(d); > >>>>+ *pi440fx_state = I440FX_PCI_DEVICE(d, pci_type); > >>>> f = *pi440fx_state; > >>>> f->system_memory = address_space_mem; > >>>> f->pci_address_space = pci_address_space; > >>>>-- > >>>>1.9.1 > >>> > >>> > >