All of lore.kernel.org
 help / color / mirror / Atom feed
From: Antoine Tenart <antoine.tenart@free-electrons.com>
To: Peter Chen <peter.chen@freescale.com>
Cc: "Antoine Ténart" <antoine.tenart@free-electrons.com>,
	balbi@ti.com, gregkh@linuxfoundation.org, kishon@ti.com,
	stern@rowland.harvard.edu, sergei.shtylyov@cogentembedded.com,
	yoshihiro.shimoda.uh@renesas.com,
	alexandre.belloni@free-electrons.com,
	thomas.petazzoni@free-electrons.com, zmxu@marvell.com,
	jszhang@marvell.com, linux-usb@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 8/9] usb: chipidea: move usb_otg into struct ci_hdrc
Date: Fri, 29 Aug 2014 16:25:35 +0200	[thread overview]
Message-ID: <20140829142535.GA16609@kwain> (raw)
In-Reply-To: <20140826102239.GD16758@peterchendt>

Hi,

On Tue, Aug 26, 2014 at 06:22:40PM +0800, Peter Chen wrote:
> On Fri, Aug 22, 2014 at 05:50:19PM +0200, Antoine Ténart wrote:
> 
> If the common usb_otg and usb_phy struct still has another's pointer, you
> may not need to add this patch.

Except if we want to access the OTG member when not using an USB PHY.

> > diff --git a/drivers/usb/chipidea/host.c b/drivers/usb/chipidea/host.c
> > index 0b67d78dd953..0952d4adfa4c 100644
> > --- a/drivers/usb/chipidea/host.c
> > +++ b/drivers/usb/chipidea/host.c
> > @@ -85,13 +85,11 @@ static int host_start(struct ci_hdrc *ci)
> >  	if (ret) {
> >  		goto disable_reg;
> >  	} else {
> > -		struct usb_otg *otg = ci->usb_phy->otg;
> > +		struct usb_otg *otg = &ci->otg;
> >  
> >  		ci->hcd = hcd;
> > -		if (otg) {
> > -			otg->host = &hcd->self;
> > -			hcd->self.otg_port = 1;
> > -		}
> > +		otg->host = &hcd->self;
> > +		hcd->self.otg_port = 1;
> >  	}
> 
> You may need use other way to identify if otg is supported or not

How would you do that?

> > -	otg->usb_phy = ci->usb_phy;
> > -	otg->gadget = &ci->gadget;
> > -	ci->fsm.otg = otg;
> > -	ci->usb_phy->otg = ci->fsm.otg;
> > +	ci->otg.usb_phy = ci->usb_phy;
> > +	ci->fsm.otg = &ci->otg;
> >  	ci->fsm.power_up = 1;
> >  	ci->fsm.id = hw_read_otgsc(ci, OTGSC_ID) ? 1 : 0;
> >  	ci->fsm.otg->state = OTG_STATE_UNDEFINED;
> 
> Why otg->gadget and ci->usb_phy->otg initialization are deleted?
> At least, the parameters of usb_otg_state_string at your 7th patch uses it.

Sure, I'll fix this

Antoine

-- 
Antoine Ténart, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com

  reply	other threads:[~2014-08-29 14:25 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-08-22 15:50 [PATCH v3 0/9] usb: add support for the generic PHY framework Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 1/9] usb: move the OTG state from the USB PHY to the OTG structure Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 2/9] usb: rename phy to usb_phy in OTG Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 3/9] usb: add support to the generic PHY framework " Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 4/9] usb: rename phy to usb_phy in HCD Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 5/9] usb: rename gen_phy to phy " Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 6/9] usb: allow to supply the PHY in the drivers when using HCD Antoine Ténart
2014-08-22 16:53   ` Sergei Shtylyov
2014-08-22 17:08     ` Sergei Shtylyov
2014-08-22 15:50 ` [PATCH v3 7/9] usb: rename transceiver and phy to usb_phy in ChipIdea Antoine Ténart
2014-08-26 10:08   ` Peter Chen
2014-08-22 15:50 ` [PATCH v3 8/9] usb: chipidea: move usb_otg into struct ci_hdrc Antoine Ténart
2014-08-26 10:22   ` Peter Chen
2014-08-29 14:25     ` Antoine Tenart [this message]
2014-09-01  1:13       ` Peter Chen
2014-09-02  9:08         ` Antoine Tenart
2014-09-02 10:18           ` Peter Chen
2014-08-22 15:50 ` [PATCH v3 9/9] usb: chipidea: add support to the generic PHY framework in ChipIdea Antoine Ténart
2014-08-26 10:42   ` Peter Chen
2014-08-29 14:22     ` Antoine Ténart

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140829142535.GA16609@kwain \
    --to=antoine.tenart@free-electrons.com \
    --cc=alexandre.belloni@free-electrons.com \
    --cc=balbi@ti.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jszhang@marvell.com \
    --cc=kishon@ti.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=peter.chen@freescale.com \
    --cc=sergei.shtylyov@cogentembedded.com \
    --cc=stern@rowland.harvard.edu \
    --cc=thomas.petazzoni@free-electrons.com \
    --cc=yoshihiro.shimoda.uh@renesas.com \
    --cc=zmxu@marvell.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.