All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Miller <davem@davemloft.net>
To: jiri@resnulli.us
Cc: netdev@vger.kernel.org, nhorman@tuxdriver.com,
	andy@greyhouse.net, tgraf@suug.ch, dborkman@redhat.com,
	ogerlitz@mellanox.com, jesse@nicira.com, pshelar@nicira.com,
	azhou@nicira.com, ben@decadent.org.uk,
	stephen@networkplumber.org, jeffrey.t.kirsher@intel.com,
	vyasevic@redhat.com, xiyou.wangcong@gmail.com,
	john.r.fastabend@intel.com, edumazet@google.com,
	jhs@mojatatu.com, sfeldma@gmail.com, f.fainelli@gmail.com,
	roopa@cumulusnetworks.com, linville@tuxdriver.com,
	jasowang@redhat.com, ebiederm@xmission.com,
	nicolas.dichtel@6wind.com, ryazanov.s.a@gmail.com,
	buytenh@wantstofly.org, aviadr@mellanox.com, nbd@openwrt.org,
	alexei.starovoitov@gmail.com, Neil.Jerram@metaswitch.com,
	ronye@mellanox.com, simon.horman@netronome.com,
	alexander.h.duyck@redhat.com, john.ronciak@intel.com,
	mleitner@redhat.com, shrijeet@gmail.com,
	gospo@cumulusnetworks.com, bcrl@kvack.org
Subject: Re: [patch net-next 06/10] bridge: introduce fdb offloading via switchdev
Date: Fri, 07 Nov 2014 15:12:44 -0500 (EST)	[thread overview]
Message-ID: <20141107.151244.1667277873637218117.davem@davemloft.net> (raw)
In-Reply-To: <1415265610-9338-7-git-send-email-jiri@resnulli.us>

From: Jiri Pirko <jiri@resnulli.us>
Date: Thu,  6 Nov 2014 10:20:06 +0100

> @@ -132,8 +133,12 @@ static void fdb_del_hw(struct net_bridge *br, const unsigned char *addr)
>  
>  static void fdb_delete(struct net_bridge *br, struct net_bridge_fdb_entry *f)
>  {
> -	if (f->is_static)
> +	if (f->is_static) {
>  		fdb_del_hw(br, f->addr.addr);
> +		if (f->dst)
> +			netdev_sw_port_fdb_del(f->dst->dev,
> +					       f->addr.addr, f->vlan_id);
> +	}
>  
>  	hlist_del_rcu(&f->hlist);
>  	fdb_notify(br, f, RTM_DELNEIGH);

I think we should now adjust the name of fdb_*_hw() because
fdb_del_hw() sounds like a function that would do what
netdev_sw_port_fdb_del() actually does, remove the fdb entry from the
hardware.  But it just removes an address from the device's unicast
filter.

Rename them to something like fdb_*_hw_address() of fdb_*_hw_addr().

Thanks.

  reply	other threads:[~2014-11-07 20:12 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-11-06  9:20 [patch net-next 00/10] introduce rocker switch driver with hardware accelerated datapath api - phase 1: bridge fdb offload Jiri Pirko
2014-11-06  9:20 ` [patch net-next 01/10] net: rename netdev_phys_port_id to more generic name Jiri Pirko
2014-11-06  9:20 ` [patch net-next 02/10] net: introduce generic switch devices support Jiri Pirko
2014-11-06  9:20 ` [patch net-next 03/10] rtnl: expose physical switch id for particular device Jiri Pirko
2014-11-06  9:20 ` [patch net-next 04/10] net-sysfs: " Jiri Pirko
2014-11-06  9:20 ` [patch net-next 05/10] rocker: introduce rocker switch driver Jiri Pirko
2014-11-07 20:08   ` David Miller
2014-11-06  9:20 ` [patch net-next 06/10] bridge: introduce fdb offloading via switchdev Jiri Pirko
2014-11-07 20:12   ` David Miller [this message]
2014-11-06  9:20 ` [patch net-next 07/10] bridge: call netdev_sw_port_stp_update when bridge port STP status changes Jiri Pirko
2014-11-06 16:59   ` Florian Fainelli
2014-11-06 18:57     ` Scott Feldman
     [not found]     ` <CAE4R7bBarGQPsuM5js20RwPLOBF24AtiiHM-f2EvkHNObp7NDQ@mail.gmail.com>
2014-11-07  8:32       ` Jiri Pirko
2014-11-06  9:20 ` [patch net-next 08/10] bridge: add API to notify bridge driver of learned FBD on offloaded device Jiri Pirko
2014-11-06  9:20 ` [patch net-next 09/10] rocker: implement rocker ofdpa flow table manipulation Jiri Pirko
2014-11-07 20:16   ` David Miller
2014-11-07 21:15     ` [PATCH] checkpatch: Add --strict preference for #defines using BIT(foo) Joe Perches
2014-11-09  9:50       ` Jiri Pirko
2014-11-09 14:22         ` Joe Perches
2014-11-10 23:36       ` Andrew Morton
2014-11-10 23:53         ` Joe Perches
2014-11-06  9:20 ` [patch net-next 10/10] rocker: implement L2 bridge offloading Jiri Pirko
2014-11-07 20:16   ` David Miller
2014-11-06 14:11 ` [patch net-next 00/10] introduce rocker switch driver with hardware accelerated datapath api - phase 1: bridge fdb offload Thomas Graf
2014-11-06 14:32   ` Jiri Pirko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20141107.151244.1667277873637218117.davem@davemloft.net \
    --to=davem@davemloft.net \
    --cc=Neil.Jerram@metaswitch.com \
    --cc=alexander.h.duyck@redhat.com \
    --cc=alexei.starovoitov@gmail.com \
    --cc=andy@greyhouse.net \
    --cc=aviadr@mellanox.com \
    --cc=azhou@nicira.com \
    --cc=bcrl@kvack.org \
    --cc=ben@decadent.org.uk \
    --cc=buytenh@wantstofly.org \
    --cc=dborkman@redhat.com \
    --cc=ebiederm@xmission.com \
    --cc=edumazet@google.com \
    --cc=f.fainelli@gmail.com \
    --cc=gospo@cumulusnetworks.com \
    --cc=jasowang@redhat.com \
    --cc=jeffrey.t.kirsher@intel.com \
    --cc=jesse@nicira.com \
    --cc=jhs@mojatatu.com \
    --cc=jiri@resnulli.us \
    --cc=john.r.fastabend@intel.com \
    --cc=john.ronciak@intel.com \
    --cc=linville@tuxdriver.com \
    --cc=mleitner@redhat.com \
    --cc=nbd@openwrt.org \
    --cc=netdev@vger.kernel.org \
    --cc=nhorman@tuxdriver.com \
    --cc=nicolas.dichtel@6wind.com \
    --cc=ogerlitz@mellanox.com \
    --cc=pshelar@nicira.com \
    --cc=ronye@mellanox.com \
    --cc=roopa@cumulusnetworks.com \
    --cc=ryazanov.s.a@gmail.com \
    --cc=sfeldma@gmail.com \
    --cc=shrijeet@gmail.com \
    --cc=simon.horman@netronome.com \
    --cc=stephen@networkplumber.org \
    --cc=tgraf@suug.ch \
    --cc=vyasevic@redhat.com \
    --cc=xiyou.wangcong@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.