From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757255AbbDVXDA (ORCPT ); Wed, 22 Apr 2015 19:03:00 -0400 Received: from mail-wi0-f180.google.com ([209.85.212.180]:36182 "EHLO mail-wi0-f180.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753341AbbDVXC7 (ORCPT ); Wed, 22 Apr 2015 19:02:59 -0400 Date: Thu, 23 Apr 2015 01:02:55 +0200 From: Frederic Weisbecker To: Tejun Heo Cc: Lai Jiangshan , linux-kernel@vger.kernel.org, Christoph Lameter , Kevin Hilman , Mike Galbraith , "Paul E. McKenney" , Viresh Kumar Subject: Re: [PATCH 3/3 V7] workqueue: Allow modifying low level unbound workqueue cpumask Message-ID: <20150422230253.GA20038@lerouge> References: <1427973282-3052-1-git-send-email-laijs@cn.fujitsu.com> <1428405998-3102-1-git-send-email-laijs@cn.fujitsu.com> <1428405998-3102-3-git-send-email-laijs@cn.fujitsu.com> <20150422193935.GG10738@htj.duckdns.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20150422193935.GG10738@htj.duckdns.org> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Apr 22, 2015 at 03:39:35PM -0400, Tejun Heo wrote: > Hello, > > Generally looks good to me. Some minor things below. > > On Tue, Apr 07, 2015 at 07:26:37PM +0800, Lai Jiangshan wrote: > > diff --git a/kernel/workqueue.c b/kernel/workqueue.c > > index cbccf5d..557612e 100644 > > --- a/kernel/workqueue.c > > +++ b/kernel/workqueue.c > > @@ -299,7 +299,7 @@ static DEFINE_SPINLOCK(wq_mayday_lock); /* protects wq->maydays list */ > > static LIST_HEAD(workqueues); /* PR: list of all workqueues */ > > static bool workqueue_freezing; /* PL: have wqs started freezing? */ > > > > -static cpumask_var_t wq_unbound_global_cpumask; > > +static cpumask_var_t wq_unbound_global_cpumask; /* PL: low level cpumask for all unbound wqs */ > > Are we set on this variable name? What would we lose by naming it > wq_unbound_cpumask or wq_cpu_possible_mask? I like wq_unbound_cpumask personally. In fact I like to have "unbound" inside to express what's concerned here. I like wq_cpu_possible_mask too but unfortunately it suggests it's about all workqueues (including per cpu ones) while it's not.