All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jeff Cody <jcody@redhat.com>
To: Alberto Garcia <berto@igalia.com>
Cc: Kevin Wolf <kwolf@redhat.com>,
	Stefan Hajnoczi <stefanha@redhat.com>,
	qemu-devel@nongnu.org, qemu-block@nongnu.org,
	Max Reitz <mreitz@redhat.com>
Subject: Re: [Qemu-devel] [Qemu-block] [PATCH v7 2/5] block: rename BlockdevSnapshot to BlockdevSnapshotSync
Date: Tue, 13 Oct 2015 18:47:07 -0400	[thread overview]
Message-ID: <20151013224707.GP11943@localhost.localdomain> (raw)
In-Reply-To: <d8a64f5e9f1c88aa27e868a44d7d920e88e37073.1444640617.git.berto@igalia.com>

On Mon, Oct 12, 2015 at 12:16:14PM +0300, Alberto Garcia wrote:
> We will introduce the 'blockdev-snapshot' command that will require
> its own struct for the parameters, so we need to rename this one in
> order to avoid name clashes.
> 
> Signed-off-by: Alberto Garcia <berto@igalia.com>
> Reviewed-by: Eric Blake <eblake@redhat.com>
> Reviewed-by: Max Reitz <mreitz@redhat.com>
> Reviewed-by: Kevin Wolf <kwolf@redhat.com>
> ---
>  blockdev.c           | 2 +-
>  qapi-schema.json     | 2 +-
>  qapi/block-core.json | 8 ++++----
>  3 files changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/blockdev.c b/blockdev.c
> index 0898d1f..12741a0 100644
> --- a/blockdev.c
> +++ b/blockdev.c
> @@ -1166,7 +1166,7 @@ void qmp_blockdev_snapshot_sync(bool has_device, const char *device,
>                                  bool has_format, const char *format,
>                                  bool has_mode, NewImageMode mode, Error **errp)
>  {
> -    BlockdevSnapshot snapshot = {
> +    BlockdevSnapshotSync snapshot = {
>          .has_device = has_device,
>          .device = (char *) device,
>          .has_node_name = has_node_name,
> diff --git a/qapi-schema.json b/qapi-schema.json
> index a05794e..65701dc 100644
> --- a/qapi-schema.json
> +++ b/qapi-schema.json
> @@ -1534,7 +1534,7 @@
>  ##
>  { 'union': 'TransactionAction',
>    'data': {
> -       'blockdev-snapshot-sync': 'BlockdevSnapshot',
> +       'blockdev-snapshot-sync': 'BlockdevSnapshotSync',
>         'drive-backup': 'DriveBackup',
>         'blockdev-backup': 'BlockdevBackup',
>         'abort': 'Abort',
> diff --git a/qapi/block-core.json b/qapi/block-core.json
> index 5f12af7..6b5ac02 100644
> --- a/qapi/block-core.json
> +++ b/qapi/block-core.json
> @@ -682,7 +682,7 @@
>    'data': [ 'existing', 'absolute-paths' ] }
>  
>  ##
> -# @BlockdevSnapshot
> +# @BlockdevSnapshotSync
>  #
>  # Either @device or @node-name must be set but not both.
>  #
> @@ -699,7 +699,7 @@
>  # @mode: #optional whether and how QEMU should create a new image, default is
>  #        'absolute-paths'.
>  ##
> -{ 'struct': 'BlockdevSnapshot',
> +{ 'struct': 'BlockdevSnapshotSync',
>    'data': { '*device': 'str', '*node-name': 'str',
>              'snapshot-file': 'str', '*snapshot-node-name': 'str',
>              '*format': 'str', '*mode': 'NewImageMode' } }
> @@ -790,7 +790,7 @@
>  #
>  # Generates a synchronous snapshot of a block device.
>  #
> -# For the arguments, see the documentation of BlockdevSnapshot.
> +# For the arguments, see the documentation of BlockdevSnapshotSync.
>  #
>  # Returns: nothing on success
>  #          If @device is not a valid block device, DeviceNotFound
> @@ -798,7 +798,7 @@
>  # Since 0.14.0
>  ##
>  { 'command': 'blockdev-snapshot-sync',
> -  'data': 'BlockdevSnapshot' }
> +  'data': 'BlockdevSnapshotSync' }
>  
>  ##
>  # @change-backing-file
> -- 
> 2.6.1
> 
> 
Reviewed-by: Jeff Cody <jcody@redhat.com>

  reply	other threads:[~2015-10-13 22:47 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-10-12  9:16 [Qemu-devel] [PATCH v7 0/5] Add 'blockdev-snapshot' command Alberto Garcia
2015-10-12  9:16 ` [Qemu-devel] [PATCH v7 1/5] block: check for existing device IDs in external_snapshot_prepare() Alberto Garcia
2015-10-12 20:20   ` Max Reitz
2015-10-13 22:45   ` [Qemu-devel] [Qemu-block] " Jeff Cody
2015-10-12  9:16 ` [Qemu-devel] [PATCH v7 2/5] block: rename BlockdevSnapshot to BlockdevSnapshotSync Alberto Garcia
2015-10-13 22:47   ` Jeff Cody [this message]
2015-10-12  9:16 ` [Qemu-devel] [PATCH v7 3/5] block: support passing 'backing': '' to 'blockdev-add' Alberto Garcia
2015-10-13 22:47   ` [Qemu-devel] [Qemu-block] " Jeff Cody
2015-10-12  9:16 ` [Qemu-devel] [PATCH v7 4/5] block: add a 'blockdev-snapshot' QMP command Alberto Garcia
2015-10-12 20:29   ` Max Reitz
2015-10-13  5:45     ` Alberto Garcia
2015-10-12  9:16 ` [Qemu-devel] [PATCH v7 5/5] block: add tests for the 'blockdev-snapshot' command Alberto Garcia
2015-10-13 22:54   ` [Qemu-devel] [Qemu-block] " Jeff Cody

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20151013224707.GP11943@localhost.localdomain \
    --to=jcody@redhat.com \
    --cc=berto@igalia.com \
    --cc=kwolf@redhat.com \
    --cc=mreitz@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    --cc=stefanha@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.