From mboxrd@z Thu Jan 1 00:00:00 1970 From: Yuanhan Liu Subject: Re: [PATCH 2/2] virtio: clean up space checks on xmit Date: Fri, 4 Dec 2015 11:28:58 +0800 Message-ID: <20151204032858.GB29571@yliu-dev.sh.intel.com> References: <1449191574-14629-1-git-send-email-stephen@networkplumber.org> <1449191574-14629-3-git-send-email-stephen@networkplumber.org> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: dev@dpdk.org To: Stephen Hemminger Return-path: Received: from mga09.intel.com (mga09.intel.com [134.134.136.24]) by dpdk.org (Postfix) with ESMTP id 019BE5683 for ; Fri, 4 Dec 2015 04:28:43 +0100 (CET) Content-Disposition: inline In-Reply-To: <1449191574-14629-3-git-send-email-stephen@networkplumber.org> List-Id: patches and discussions about DPDK List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Thu, Dec 03, 2015 at 05:12:54PM -0800, Stephen Hemminger wrote: > The space check for transmit ring only needs a single conditional. > I.e only need to recheck for space if there was no space in first check. > > This can help performance and simplifies loop. This is a good cleanup. Besides that, I have few minor comments below. > > Signed-off-by: Stephen Hemminger > --- > drivers/net/virtio/virtio_rxtx.c | 68 +++++++++++++++++----------------------- > 1 file changed, 29 insertions(+), 39 deletions(-) > > diff --git a/drivers/net/virtio/virtio_rxtx.c b/drivers/net/virtio/virtio_rxtx.c > index 466fee6..7cb932a 100644 > --- a/drivers/net/virtio/virtio_rxtx.c > +++ b/drivers/net/virtio/virtio_rxtx.c > @@ -832,7 +832,6 @@ uint16_t > virtio_xmit_pkts(void *tx_queue, struct rte_mbuf **tx_pkts, uint16_t nb_pkts) > { > struct virtqueue *txvq = tx_queue; > - struct rte_mbuf *txm; > uint16_t nb_used, nb_tx; > int error; > > @@ -846,58 +845,49 @@ virtio_xmit_pkts(void *tx_queue, struct rte_mbuf **tx_pkts, uint16_t nb_pkts) > if (likely(nb_used > txvq->vq_nentries - txvq->vq_free_thresh)) > virtio_xmit_cleanup(txvq, nb_used); > > - nb_tx = 0; > - > - while (nb_tx < nb_pkts) { > + for (nb_tx = 0; nb_tx < nb_pkts; nb_tx++) { > + struct rte_mbuf *txm = tx_pkts[nb_tx]; > /* Need one more descriptor for virtio header. */ > - int need = tx_pkts[nb_tx]->nb_segs - txvq->vq_free_cnt + 1; > + int need = txm->nb_segs - txvq->vq_free_cnt + 1; While reviewing the code, I found the var name `need' is not properly taken. Maybe `need_cleanup' is better, and it's better to be defined as bool type. What do you think of that? (And yes, it has nothing to do with your patch, I just found it we can rename it to a better name to improve the code readability a bit. If you agree, would you submit a patch, or should I do it?) > > - /*Positive value indicates it need free vring descriptors */ > + /* Positive value indicates it need free vring descriptors */ > if (unlikely(need > 0)) { > nb_used = VIRTQUEUE_NUSED(txvq); > virtio_rmb(); > need = RTE_MIN(need, (int)nb_used); > > virtio_xmit_cleanup(txvq, need); > - need = (int)tx_pkts[nb_tx]->nb_segs - > - txvq->vq_free_cnt + 1; > + need = txm->nb_segs - txvq->vq_free_cnt + 1; > + if (unlikely(need > 0)) { > + PMD_TX_LOG(ERR, > + "No free tx descriptors to transmit"); > + break; > + } ^ Minor nit: I found a leading white space there. Otherwise, it looks good: Acked-by: Yuanhan Liu --yliu