On Tue, Jan 05, 2016 at 02:36:36PM +0000, Charles Keepax wrote: > On Tue, Jan 05, 2016 at 02:20:25PM +0000, Mark Brown wrote: > > That's not an interrupt acknowlegement, it's a request for more data. > Well a request to let us know about there being more data. We will > keep consuming data as it is generated until we reach a point where > we have less than one fragment, then we set this and wait for an > IRQ to say we have more than a fragment again. Whatever it is it's not an interrupt being acknowledged, if anything it's more one being unmasked but it seems like it's probably just a general software channel. > > > I could perhaps rename the function to > > > wm_adsp_buffer_request_irq? and buf->irq_ack to buf->irq_count? > > > That might make the usage a little more clear. > > That might be a bit clearer, yes - it looks like this is a mailbox on > > the DSP that you're kicking? > Effectively you could think of it as a mailbox, I haven't looked > much at the framework but I suspect it is a little overkill for > what we want to do here. I'm not suggesting using the framework, I'm saying don't describe it as an interrupt when it's clearly not one and does things that would be bugs if it were actually an interrupt.