From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755281AbcDKNSc (ORCPT ); Mon, 11 Apr 2016 09:18:32 -0400 Received: from mail-wm0-f45.google.com ([74.125.82.45]:35559 "EHLO mail-wm0-f45.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754893AbcDKNSa (ORCPT ); Mon, 11 Apr 2016 09:18:30 -0400 Date: Mon, 11 Apr 2016 15:18:16 +0200 From: Frederic Weisbecker To: Peter Zijlstra Cc: LKML , Byungchul Park , Chris Metcalf , Thomas Gleixner , Luiz Capitulino , Christoph Lameter , "Paul E . McKenney" , Mike Galbraith , Rik van Riel , Ingo Molnar Subject: Re: [PATCH 3/3] sched: Optimize !CONFIG_NO_HZ_COMMON cpu load updates Message-ID: <20160411131814.GA22628@lerouge> References: <1460077633-23431-1-git-send-email-fweisbec@gmail.com> <1460077633-23431-4-git-send-email-fweisbec@gmail.com> <20160408104821.GM3448@twins.programming.kicks-ass.net> <20160408125521.GC24956@lerouge> <20160408174414.GE1087@worktop> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20160408174414.GE1087@worktop> User-Agent: Mutt/1.5.24 (2015-08-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Apr 08, 2016 at 07:44:14PM +0200, Peter Zijlstra wrote: > On Fri, Apr 08, 2016 at 02:55:22PM +0200, Frederic Weisbecker wrote: > > > > @@ -4540,17 +4568,8 @@ static void cpu_load_update(struct rq *this_rq, unsigned long this_load, > > > > > > > > /* scale is effectively 1 << i now, and >> i divides by scale */ > > > > > > > > - old_load = this_rq->cpu_load[i]; > > > #ifdef CONFIG_NO_HZ_COMMON > > > > - old_load = decay_load_missed(old_load, pending_updates - 1, i); > > > > - if (tickless_load) { > > > > - old_load -= decay_load_missed(tickless_load, pending_updates - 1, i); > > > > - /* > > > > - * old_load can never be a negative value because a > > > > - * decayed tickless_load cannot be greater than the > > > > - * original tickless_load. > > > > - */ > > > > - old_load += tickless_load; > > > > - } > > > #endif > > > > Ah sure, if you prefer it that way, I can do that. > > Yes please. I normally favour the thing you did, but here it makes > tricky code that much harder to read. So I tried and it warns about the unused variable tickless_load, so I would need two scattered ifdeffery in the function: @@ -4528,7 +4529,9 @@ decay_load_missed(unsigned long load, unsigned long missed_updates, int idx) static void cpu_load_update(struct rq *this_rq, unsigned long this_load, unsigned long pending_updates) { +#ifdef CONFIG_NO_HZ_COMMON unsigned long tickless_load = this_rq->cpu_load[0]; +#endif int i, scale; this_rq->nr_load_updates++; @@ -4541,6 +4544,7 @@ static void cpu_load_update(struct rq *this_rq, unsigned long this_load, /* scale is effectively 1 << i now, and >> i divides by scale */ old_load = this_rq->cpu_load[i]; +#ifdef CONFIG_NO_HZ_COMMON old_load = decay_load_missed(old_load, pending_updates - 1, i); if (tickless_load) { old_load -= decay_load_missed(tickless_load, pending_updates - 1, i); @@ -4551,6 +4555,7 @@ static void cpu_load_update(struct rq *this_rq, unsigned long this_load, */ old_load += tickless_load; } +#endif new_load = this_load; /* * Round up the averaging division if load is increasing. This Are you still sure you don't want the ifdeffed inline function? Thanks.