All of lore.kernel.org
 help / color / mirror / Atom feed
From: Vinod Koul <vinod.koul@intel.com>
To: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
Cc: alsa-devel@alsa-project.org, patches@opensource.wolfsonmicro.com,
	lgirdwood@gmail.com, tiwai@suse.com, broonie@kernel.org
Subject: Re: [PATCH v4 2/4] ALSA: compress: Add function to indicate the stream has gone bad
Date: Tue, 19 Apr 2016 18:34:03 +0530	[thread overview]
Message-ID: <20160419130403.GO2274@localhost> (raw)
In-Reply-To: <20160419083140.GA1581@localhost.localdomain>

On Tue, Apr 19, 2016 at 09:31:40AM +0100, Charles Keepax wrote:
> On Tue, Apr 19, 2016 at 11:55:52AM +0530, Vinod Koul wrote:
> > On Tue, Apr 12, 2016 at 11:32:07AM +0100, Charles Keepax wrote:
> > 
> > > + * @state: state to transition the stream to
> > > + *
> > > + * Stop the stream and set its state.
> > > + *
> > > + * Should be called with compressed device lock held.
> > > + */
> > > +int snd_compr_stop_error(struct snd_compr_stream *stream,
> > > +			 snd_pcm_state_t state)
> > 
> > Do we want the state as an agument here, since we are invoking stop, it
> > should transistion to the stopped state
> > 
> 
> This was my interpretation of this comment of yours:
> 
> "Also should this be made a generic stop rather than
> xrun. Perhaps the reason can be specified as an argument."
> 
> If you clarify what you are looking for I am happy to respin. We
> should set the state to something that indicates there has
> been an error, such that things are distinct from a normal
> stop operation. Personally I liked simply calling the function
> snd_compr_stop_xrun and always setting it to xrun and it matches
> what the PCM framework does. So I am happy to go back to that if
> you prefer?

Your interpretation was right, but there is no point in setting xrun as this
will be essentially overwritten when you invoke the snd_compr_stop()

It does set it back to setup state..

Thanks
-- 
~Vinod

  reply	other threads:[~2016-04-19 12:59 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-04-12 10:32 [PATCH v4 0/4] Propagate errors out from compressed streams Charles Keepax
2016-04-12 10:32 ` [PATCH v4 1/4] ALSA: compress: Replace complex if statement with switch Charles Keepax
2016-04-19  6:21   ` Vinod Koul
2016-04-12 10:32 ` [PATCH v4 2/4] ALSA: compress: Add function to indicate the stream has gone bad Charles Keepax
2016-04-19  6:25   ` Vinod Koul
2016-04-19  8:31     ` Charles Keepax
2016-04-19 13:04       ` Vinod Koul [this message]
2016-04-19 16:52         ` Charles Keepax
2016-04-12 10:32 ` [PATCH v4 3/4] ASoC: wm_adsp: Use new snd_compr_stop_error to signal stream failure Charles Keepax
2016-04-12 10:32 ` [PATCH v4 4/4] ASoC: compress: Pass error out of soc_compr_pointer Charles Keepax
2016-04-19  6:26   ` Vinod Koul

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160419130403.GO2274@localhost \
    --to=vinod.koul@intel.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=ckeepax@opensource.wolfsonmicro.com \
    --cc=lgirdwood@gmail.com \
    --cc=patches@opensource.wolfsonmicro.com \
    --cc=tiwai@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.