All of lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel@ffwll.ch>
To: Chris Wilson <chris@chris-wilson.co.uk>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>,
	intel-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org
Subject: Re: [PATCH v2 02/21] drm: Add a callback from connector registering
Date: Wed, 1 Jun 2016 11:57:09 +0200	[thread overview]
Message-ID: <20160601095709.GT7231@phenom.ffwll.local> (raw)
In-Reply-To: <1464597519-16659-3-git-send-email-chris@chris-wilson.co.uk>

On Mon, May 30, 2016 at 09:38:20AM +0100, Chris Wilson wrote:
> If a driver wants to more precisely control its initialisation and in
> particular, defer registering its interfaces with userspace until after
> everything is setup, it also needs to defer registering the connectors.
> As some devices need more work during registration, add a callback so
> that drivers can do additional work if required for a connector.
> 
> Correspondingly, we also require an unregister callback.
> 
> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
> Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
> Cc: dri-devel@lists.freedesktop.org

tbh I'd call these hooks simply register/unregister. There shouldn't be
any need for ordering every with interface registration/unregistartion,
assuming drivers don't fumble things.

Besides naming&kerneldoc (see below) lgtm as an idea.
-Daniel

> ---
>  drivers/gpu/drm/drm_crtc.c | 18 ++++++++++++++++--
>  include/drm/drm_crtc.h     | 25 +++++++++++++++++++++++++
>  2 files changed, 41 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
> index d2a6d958ca76..81641544ac3e 100644
> --- a/drivers/gpu/drm/drm_crtc.c
> +++ b/drivers/gpu/drm/drm_crtc.c
> @@ -1036,13 +1036,24 @@ int drm_connector_register(struct drm_connector *connector)
>  
>  	ret = drm_debugfs_connector_add(connector);
>  	if (ret) {
> -		drm_sysfs_connector_remove(connector);
> -		return ret;
> +		goto err_sysfs;
> +	}
> +
> +	if (connector->funcs->late_register) {
> +		ret = connector->funcs->late_register(connector);
> +		if (ret)
> +			goto err_debugfs;
>  	}
>  
>  	drm_mode_object_register(connector->dev, &connector->base);
>  
>  	return 0;
> +
> +err_debugfs:
> +	drm_debugfs_connector_remove(connector);
> +err_sysfs:
> +	drm_sysfs_connector_remove(connector);
> +	return ret;
>  }
>  EXPORT_SYMBOL(drm_connector_register);
>  
> @@ -1054,6 +1065,9 @@ EXPORT_SYMBOL(drm_connector_register);
>   */
>  void drm_connector_unregister(struct drm_connector *connector)
>  {
> +	if (connector->funcs->early_unregister)
> +		connector->funcs->early_unregister(connector);
> +
>  	drm_sysfs_connector_remove(connector);
>  	drm_debugfs_connector_remove(connector);
>  }
> diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h
> index d1559cd04e3d..77b775cff4e7 100644
> --- a/include/drm/drm_crtc.h
> +++ b/include/drm/drm_crtc.h
> @@ -926,6 +926,31 @@ struct drm_connector_funcs {
>  			     uint64_t val);
>  
>  	/**
> +	 * @late_register:
> +	 *
> +	 * Register the connector with userspace, called from
> +	 * drm_connector_register. This should be called after driver
> +	 * load during its registration phase. All actions such as registering
> +	 * with auxiliary devices (such as drm_dp_aux_register) should be done
> +	 * during this callback. A simple guideline is that everything added
> +	 * from this callback should be removed during early_unregister (and
> +	 * vice versa).

Slight bikeshedding of the kerneldoc:

"This optional hook can be used to register additional userspace
interfaces attached to the connector, like backlight control, i2c, dp aux
or similar interfaces. It is called from drm_connector_register() when
registering all the core drm connector interfaces. Everything added from
this callback should be unregistered in the unregister() callback.

"Returns:

"0 on success or a negative failure code on error."

Similar bikeshed with unregister, i.e. state that it is optional, and that
is just to unregister additional interfaces.
> +	 *
> +	 */
> +	int (*late_register)(struct drm_connector *connector);
> +
> +	/**
> +	 * @early_unregister:
> +	 *
> +	 * Unregister the connector with userspace, called from
> +	 * drm_connector_unregister. This is called early in the driver

Please add () to drm_connector_unregister() so you end up with a hyperlink.

> +	 * unload sequence to disable userspace access before data
> +	 * structures are torndown.  A simple guideline is that this callback
> +	 * should remove everything added during late_register (and vice versa).
> +	 */
> +	void (*early_unregister)(struct drm_connector *connector);
> +
> +	/**
>  	 * @destroy:
>  	 *
>  	 * Clean up connector resources. This is called at driver unload time
> -- 
> 2.8.1
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2016-06-01  9:57 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-05-30  8:38 Reordering debugfs registration vs driver loader, take 2 Chris Wilson
2016-05-30  8:38 ` [PATCH v2 01/21] drm: Export drm_dev_init() for subclassing Chris Wilson
2016-06-01 10:01   ` Daniel Vetter
2016-06-01 10:07     ` Daniel Vetter
2016-06-01 10:29     ` Chris Wilson
2016-05-30  8:38 ` [PATCH v2 02/21] drm: Add a callback from connector registering Chris Wilson
2016-06-01  9:57   ` Daniel Vetter [this message]
2016-06-01 10:38     ` Chris Wilson
2016-06-01 14:42       ` Daniel Vetter
2016-05-30  8:38 ` [PATCH v2 03/21] drm: Make drm_connector_register() safe against multiple calls Chris Wilson
2016-06-01  9:45   ` Daniel Vetter
2016-05-30  8:38 ` [PATCH v2 04/21] drm: Automatically unregister the connector during cleanup Chris Wilson
2016-06-01  9:45   ` Daniel Vetter
2016-05-30  8:38 ` [PATCH v2 05/21] drm: Minimally initialise drm_dp_aux Chris Wilson
2016-06-01  9:49   ` Daniel Vetter
2016-06-01  9:54     ` Chris Wilson
2016-05-30  8:38 ` [PATCH v2 06/21] drm/i915: Perform async fbdev initialisation much later Chris Wilson
2016-05-30  8:38 ` [PATCH v2 07/21] drm/i915: Make panel/backlight safe to setup/cleanup multiple times Chris Wilson
2016-05-30  8:38 ` [PATCH v2 08/21] drm/i915: Move panel's pipe from backlight setup to init Chris Wilson
2016-05-30  8:38 ` [PATCH v2 09/21] drm/i915: Move intel_connector->unregister to connector->early_unregister Chris Wilson
2016-05-30  8:38 ` [PATCH v2 10/21] drm/i915: Move backlight unregistration to connector unregistration Chris Wilson
2016-05-30  8:38 ` [PATCH v2 11/21] drm/i915: Move registration actions to connector->late_register Chris Wilson
2016-05-30  8:38 ` [PATCH v2 12/21] drm/i915: Move backlight setup to connector registration Chris Wilson
2016-05-30  8:38 ` [PATCH v2 13/21] drm/i915: Move backlight registration " Chris Wilson
2016-05-30  8:38 ` [PATCH v2 14/21] drm/i915: Move connector registration to driver registration Chris Wilson
2016-05-30  8:38 ` [PATCH v2 15/21] drm/i915: Register debugfs interface last Chris Wilson
2016-05-30  8:38 ` [PATCH v2 16/21] drm/i915: Demidlayer driver loading Chris Wilson
2016-05-30  8:38 ` [PATCH v2 17/21] drm/i915: Demidlayer driver unloading Chris Wilson
2016-05-30  8:38 ` [PATCH v2 18/21] drm/i915: Start exploiting drm_device subclassing Chris Wilson
2016-05-30 10:38   ` Joonas Lahtinen
2016-05-30  8:38 ` [PATCH v2 19/21] drm/i915: Merge i915_dma.c into i915_drv.c Chris Wilson
2016-05-30  8:38 ` [PATCH v2 20/21] drm/i915: Split out the PCI driver interface to i915_pci.c Chris Wilson
2016-05-30  8:38 ` [PATCH v2 21/21] drm/i915: Move module init/exit " Chris Wilson
2016-05-30  8:51 ` ✓ Ro.CI.BAT: success for series starting with [v2,01/21] drm: Export drm_dev_init() for subclassing Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160601095709.GT7231@phenom.ffwll.local \
    --to=daniel@ffwll.ch \
    --cc=chris@chris-wilson.co.uk \
    --cc=daniel.vetter@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.