From mboxrd@z Thu Jan 1 00:00:00 1970 From: Sivaram Nair Subject: Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox Date: Thu, 7 Jul 2016 11:44:29 -0700 Message-ID: <20160707184429.GA26114@kickseed.nvidia.com> References: <20160705090431.5852-1-josephl@nvidia.com> <20160705090431.5852-2-josephl@nvidia.com> <20160707181356.GA6864@kickseed.nvidia.com> <577EA0D6.9020308@wwwdotorg.org> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Return-path: In-Reply-To: <577EA0D6.9020308-3lzwWm7+Weoh9ZMKESR00Q@public.gmane.org> Content-Disposition: inline Sender: linux-tegra-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org To: Stephen Warren Cc: Joseph Lo , Thierry Reding , Alexandre Courbot , linux-tegra-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org, Rob Herring , Mark Rutland , Peter De Schrijver , Matthew Longnecker , devicetree-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, Jassi Brar , linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, Catalin Marinas , Will Deacon List-Id: linux-tegra@vger.kernel.org On Thu, Jul 07, 2016 at 12:35:02PM -0600, Stephen Warren wrote: > On 07/07/2016 12:13 PM, Sivaram Nair wrote: > >On Tue, Jul 05, 2016 at 05:04:22PM +0800, Joseph Lo wrote: > >>Add DT binding for the Hardware Synchronization Primitives (HSP). The > >>HSP is designed for the processors to share resources and communicate > >>together. It provides a set of hardware synchronization primitives for > >>interprocessor communication. So the interprocessor communication (IPC) > >>protocols can use hardware synchronization primitive, when operating > >>between two processors not in an SMP relationship. > > >>diff --git a/include/dt-bindings/mailbox/tegra186-hsp.h b/include/dt-bindings/mailbox/tegra186-hsp.h > > >>+#define HSP_MBOX_TYPE_DB 0x0 > >>+#define HSP_MBOX_TYPE_SM 0x1 > >>+#define HSP_MBOX_TYPE_SS 0x2 > >>+#define HSP_MBOX_TYPE_AS 0x3 > >>+ > >>+#define HSP_DB_MASTER_CCPLEX 17 > >>+#define HSP_DB_MASTER_BPMP 19 > >>+ > >>+#define HSP_MBOX_ID(type, ID) \ > >>+ (HSP_MBOX_TYPE_##type << 16 | ID) > > > >It will be nicer if you avoid the macro glue magic '##' for 'type'. I > >would also suggest to use braces around 'type' and 'ID'. > > This technique been used without issue in quite a few other places > without issue, and has the benefit of simplifying the text wherever > the macro is used. What issue do you foresee? It improves readability where HSP_MBOX_ID is used (in tegra186.dtsi file in this case) - but consider this as a cosmetic comment. > > BTW, if this patch does need reposting, I'd suggest s/ID/id/ since > macro parameters are usually lower-case. From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932258AbcGGSoj (ORCPT ); Thu, 7 Jul 2016 14:44:39 -0400 Received: from hqemgate16.nvidia.com ([216.228.121.65]:3215 "EHLO hqemgate16.nvidia.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752774AbcGGSob (ORCPT ); Thu, 7 Jul 2016 14:44:31 -0400 X-PGP-Universal: processed; by hqnvupgp08.nvidia.com on Thu, 07 Jul 2016 11:42:49 -0700 Date: Thu, 7 Jul 2016 11:44:29 -0700 From: Sivaram Nair To: Stephen Warren CC: Joseph Lo , Thierry Reding , Alexandre Courbot , , , Rob Herring , Mark Rutland , Peter De Schrijver , Matthew Longnecker , , Jassi Brar , , Catalin Marinas , Will Deacon Subject: Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox Message-ID: <20160707184429.GA26114@kickseed.nvidia.com> References: <20160705090431.5852-1-josephl@nvidia.com> <20160705090431.5852-2-josephl@nvidia.com> <20160707181356.GA6864@kickseed.nvidia.com> <577EA0D6.9020308@wwwdotorg.org> MIME-Version: 1.0 In-Reply-To: <577EA0D6.9020308@wwwdotorg.org> X-NVConfidentiality: public User-Agent: Mutt/1.5.21 (2010-09-15) Content-Type: text/plain; charset="us-ascii" Content-Disposition: inline Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Jul 07, 2016 at 12:35:02PM -0600, Stephen Warren wrote: > On 07/07/2016 12:13 PM, Sivaram Nair wrote: > >On Tue, Jul 05, 2016 at 05:04:22PM +0800, Joseph Lo wrote: > >>Add DT binding for the Hardware Synchronization Primitives (HSP). The > >>HSP is designed for the processors to share resources and communicate > >>together. It provides a set of hardware synchronization primitives for > >>interprocessor communication. So the interprocessor communication (IPC) > >>protocols can use hardware synchronization primitive, when operating > >>between two processors not in an SMP relationship. > > >>diff --git a/include/dt-bindings/mailbox/tegra186-hsp.h b/include/dt-bindings/mailbox/tegra186-hsp.h > > >>+#define HSP_MBOX_TYPE_DB 0x0 > >>+#define HSP_MBOX_TYPE_SM 0x1 > >>+#define HSP_MBOX_TYPE_SS 0x2 > >>+#define HSP_MBOX_TYPE_AS 0x3 > >>+ > >>+#define HSP_DB_MASTER_CCPLEX 17 > >>+#define HSP_DB_MASTER_BPMP 19 > >>+ > >>+#define HSP_MBOX_ID(type, ID) \ > >>+ (HSP_MBOX_TYPE_##type << 16 | ID) > > > >It will be nicer if you avoid the macro glue magic '##' for 'type'. I > >would also suggest to use braces around 'type' and 'ID'. > > This technique been used without issue in quite a few other places > without issue, and has the benefit of simplifying the text wherever > the macro is used. What issue do you foresee? It improves readability where HSP_MBOX_ID is used (in tegra186.dtsi file in this case) - but consider this as a cosmetic comment. > > BTW, if this patch does need reposting, I'd suggest s/ID/id/ since > macro parameters are usually lower-case. From mboxrd@z Thu Jan 1 00:00:00 1970 From: sivaramn@nvidia.com (Sivaram Nair) Date: Thu, 7 Jul 2016 11:44:29 -0700 Subject: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox In-Reply-To: <577EA0D6.9020308@wwwdotorg.org> References: <20160705090431.5852-1-josephl@nvidia.com> <20160705090431.5852-2-josephl@nvidia.com> <20160707181356.GA6864@kickseed.nvidia.com> <577EA0D6.9020308@wwwdotorg.org> Message-ID: <20160707184429.GA26114@kickseed.nvidia.com> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org On Thu, Jul 07, 2016 at 12:35:02PM -0600, Stephen Warren wrote: > On 07/07/2016 12:13 PM, Sivaram Nair wrote: > >On Tue, Jul 05, 2016 at 05:04:22PM +0800, Joseph Lo wrote: > >>Add DT binding for the Hardware Synchronization Primitives (HSP). The > >>HSP is designed for the processors to share resources and communicate > >>together. It provides a set of hardware synchronization primitives for > >>interprocessor communication. So the interprocessor communication (IPC) > >>protocols can use hardware synchronization primitive, when operating > >>between two processors not in an SMP relationship. > > >>diff --git a/include/dt-bindings/mailbox/tegra186-hsp.h b/include/dt-bindings/mailbox/tegra186-hsp.h > > >>+#define HSP_MBOX_TYPE_DB 0x0 > >>+#define HSP_MBOX_TYPE_SM 0x1 > >>+#define HSP_MBOX_TYPE_SS 0x2 > >>+#define HSP_MBOX_TYPE_AS 0x3 > >>+ > >>+#define HSP_DB_MASTER_CCPLEX 17 > >>+#define HSP_DB_MASTER_BPMP 19 > >>+ > >>+#define HSP_MBOX_ID(type, ID) \ > >>+ (HSP_MBOX_TYPE_##type << 16 | ID) > > > >It will be nicer if you avoid the macro glue magic '##' for 'type'. I > >would also suggest to use braces around 'type' and 'ID'. > > This technique been used without issue in quite a few other places > without issue, and has the benefit of simplifying the text wherever > the macro is used. What issue do you foresee? It improves readability where HSP_MBOX_ID is used (in tegra186.dtsi file in this case) - but consider this as a cosmetic comment. > > BTW, if this patch does need reposting, I'd suggest s/ID/id/ since > macro parameters are usually lower-case.