From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752755AbcGON0x (ORCPT ); Fri, 15 Jul 2016 09:26:53 -0400 Received: from mx1.redhat.com ([209.132.183.28]:36424 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751561AbcGON0v (ORCPT ); Fri, 15 Jul 2016 09:26:51 -0400 Date: Fri, 15 Jul 2016 15:27:09 +0200 From: Oleg Nesterov To: Peter Zijlstra Cc: mingo@kernel.org, linux-kernel@vger.kernel.org, tj@kernel.org, paulmck@linux.vnet.ibm.com, john.stultz@linaro.org, dimitrysh@google.com, romlem@google.com, ccross@google.com, tkjos@google.com Subject: Re: [PATCH 2/2] locking/percpu-rwsem: Introduce bias knob Message-ID: <20160715132709.GA27644@redhat.com> References: <20160714182545.786693675@infradead.org> <20160714183022.336211504@infradead.org> <20160714184351.GA18388@redhat.com> <20160714192018.GM30154@twins.programming.kicks-ass.net> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20160714192018.GM30154@twins.programming.kicks-ass.net> User-Agent: Mutt/1.5.18 (2008-05-17) X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.28]); Fri, 15 Jul 2016 13:26:51 +0000 (UTC) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 07/14, Peter Zijlstra wrote: > > On Thu, Jul 14, 2016 at 08:43:51PM +0200, Oleg Nesterov wrote: > > > > Oh well... I personally do not think this is what we want... Can't > > we just add the stupid rcu_sync_enter() into cgroup_init() at least > > for now? Yes, this means the unnecessary .sync() at boot time, but > > it will go away after cleanups I am going to send. > > Something like so then? OK, agreed, > --- > --- a/include/linux/rcu_sync.h > +++ b/include/linux/rcu_sync.h > @@ -59,6 +59,7 @@ static inline bool rcu_sync_is_idle(stru > } > > extern void rcu_sync_init(struct rcu_sync *, enum rcu_sync_type); > +extern void rcu_sync_sabotage(struct rcu_sync *); > extern void rcu_sync_enter(struct rcu_sync *); > extern void rcu_sync_exit(struct rcu_sync *); > extern void rcu_sync_dtor(struct rcu_sync *); > --- a/kernel/cgroup.c > +++ b/kernel/cgroup.c > @@ -5609,6 +5609,8 @@ int __init cgroup_init(void) > BUG_ON(cgroup_init_cftypes(NULL, cgroup_dfl_base_files)); > BUG_ON(cgroup_init_cftypes(NULL, cgroup_legacy_base_files)); > > + rcu_sync_sabotage(&cgroup_threadgroup_rwsem.rss); Heh ;) I too think it should be renamed. I'd suggest __rcu_sync_enter(rss); although I do not really mind and agree with any name. Hopefully I'll send some cleanups soon, rcu_sync_enter() will be re-implemented as rcu_sync_enter(rss) { if (__rcu_sync_enter(rss)) __rcu_sync_wait(rss); } > + * rcu_sync_sabotage() - Sabotage a fresh rcu_sync instance > + * @rsp: Pointer to rcu_sync structure to be sabotaged > + * > + * Must be called after rcu_sync_init() and before first use. OK. And after those cleanups __rcu_sync_enter() can be called at any time. Oleg.