All of lore.kernel.org
 help / color / mirror / Atom feed
From: Chris Wilson <chris@chris-wilson.co.uk>
To: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 13/73] drm/i915: Move the modulus for ring emission to the register write
Date: Mon, 1 Aug 2016 17:32:25 +0100	[thread overview]
Message-ID: <20160801163225.GD5384@nuc-i3427.alporthouse.com> (raw)
In-Reply-To: <1470061714.4174.23.camel@linux.intel.com>

On Mon, Aug 01, 2016 at 05:28:34PM +0300, Joonas Lahtinen wrote:
> On ma, 2016-08-01 at 11:15 +0100, Chris Wilson wrote:
> > On Mon, Aug 01, 2016 at 01:07:55PM +0300, Joonas Lahtinen wrote:
> > > 
> > > On ma, 2016-08-01 at 10:10 +0100, Chris Wilson wrote:
> > > > 
> > > > Space reservation is already safe with respect to the ring->size
> > > > modulus, but hardware only expects to see values in the range
> > > > 0...ring->size-1 (inclusive) and so requires the modulus to prevent us
> > > > writing the value ring->size instead of 0. As this is only required for
> > > > the register itself, we can defer the modulus to the register update and
> > > > not perform it after every command packet. We keep the
> > > > intel_ring_advance() around in the code to provide demarcation for the
> > > > end-of-packet (which then can be compared against intel_ring_begin() as
> > > > the number of dwords emitted must match the reserved space).
> > > > 
> > > > Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
> > > > Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
> > > > Cc: Dave Gordon <david.s.gordon@intel.com>
> > > > ---
> > > >  drivers/gpu/drm/i915/intel_lrc.c        |  2 +-
> > > >  drivers/gpu/drm/i915/intel_ringbuffer.c |  6 ++++--
> > > >  drivers/gpu/drm/i915/intel_ringbuffer.h | 17 +++++++++++++----
> > > >  3 files changed, 18 insertions(+), 7 deletions(-)
> > > > 
> > > > diff --git a/drivers/gpu/drm/i915/intel_lrc.c b/drivers/gpu/drm/i915/intel_lrc.c
> > > > index bf42a66d6624..824f7efe4e64 100644
> > > > --- a/drivers/gpu/drm/i915/intel_lrc.c
> > > > +++ b/drivers/gpu/drm/i915/intel_lrc.c
> > > > @@ -373,7 +373,7 @@ static void execlists_update_context(struct drm_i915_gem_request *rq)
> > > >  	struct i915_hw_ppgtt *ppgtt = rq->ctx->ppgtt;
> > > >  	uint32_t *reg_state = rq->ctx->engine[engine->id].lrc_reg_state;
> > > >  
> > > > -	reg_state[CTX_RING_TAIL+1] = rq->tail;
> > > > +	reg_state[CTX_RING_TAIL+1] = intel_ring_offset(rq->ring, rq->tail);
> > > >  
> > > >  	/* True 32b PPGTT with dynamic page allocation: update PDP
> > > >  	 * registers and point the unallocated PDPs to scratch page.
> > > > diff --git a/drivers/gpu/drm/i915/intel_ringbuffer.c b/drivers/gpu/drm/i915/intel_ringbuffer.c
> > > > index 3142085b5cc0..21d5e8209400 100644
> > > > --- a/drivers/gpu/drm/i915/intel_ringbuffer.c
> > > > +++ b/drivers/gpu/drm/i915/intel_ringbuffer.c
> > > > @@ -1718,7 +1718,8 @@ static void i9xx_submit_request(struct drm_i915_gem_request *request)
> > > >  {
> > > >  	struct drm_i915_private *dev_priv = request->i915;
> > > >  
> > > > -	I915_WRITE_TAIL(request->engine, request->tail);
> > > > +	I915_WRITE_TAIL(request->engine,
> > > > +			intel_ring_offset(request->ring, request->tail));
> > > >  }
> > > >  
> > > >  static void
> > > > @@ -2505,7 +2506,8 @@ static void gen6_bsd_submit_request(struct drm_i915_gem_request *request)
> > > >  		DRM_ERROR("timed out waiting for the BSD ring to wake up\n");
> > > >  
> > > >  	/* Now that the ring is fully powered up, update the tail */
> > > > -	I915_WRITE_FW(RING_TAIL(request->engine->mmio_base), request->tail);
> > > > +	I915_WRITE_FW(RING_TAIL(request->engine->mmio_base),
> > > > +		      intel_ring_offset(request->ring, request->tail));
> > > >  	POSTING_READ_FW(RING_TAIL(request->engine->mmio_base));
> > > >  
> > > >  	/* Let the ring send IDLE messages to the GT again,
> > > > diff --git a/drivers/gpu/drm/i915/intel_ringbuffer.h b/drivers/gpu/drm/i915/intel_ringbuffer.h
> > > > index 14d2ea36fb88..9ac96ddb01ee 100644
> > > > --- a/drivers/gpu/drm/i915/intel_ringbuffer.h
> > > > +++ b/drivers/gpu/drm/i915/intel_ringbuffer.h
> > > > @@ -460,14 +460,23 @@ static inline void intel_ring_emit_reg(struct intel_ring *ring, i915_reg_t reg)
> > > >  
> > > >  static inline void intel_ring_advance(struct intel_ring *ring)
> > > >  {
> > > > +	/* Dummy function.
> > > > +	 *
> > > > +	 * This serves as a placeholder in the code so that the reader
> > > > +	 * can compare against the preceding intel_ring_begin() and
> > > > +	 * check that the number of dwords emitted matches the space
> > > > +	 * reserved for the command packet (i.e. the value passed to
> > > > +	 * intel_ring_begin()).
> > > > +	 */
> > > > +}
> > > > +
> > > > +static inline u32 intel_ring_offset(struct intel_ring *ring, u32 value)
> > > > +{
> > > >  	/* The modulus is required so that we avoid writing
> > > >  	 * request->tail == ring->size, rather than the expected 0,
> > > >  	 * into the RING_TAIL register as that can cause a GPU hang.
> > > > -	 * As this is only strictly required for the request->tail,
> > > > -	 * and only then as we write the value into hardware, we can
> > > > -	 * one day remove the modulus after every command packet.
> > > >  	 */
> > > > -	ring->tail &= ring->size - 1;
> > > > +	return value & (ring->size - 1);
> > > >  }
> > > The comment seems outdated-ish as it speaks of modulus which is nowhere
> > > to be seen. I'd speak of 'masking'. With that,
> > The operation is a modulus. The common optimisation for moduli with
> > a power-of-two divisor being applied.
> 
> Yes, I'm perfectly aware of that, but as discussed in IRC, that
> information would be good to be local. Modulus in this case a trick to
> achieve value == ring->size ? 0 : value; Which would again be more
> informative, we do not expect wrap, but we have one special value.

Ditch all the verbage, and go with the single line:
	/* Don't write ring->size (equivalent to 0) as that hangs some GPUs. */
that just fits into 80cols.

Keep it to why not how and we need not argue about language.
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  parent reply	other threads:[~2016-08-01 16:32 UTC|newest]

Thread overview: 94+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-08-01  9:10 A few bug fixes leading to exporting prime fences [mostly reviewed] Chris Wilson
2016-08-01  9:10 ` [PATCH 01/73] drm/i915: Unify intel_logical_ring_emit and intel_ring_emit Chris Wilson
2016-08-01  9:10 ` [PATCH 02/73] drm/i915: Rename request->ringbuf to request->ring Chris Wilson
2016-08-01  9:10 ` [PATCH 03/73] drm/i915: Rename intel_context[engine].ringbuf Chris Wilson
2016-08-01  9:10 ` [PATCH 04/73] drm/i915: Rename struct intel_ringbuffer to struct intel_ring Chris Wilson
2016-08-01  9:10 ` [PATCH 05/73] drm/i915: Rename residual ringbuf parameters Chris Wilson
2016-08-01  9:10 ` [PATCH 06/73] drm/i915: Rename intel_pin_and_map_ring() Chris Wilson
2016-08-01  9:10 ` [PATCH 07/73] drm/i915: Remove obsolete engine->gpu_caches_dirty Chris Wilson
2016-08-01  9:10 ` [PATCH 08/73] drm/i915: Reduce engine->emit_flush() to a single mode parameter Chris Wilson
2016-08-01  9:10 ` [PATCH 09/73] drm/i915: Simplify request_alloc by returning the allocated request Chris Wilson
2016-08-01  9:10 ` [PATCH 10/73] drm/i915: Unify legacy/execlists emission of MI_BATCHBUFFER_START Chris Wilson
2016-08-01  9:10 ` [PATCH 11/73] drm/i915: Remove intel_ring_get_tail() Chris Wilson
2016-08-01  9:10 ` [PATCH 12/73] drm/i915: Convert engine->write_tail to operate on a request Chris Wilson
2016-08-01  9:10 ` [PATCH 13/73] drm/i915: Move the modulus for ring emission to the register write Chris Wilson
2016-08-01 10:07   ` Joonas Lahtinen
2016-08-01 10:15     ` Chris Wilson
2016-08-01 14:28       ` Joonas Lahtinen
2016-08-01 16:17         ` Chris Wilson
2016-08-01 16:23           ` Chris Wilson
2016-08-01 16:32         ` Chris Wilson [this message]
2016-08-02  9:42           ` Dave Gordon
2016-08-02 10:14             ` Chris Wilson
2016-08-01 10:21     ` Chris Wilson
2016-08-01  9:10 ` [PATCH 14/73] drm/i915: Unify request submission Chris Wilson
2016-08-01 14:30   ` Joonas Lahtinen
2016-08-01 17:17   ` [PATCH v2] " Chris Wilson
2016-08-01  9:10 ` [PATCH 15/73] drm/i915/lrc: Update function names to match request flow Chris Wilson
2016-08-01  9:10 ` [PATCH 16/73] drm/i915: Stop passing caller's num_dwords to engine->semaphore.signal() Chris Wilson
2016-08-01  9:10 ` [PATCH 17/73] drm/i915: Reuse legacy breadcrumbs + tail emission Chris Wilson
2016-08-01  9:10 ` [PATCH 18/73] drm/i915/ringbuffer: Specialise SNB+ request emission for semaphores Chris Wilson
2016-08-01  9:10 ` [PATCH 19/73] drm/i915: Remove duplicate golden render state init from execlists Chris Wilson
2016-08-01  9:10 ` [PATCH 20/73] drm/i915: Refactor golden render state emission to unconfuse gcc Chris Wilson
2016-08-01  9:10 ` [PATCH 21/73] drm/i915: Unify legacy/execlists submit_execbuf callbacks Chris Wilson
2016-08-01  9:10 ` [PATCH 22/73] drm/i915: Simplify calling engine->sync_to Chris Wilson
2016-08-01  9:10 ` [PATCH 23/73] drm/i915: Rename engine->semaphore.sync_to, engine->sempahore.signal locals Chris Wilson
2016-08-01  9:10 ` [PATCH 24/73] drm/i915: Amalgamate GGTT/ppGTT vma debug list walkers Chris Wilson
2016-08-01  9:10 ` [PATCH 25/73] drm/i915: Split early global GTT initialisation Chris Wilson
2016-08-01  9:10 ` [PATCH 26/73] drm/i915: Store owning file on the i915_address_space Chris Wilson
2016-08-01  9:10 ` [PATCH 27/73] drm/i915: Count how many VMA are bound for an object Chris Wilson
2016-08-01  9:10 ` [PATCH 28/73] drm/i915: Be more careful when unbinding vma Chris Wilson
2016-08-01  9:10 ` [PATCH 29/73] drm/i915: Kill drop_pages() Chris Wilson
2016-08-01  9:10 ` [PATCH 30/73] drm/i915: Introduce i915_gem_active for request tracking Chris Wilson
2016-08-01  9:10 ` [PATCH 31/73] drm/i915: Prepare i915_gem_active for annotations Chris Wilson
2016-08-01  9:10 ` [PATCH 32/73] drm/i915: Mark up i915_gem_active for locking annotation Chris Wilson
2016-08-01  9:10 ` [PATCH 33/73] drm/i915: Refactor blocking waits Chris Wilson
2016-08-01  9:10 ` [PATCH 34/73] drm/i915: Rename request->list to link for consistency Chris Wilson
2016-08-01  9:10 ` [PATCH 35/73] drm/i915: Remove obsolete i915_gem_object_flush_active() Chris Wilson
2016-08-01  9:10 ` [PATCH 36/73] drm/i915: Refactor activity tracking for requests Chris Wilson
2016-08-01 12:52   ` Joonas Lahtinen
2016-08-01  9:10 ` [PATCH 37/73] drm/i915: Track requests inside each intel_ring Chris Wilson
2016-08-01  9:10 ` [PATCH 38/73] drm/i915: Convert intel_overlay to request tracking Chris Wilson
2016-08-01  9:10 ` [PATCH 39/73] drm/i915: Move the special case wait-request handling to its one caller Chris Wilson
2016-08-01  9:10 ` [PATCH 40/73] drm/i915: Disable waitboosting for a saturated engine Chris Wilson
2016-08-01  9:10 ` [PATCH 41/73] drm/i915: s/__i915_wait_request/i915_wait_request/ Chris Wilson
2016-08-01  9:10 ` [PATCH 42/73] drm/i915: Double check activity before relocations Chris Wilson
2016-08-01  9:10 ` [PATCH 43/73] drm/i915: Move request list retirement to i915_gem_request.c Chris Wilson
2016-08-01  9:10 ` [PATCH 44/73] drm/i915: i915_vma_move_to_active prep patch Chris Wilson
2016-08-01  9:10 ` [PATCH 45/73] drm/i915: Track active vma requests Chris Wilson
2016-08-01  9:10 ` [PATCH 46/73] drm/i915: Release vma when the handle is closed Chris Wilson
2016-08-01 11:26   ` Joonas Lahtinen
2016-08-01  9:10 ` [PATCH 47/73] drm/i915: Mark the context and address space as closed Chris Wilson
2016-08-01  9:10 ` [PATCH 48/73] Revert "drm/i915: Clean up associated VMAs on context destruction" Chris Wilson
2016-08-01  9:10 ` [PATCH 49/73] drm/i915: Combine loops within i915_gem_evict_something Chris Wilson
2016-08-01  9:10 ` [PATCH 50/73] drm/i915: Remove surplus drm_device parameter to i915_gem_evict_something() Chris Wilson
2016-08-01  9:10 ` [PATCH 51/73] drm/i915: Double check the active status on the batch pool Chris Wilson
2016-08-01  9:11 ` [PATCH 52/73] drm/i915: Remove request retirement before each batch Chris Wilson
2016-08-01  9:11 ` [PATCH 53/73] drm/i915: Remove i915_gem_execbuffer_retire_commands() Chris Wilson
2016-08-01  9:11 ` [PATCH 54/73] drm/i915: Fix up vma alignment to be u64 Chris Wilson
2016-08-01 12:21   ` Joonas Lahtinen
2016-08-01  9:11 ` [PATCH 55/73] drm/i915: Pad GTT views of exec objects up to user specified size Chris Wilson
2016-08-01  9:11 ` [PATCH 56/73] drm/i915: Reduce WARN(i915_gem_valid_gtt_space) to a debug-only check Chris Wilson
2016-08-01  9:11 ` [PATCH 57/73] drm/i915: Split insertion/binding of an object into the VM Chris Wilson
2016-08-01  9:11 ` [PATCH 58/73] drm/i915: Convert 4096 alignment request to 0 for drm_mm allocations Chris Wilson
2016-08-01  9:11 ` [PATCH 59/73] drm/i915: Update the GGTT size/alignment query functions Chris Wilson
2016-08-01 12:27   ` Joonas Lahtinen
2016-08-01  9:11 ` [PATCH 60/73] drm/i915: Update i915_gem_get_ggtt_size/_alignment to use drm_i915_private Chris Wilson
2016-08-01 12:30   ` Joonas Lahtinen
2016-08-01  9:11 ` [PATCH 61/73] drm/i915: Record allocated vma size Chris Wilson
2016-08-01 12:36   ` Joonas Lahtinen
2016-08-01 12:44     ` Chris Wilson
2016-08-01  9:11 ` [PATCH 62/73] drm/i915: Wrap vma->pin_count accessors with small inline helpers Chris Wilson
2016-08-01  9:11 ` [PATCH 63/73] drm/i915: Start passing around i915_vma from execbuffer Chris Wilson
2016-08-01  9:11 ` [PATCH 64/73] drm/i915: Combine all i915_vma bitfields into a single set of flags Chris Wilson
2016-08-01  9:11 ` [PATCH 65/73] drm/i915: Make i915_vma_pin() small and inline Chris Wilson
2016-08-01  9:11 ` [PATCH 66/73] drm/i915: Remove highly confusing i915_gem_obj_ggtt_pin() Chris Wilson
2016-08-01  9:11 ` [PATCH 67/73] drm/i915: Make fb_tracking.lock a spinlock Chris Wilson
2016-08-01  9:11 ` [PATCH 68/73] drm/i915: Use atomics to manipulate obj->frontbuffer_bits Chris Wilson
2016-08-01  9:11 ` [PATCH 69/73] drm/i915: Use dev_priv consistently through the intel_frontbuffer interface Chris Wilson
2016-08-01  9:11 ` [PATCH 70/73] drm/i915: Move obj->active:5 to obj->flags Chris Wilson
2016-08-01 12:46   ` Joonas Lahtinen
2016-08-01  9:11 ` [PATCH 71/73] drm/i915: Move i915_gem_object_wait_rendering() Chris Wilson
2016-08-01  9:11 ` [PATCH 72/73] drm/i915: Enable lockless lookup of request tracking via RCU Chris Wilson
2016-08-01  9:11 ` [PATCH 73/73] drm/i915: Export our request as a dma-buf fence on the reservation object Chris Wilson
2016-08-01 11:45 ` ✗ Ro.CI.BAT: failure for series starting with [01/73] drm/i915: Unify intel_logical_ring_emit and intel_ring_emit Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160801163225.GD5384@nuc-i3427.alporthouse.com \
    --to=chris@chris-wilson.co.uk \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=joonas.lahtinen@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.