From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1768157AbcHROdB (ORCPT ); Thu, 18 Aug 2016 10:33:01 -0400 Received: from mx1.redhat.com ([209.132.183.28]:37498 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1950520AbcHROc6 (ORCPT ); Thu, 18 Aug 2016 10:32:58 -0400 Date: Thu, 18 Aug 2016 09:31:36 -0500 From: Josh Poimboeuf To: Ingo Molnar Cc: Frederic Weisbecker , Thomas Gleixner , "H . Peter Anvin" , x86@kernel.org, linux-kernel@vger.kernel.org, Andy Lutomirski , Linus Torvalds , Steven Rostedt , Brian Gerst , Kees Cook , Peter Zijlstra , Byungchul Park , Nilay Vaish Subject: Re: [PATCH v4 00/57] x86/dumpstack: rewrite x86 stack dump code Message-ID: <20160818143136.wogmldvu7tysmd5q@treble> References: <20160818132507.GD22490@lerouge> <20160818133935.GA3737@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <20160818133935.GA3737@gmail.com> User-Agent: Mutt/1.6.0.1 (2016-04-01) X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.28]); Thu, 18 Aug 2016 14:31:39 +0000 (UTC) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Aug 18, 2016 at 03:39:35PM +0200, Ingo Molnar wrote: > > * Frederic Weisbecker wrote: > > > > Josh Poimboeuf (57): > > > > I am personally unable to review a 57 patches series. > > > > Any chance you could split it into self-contained steps? In general doing so > > increase the chances for reviews, accelerate merging, improve maintainance... > > Yes, please! > > Series of no more than 4-6 patches, ordered in a logical fasion from lowest risk / > simplest towards highest risk / most complex. You're right, that would be better. My apologies for spamming. It started with "only" 19 patches in v1 and then quickly got out of hand. I may split it up something like this: cleanups: x86/dumpstack: remove show_trace() x86/asm/head: remove unused init_rsp variable extern x86/asm/head: rename 'stack_start' -> 'initial_stack' x86/dumpstack: add IRQ_USABLE_STACK_SIZE define x86/dumpstack: remove extra brackets around "" x86/head: remove useless zeroed word x86/dumpstack: fix x86_32 kernel_stack_pointer() previous stack access proc: fix return address printk conversion specifer in /proc//stack x86: remove 64-byte gap at end of irq stack function graph fixes: ftrace: remove CONFIG_HAVE_FUNCTION_GRAPH_FP_TEST from config ftrace: only allocate the ret_stack 'fp' field when needed ftrace: add return address pointer to ftrace_ret_stack ftrace: add ftrace_graph_ret_addr() stack unwinding helpers x86/dumpstack/ftrace: convert dump_trace() callbacks to use ftrace_graph_ret_addr() ftrace/x86: implement HAVE_FUNCTION_GRAPH_RET_ADDR_PTR x86/dumpstack/ftrace: mark function graph handler function as unreliable x86/dumpstack/ftrace: don't print unreliable addresses in print_context_stack_bp() get_stack_info(): x86/dumpstack: simplify in_exception_stack() x86/dumpstack: add get_stack_info() interface x86/dumpstack: add recursion checking for all stacks unwinder prep: perf/x86: check perf_callchain_store() error oprofile/x86: add regs->ip to oprofile trace x86/dumpstack: remove unnecessary stack pointer arguments x86/dumpstack: add get_stack_pointer() and get_frame_pointer() x86/dumpstack: make printk_stack_address() more generally useful x86/dumpstack: fix irq stack bounds calculation in show_stack_log_lvl() x86/dumpstack: allow preemption in show_stack_log_lvl() and dump_trace() unwinder: x86/unwind: add new unwind interface and implementations perf/x86: convert perf_callchain_kernel() to use the new unwinder x86/stacktrace: convert save_stack_trace_*() to use the new unwinder oprofile/x86: convert x86_backtrace() to use the new unwinder x86/dumpstack: convert show_trace_log_lvl() to use the new unwinder x86/dumpstack: remove dump_trace() and related callbacks hardened usercopy: x86/mm: move arch_within_stack_frames() to usercopy.c x86/mm: convert arch_within_stack_frames() to use the new unwinder x86/mm: simplify starting frame logic for hardened usercopy x86/mm: removed unused arch_within_stack_frames() arguments mm: re-enable gcc frame address warning standardize the end of the stack: x86/entry/head/32: use local labels x86/asm/head: use a common function for starting CPUs x86: move _stext marker to before head code x86/head: put real return address on idle task stack x86/head: fix the end of the stack for idle tasks x86/entry/32: fix the end of the stack for newly forked tasks x86/head/32: fix the end of the stack for idle tasks x86/smp: fix initial idle stack location on 32-bit x86/entry/32: rename 'error_code' to 'common_exception' pt_regs frames: x86/entry/unwind: create stack frames for saved interrupt registers x86/unwind: create stack frames for saved syscall registers x86/dumpstack: print stack identifier on its own line x86/dumpstack: print any pt_regs found on the stack x86/dumpstack: fix duplicate RIP address display in __show_regs() x86/dumpstack: print orig_ax in __show_regs() unwinder warnings: x86/unwind: warn on kernel stack corruption x86/unwind: warn on bad stack return address x86/unwind: warn if stack grows up x86/dumpstack: warn on stack recursion -- Josh