From mboxrd@z Thu Jan 1 00:00:00 1970 From: Mark Rutland Subject: Re: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file Date: Thu, 20 Oct 2016 15:45:39 +0100 Message-ID: <20161020144510.GJ10234@leverpostej> References: <1475086637-1914-1-git-send-email-fu.wei@linaro.org> <1475086637-1914-2-git-send-email-fu.wei@linaro.org> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Return-path: Content-Disposition: inline In-Reply-To: <1475086637-1914-2-git-send-email-fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org> Sender: linux-watchdog-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org To: fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org Cc: rjw-LthD3rsA81gm4RdzfppkhA@public.gmane.org, lenb-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org, daniel.lezcano-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org, tglx-hfZtesqFncYOwBW4kG4KsQ@public.gmane.org, marc.zyngier-5wv7dgnIgG8@public.gmane.org, lorenzo.pieralisi-5wv7dgnIgG8@public.gmane.org, sudeep.holla-5wv7dgnIgG8@public.gmane.org, hanjun.guo-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org, linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org, linaro-acpi-cunTk1MwBs8s++Sfvej+rw@public.gmane.org, linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, linux-acpi-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, rruigrok-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org, harba-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org, cov-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org, timur-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org, graeme.gregory-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org, al.stone-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org, jcm-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org, wei-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org, arnd-r2nGTMty4D4@public.gmane.org, catalin.marinas-5wv7dgnIgG8@public.gmane.org, will.deacon-5wv7dgnIgG8@public.gmane.org, Suravee.Suthikulpanit-5C7GfCeVMHo@public.gmane.org, leo.duran-5C7GfCeVMHo@public.gmane.org, wim-IQzOog9fTRqzQB+pC5nmwQ@public.gmane.org, linux-0h96xk9xTtrk1uMJSBkQmQ@public.gmane.org, linux-watchdog-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, tn-nYOzD4b6Jr9Wk0Htik3J/w@public.gmane.org, christoffer.dall-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org, julien.grall-5wv7dgnIgG8@public.gmane.org List-Id: linux-acpi@vger.kernel.org Hi, On Thu, Sep 29, 2016 at 02:17:09AM +0800, fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org wrote: > diff --git a/include/clocksource/arm_arch_timer.h b/include/clocksource/arm_arch_timer.h > index caedb74..6f06481 100644 > --- a/include/clocksource/arm_arch_timer.h > +++ b/include/clocksource/arm_arch_timer.h > @@ -19,6 +19,9 @@ Please add: #include ... immediately before the includes below; it's needed to ensure that BIT() is defined in all cases. Previously we were relying on implicit header includes, which is not good practice. > #include > #include > > +#define ARCH_CP15_TIMER BIT(0) > +#define ARCH_MEM_TIMER BIT(1) If we're going to expose these in a header, it would be better to rename them to something that makes their usage/meaning clear. These should probably be ARCH_TIMER_TYPE_{CP15,MEM}. I guess this can wait for subsequent cleanup. > +enum ppi_nr { > + PHYS_SECURE_PPI, > + PHYS_NONSECURE_PPI, > + VIRT_PPI, > + HYP_PPI, > + MAX_TIMER_PPI > +}; Please rename this to arch_timer_ppi_nr (updating the single user in drivers/clocksource/arm_arch_timer.c). That'll avoid the potential for name clashes in files this happens to get included in (potentially transitively via other headers). With those changes (regardless of the ARCH_TIMER_TYPE_* bits): Acked-by: Mark Rutland Thanks, Mark. > + > #define ARCH_TIMER_PHYS_ACCESS 0 > #define ARCH_TIMER_VIRT_ACCESS 1 > #define ARCH_TIMER_MEM_PHYS_ACCESS 2 > -- > 2.7.4 > -- To unsubscribe from this list: send the line "unsubscribe linux-watchdog" in the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org More majordomo info at http://vger.kernel.org/majordomo-info.html From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756936AbcJTOqP (ORCPT ); Thu, 20 Oct 2016 10:46:15 -0400 Received: from foss.arm.com ([217.140.101.70]:49532 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753462AbcJTOqO (ORCPT ); Thu, 20 Oct 2016 10:46:14 -0400 Date: Thu, 20 Oct 2016 15:45:39 +0100 From: Mark Rutland To: fu.wei@linaro.org Cc: rjw@rjwysocki.net, lenb@kernel.org, daniel.lezcano@linaro.org, tglx@linutronix.de, marc.zyngier@arm.com, lorenzo.pieralisi@arm.com, sudeep.holla@arm.com, hanjun.guo@linaro.org, linux-arm-kernel@lists.infradead.org, linaro-acpi@lists.linaro.org, linux-kernel@vger.kernel.org, linux-acpi@vger.kernel.org, rruigrok@codeaurora.org, harba@codeaurora.org, cov@codeaurora.org, timur@codeaurora.org, graeme.gregory@linaro.org, al.stone@linaro.org, jcm@redhat.com, wei@redhat.com, arnd@arndb.de, catalin.marinas@arm.com, will.deacon@arm.com, Suravee.Suthikulpanit@amd.com, leo.duran@amd.com, wim@iguana.be, linux@roeck-us.net, linux-watchdog@vger.kernel.org, tn@semihalf.com, christoffer.dall@linaro.org, julien.grall@arm.com Subject: Re: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file Message-ID: <20161020144510.GJ10234@leverpostej> References: <1475086637-1914-1-git-send-email-fu.wei@linaro.org> <1475086637-1914-2-git-send-email-fu.wei@linaro.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1475086637-1914-2-git-send-email-fu.wei@linaro.org> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi, On Thu, Sep 29, 2016 at 02:17:09AM +0800, fu.wei@linaro.org wrote: > diff --git a/include/clocksource/arm_arch_timer.h b/include/clocksource/arm_arch_timer.h > index caedb74..6f06481 100644 > --- a/include/clocksource/arm_arch_timer.h > +++ b/include/clocksource/arm_arch_timer.h > @@ -19,6 +19,9 @@ Please add: #include ... immediately before the includes below; it's needed to ensure that BIT() is defined in all cases. Previously we were relying on implicit header includes, which is not good practice. > #include > #include > > +#define ARCH_CP15_TIMER BIT(0) > +#define ARCH_MEM_TIMER BIT(1) If we're going to expose these in a header, it would be better to rename them to something that makes their usage/meaning clear. These should probably be ARCH_TIMER_TYPE_{CP15,MEM}. I guess this can wait for subsequent cleanup. > +enum ppi_nr { > + PHYS_SECURE_PPI, > + PHYS_NONSECURE_PPI, > + VIRT_PPI, > + HYP_PPI, > + MAX_TIMER_PPI > +}; Please rename this to arch_timer_ppi_nr (updating the single user in drivers/clocksource/arm_arch_timer.c). That'll avoid the potential for name clashes in files this happens to get included in (potentially transitively via other headers). With those changes (regardless of the ARCH_TIMER_TYPE_* bits): Acked-by: Mark Rutland Thanks, Mark. > + > #define ARCH_TIMER_PHYS_ACCESS 0 > #define ARCH_TIMER_VIRT_ACCESS 1 > #define ARCH_TIMER_MEM_PHYS_ACCESS 2 > -- > 2.7.4 > From mboxrd@z Thu Jan 1 00:00:00 1970 From: mark.rutland@arm.com (Mark Rutland) Date: Thu, 20 Oct 2016 15:45:39 +0100 Subject: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file In-Reply-To: <1475086637-1914-2-git-send-email-fu.wei@linaro.org> References: <1475086637-1914-1-git-send-email-fu.wei@linaro.org> <1475086637-1914-2-git-send-email-fu.wei@linaro.org> Message-ID: <20161020144510.GJ10234@leverpostej> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org Hi, On Thu, Sep 29, 2016 at 02:17:09AM +0800, fu.wei at linaro.org wrote: > diff --git a/include/clocksource/arm_arch_timer.h b/include/clocksource/arm_arch_timer.h > index caedb74..6f06481 100644 > --- a/include/clocksource/arm_arch_timer.h > +++ b/include/clocksource/arm_arch_timer.h > @@ -19,6 +19,9 @@ Please add: #include ... immediately before the includes below; it's needed to ensure that BIT() is defined in all cases. Previously we were relying on implicit header includes, which is not good practice. > #include > #include > > +#define ARCH_CP15_TIMER BIT(0) > +#define ARCH_MEM_TIMER BIT(1) If we're going to expose these in a header, it would be better to rename them to something that makes their usage/meaning clear. These should probably be ARCH_TIMER_TYPE_{CP15,MEM}. I guess this can wait for subsequent cleanup. > +enum ppi_nr { > + PHYS_SECURE_PPI, > + PHYS_NONSECURE_PPI, > + VIRT_PPI, > + HYP_PPI, > + MAX_TIMER_PPI > +}; Please rename this to arch_timer_ppi_nr (updating the single user in drivers/clocksource/arm_arch_timer.c). That'll avoid the potential for name clashes in files this happens to get included in (potentially transitively via other headers). With those changes (regardless of the ARCH_TIMER_TYPE_* bits): Acked-by: Mark Rutland Thanks, Mark. > + > #define ARCH_TIMER_PHYS_ACCESS 0 > #define ARCH_TIMER_VIRT_ACCESS 1 > #define ARCH_TIMER_MEM_PHYS_ACCESS 2 > -- > 2.7.4 >