All of lore.kernel.org
 help / color / mirror / Atom feed
From: Chris Wilson <chris@chris-wilson.co.uk>
To: Manasi Navare <manasi.d.navare@intel.com>
Cc: Daniel Vetter <daniel.vetter@intel.com>,
	intel-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org
Subject: Re: [PATCH 1/2] drm: Add a new connector property for link status
Date: Wed, 26 Oct 2016 10:27:55 +0100	[thread overview]
Message-ID: <20161026092755.GJ10167@nuc-i3427.alporthouse.com> (raw)
In-Reply-To: <20161026011947.GA19699@intel.com>

On Tue, Oct 25, 2016 at 06:19:47PM -0700, Manasi Navare wrote:
> Chris,
> 
> Would you be able to make the necessary changes in the suerspace
> driver so I can do some testing tomorrow?
> 
> Manasi
> 
> On Tue, Oct 25, 2016 at 06:16:34PM -0700, Manasi Navare wrote:
> > A new optional connector property is added for keeping
> > track of whether the link is good (link training passed) or
> > link is bad (link training  failed). If the link status property
> > is Bad, then userspace should fire off a new modeset at the current
> > mode even if there have not been any changes in the mode list
> > or connector status.
> > 
> > Cc: dri-devel@lists.freedesktop.org
> > Cc: Jani Nikula <jani.nikula@linux.intel.com>
> > Cc: Daniel Vetter <daniel.vetter@intel.com>
> > Cc: Ville Syrjala <ville.syrjala@linux.intel.com>
> > Cc: Chris Wilson <chris@chris-wilson.co.uk>
> > Signed-off-by: Manasi Navare <manasi.d.navare@intel.com>
> > ---
> >  drivers/gpu/drm/drm_connector.c | 32 ++++++++++++++++++++++++++++++++
> >  include/drm/drm_connector.h     |  1 +
> >  include/drm/drm_crtc.h          |  6 ++++++
> >  include/uapi/drm/drm_mode.h     |  4 ++++
> >  4 files changed, 43 insertions(+)
> > 
> > diff --git a/drivers/gpu/drm/drm_connector.c b/drivers/gpu/drm/drm_connector.c
> > index 2db7fb5..b4ce19f 100644
> > --- a/drivers/gpu/drm/drm_connector.c
> > +++ b/drivers/gpu/drm/drm_connector.c
> > @@ -588,6 +588,11 @@ int drm_display_info_set_bus_formats(struct drm_display_info *info,
> >  DRM_ENUM_NAME_FN(drm_get_tv_subconnector_name,
> >  		 drm_tv_subconnector_enum_list)
> >  
> > +static const struct drm_prop_enum_list drm_link_status_enum_list[] = {
> > +	{ DRM_MODE_LINK_STATUS_GOOD, "Good" },
> > +	{ DRM_MODE_LINK_STATUS_BAD, "Bad" },
> > +};
> > +
> >  int drm_connector_create_standard_properties(struct drm_device *dev)
> >  {
> >  	struct drm_property *prop;
> > @@ -845,6 +850,33 @@ int drm_mode_create_suggested_offset_properties(struct drm_device *dev)
> >  EXPORT_SYMBOL(drm_mode_create_suggested_offset_properties);
> >  
> >  /**
> > + * drm_mode_create_link_status_property - Create link status property
> > + * @dev: DRM device
> > + *
> > + * Called by a driver the first time it's needed, must be attached to desired
> > + * connectors.
> > + * This property is used to indicate whether link sttaus is Good or Bad as
> > + * a result fo link training
> > + */
> > +int drm_mode_create_link_status_property(struct drm_device *dev)
> > +{
> > +	struct drm_property *link_status;
> > +
> > +	if (dev->mode_config.link_status_property)
> > +		return 0;
> > +
> > +	link_status =
> > +		drm_property_create_enum(dev, 0, "link-status",

s/0/DRM_MODE_PROP_IMMUTABLE/

Bikeshed commitee: "link-status" or "link status" or "Link status"
		   "Good" or "good"

Do we want a general term such as bad or more specific error? Anything
not !good is an error, so we are always free to add more if need be.
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2016-10-26  9:27 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-26  1:16 [PATCH 1/2] drm: Add a new connector property for link status Manasi Navare
2016-10-26  1:16 ` [PATCH 2/2] drm/i915: Set link status property for DP connector Manasi Navare
2016-10-26  1:19 ` [PATCH 1/2] drm: Add a new connector property for link status Manasi Navare
2016-10-26  9:27   ` Chris Wilson [this message]
2016-10-26  1:58 ` ✗ Fi.CI.BAT: failure for series starting with [1/2] " Patchwork
2016-10-26  5:52 ` [Intel-gfx] [PATCH 1/2] " Daniel Vetter
2016-10-26  9:42   ` Chris Wilson
2016-10-26  9:51     ` Jani Nikula
2016-10-26 11:17       ` [Intel-gfx] " Ville Syrjälä
2016-10-26 13:11         ` Chris Wilson
2016-10-26 13:15           ` Ville Syrjälä
2016-10-26 13:29             ` [Intel-gfx] " Chris Wilson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20161026092755.GJ10167@nuc-i3427.alporthouse.com \
    --to=chris@chris-wilson.co.uk \
    --cc=daniel.vetter@intel.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=manasi.d.navare@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.