All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/2] drm documentation and clean ups
@ 2017-01-02 14:20 Gabriel Krisman Bertazi
  2017-01-02 14:20 ` [PATCH v2 1/2] exynos_drm: Clean up duplicated assignment in exynos_drm_driver Gabriel Krisman Bertazi
  2017-01-02 14:20 ` [PATCH v2 2/2] drm: Document deprecated load/unload hook Gabriel Krisman Bertazi
  0 siblings, 2 replies; 5+ messages in thread
From: Gabriel Krisman Bertazi @ 2017-01-02 14:20 UTC (permalink / raw)
  To: daniel.vetter; +Cc: Gabriel Krisman Bertazi, dri-devel

Here's a v2 with the part of the series that didn't get pushed yet.
Patch 2 has the suggestions from Daniel applied.

Thanks,

Gabriel Krisman Bertazi (2):
  exynos_drm: Clean up duplicated assignment in exynos_drm_driver
  drm: Document deprecated load/unload hook

 drivers/gpu/drm/exynos/exynos_drm_drv.c |  1 -
 include/drm/drm_drv.h                   | 35 +++++++++++++++++++++++++++++++++
 2 files changed, 35 insertions(+), 1 deletion(-)

-- 
2.11.0

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH v2 1/2] exynos_drm: Clean up duplicated assignment in exynos_drm_driver
  2017-01-02 14:20 [PATCH v2 0/2] drm documentation and clean ups Gabriel Krisman Bertazi
@ 2017-01-02 14:20 ` Gabriel Krisman Bertazi
  2017-01-02 14:20 ` [PATCH v2 2/2] drm: Document deprecated load/unload hook Gabriel Krisman Bertazi
  1 sibling, 0 replies; 5+ messages in thread
From: Gabriel Krisman Bertazi @ 2017-01-02 14:20 UTC (permalink / raw)
  To: daniel.vetter
  Cc: Seung-Woo Kim, dri-devel, Kyungmin Park, Gabriel Krisman Bertazi

num_ioctls is already assigned when declaring the exynos_drm_driver
structure.  No need to duplicate it here.

Signed-off-by: Gabriel Krisman Bertazi <krisman@collabora.co.uk>
CC: Inki Dae <inki.dae@samsung.com>
CC: Joonyoung Shim <jy0922.shim@samsung.com>
CC: Seung-Woo Kim <sw0312.kim@samsung.com>
CC: Kyungmin Park <kyungmin.park@samsung.com>
---
 drivers/gpu/drm/exynos/exynos_drm_drv.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/drivers/gpu/drm/exynos/exynos_drm_drv.c b/drivers/gpu/drm/exynos/exynos_drm_drv.c
index 739180ac3da5..44b4d07eefb5 100644
--- a/drivers/gpu/drm/exynos/exynos_drm_drv.c
+++ b/drivers/gpu/drm/exynos/exynos_drm_drv.c
@@ -570,7 +570,6 @@ static int exynos_drm_platform_probe(struct platform_device *pdev)
 	struct component_match *match;
 
 	pdev->dev.coherent_dma_mask = DMA_BIT_MASK(32);
-	exynos_drm_driver.num_ioctls = ARRAY_SIZE(exynos_ioctls);
 
 	match = exynos_drm_match_add(&pdev->dev);
 	if (IS_ERR(match))
-- 
2.11.0

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* [PATCH v2 2/2] drm: Document deprecated load/unload hook
  2017-01-02 14:20 [PATCH v2 0/2] drm documentation and clean ups Gabriel Krisman Bertazi
  2017-01-02 14:20 ` [PATCH v2 1/2] exynos_drm: Clean up duplicated assignment in exynos_drm_driver Gabriel Krisman Bertazi
@ 2017-01-02 14:20 ` Gabriel Krisman Bertazi
  2017-01-04  8:55   ` Daniel Vetter
  1 sibling, 1 reply; 5+ messages in thread
From: Gabriel Krisman Bertazi @ 2017-01-02 14:20 UTC (permalink / raw)
  To: daniel.vetter; +Cc: Gabriel Krisman Bertazi, dri-devel

v2:
 - Replace discouraged with deprecated
 - Link to new initialization/teardown functions

Signed-off-by: Gabriel Krisman Bertazi <krisman@collabora.co.uk>
---
 include/drm/drm_drv.h | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/include/drm/drm_drv.h b/include/drm/drm_drv.h
index c4fc49583dc0..9c2d9f0bb043 100644
--- a/include/drm/drm_drv.h
+++ b/include/drm/drm_drv.h
@@ -64,12 +64,47 @@ struct drm_mode_create_dumb;
  * structure for GEM drivers.
  */
 struct drm_driver {
+
+	/**
+	 * @load:
+	 *
+	 * Backward-compatible driver callback to complete
+	 * initialization steps after the driver is registered.  For
+	 * this reason, may suffer from race conditions and its use is
+	 * deprecated for new drivers.  It is therefore only supported
+	 * for existing drivers not yet converted to the new scheme.
+	 * See drm_dev_init() and drm_dev_register() for proper and
+	 * race-free way to set up a &struct drm_device.
+	 *
+	 * Returns:
+	 *
+	 * Zero on success, non-zero value on failure.
+	 */
 	int (*load) (struct drm_device *, unsigned long flags);
 	int (*firstopen) (struct drm_device *);
 	int (*open) (struct drm_device *, struct drm_file *);
 	void (*preclose) (struct drm_device *, struct drm_file *file_priv);
 	void (*postclose) (struct drm_device *, struct drm_file *);
 	void (*lastclose) (struct drm_device *);
+
+	/**
+	 * @unload:
+	 *
+	 * Reverse the effects of the driver load callback.  Ideally,
+	 * the clean up performed by the driver should happen in the
+	 * reverse order of the initialization.  Similarly to the load
+	 * hook, this handler is deprecated and its usage should be
+	 * dropped in favor of an open-coded teardown function at the
+	 * driver layer.  See drm_dev_unregister() and drm_dev_unref()
+	 * for the proper way to remove a &struct drm_device.
+	 *
+	 * The unload() hook is called right after unregistering
+	 * the device.
+	 *
+	 * Returns:
+	 *
+	 * The return value is ignored.
+	 */
 	int (*unload) (struct drm_device *);
 	int (*dma_ioctl) (struct drm_device *dev, void *data, struct drm_file *file_priv);
 	int (*dma_quiescent) (struct drm_device *);
-- 
2.11.0

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH v2 2/2] drm: Document deprecated load/unload hook
  2017-01-02 14:20 ` [PATCH v2 2/2] drm: Document deprecated load/unload hook Gabriel Krisman Bertazi
@ 2017-01-04  8:55   ` Daniel Vetter
  2017-01-04 17:05     ` Gabriel Krisman Bertazi
  0 siblings, 1 reply; 5+ messages in thread
From: Daniel Vetter @ 2017-01-04  8:55 UTC (permalink / raw)
  To: Gabriel Krisman Bertazi; +Cc: daniel.vetter, dri-devel

On Mon, Jan 02, 2017 at 12:20:08PM -0200, Gabriel Krisman Bertazi wrote:
> v2:
>  - Replace discouraged with deprecated
>  - Link to new initialization/teardown functions
> 
> Signed-off-by: Gabriel Krisman Bertazi <krisman@collabora.co.uk>
> ---
>  include/drm/drm_drv.h | 35 +++++++++++++++++++++++++++++++++++
>  1 file changed, 35 insertions(+)
> 
> diff --git a/include/drm/drm_drv.h b/include/drm/drm_drv.h
> index c4fc49583dc0..9c2d9f0bb043 100644
> --- a/include/drm/drm_drv.h
> +++ b/include/drm/drm_drv.h
> @@ -64,12 +64,47 @@ struct drm_mode_create_dumb;
>   * structure for GEM drivers.
>   */
>  struct drm_driver {
> +
> +	/**
> +	 * @load:
> +	 *
> +	 * Backward-compatible driver callback to complete
> +	 * initialization steps after the driver is registered.  For
> +	 * this reason, may suffer from race conditions and its use is
> +	 * deprecated for new drivers.  It is therefore only supported
> +	 * for existing drivers not yet converted to the new scheme.
> +	 * See drm_dev_init() and drm_dev_register() for proper and
> +	 * race-free way to set up a &struct drm_device.
> +	 *
> +	 * Returns:
> +	 *
> +	 * Zero on success, non-zero value on failure.
> +	 */
>  	int (*load) (struct drm_device *, unsigned long flags);
>  	int (*firstopen) (struct drm_device *);
>  	int (*open) (struct drm_device *, struct drm_file *);
>  	void (*preclose) (struct drm_device *, struct drm_file *file_priv);
>  	void (*postclose) (struct drm_device *, struct drm_file *);
>  	void (*lastclose) (struct drm_device *);
> +
> +	/**
> +	 * @unload:
> +	 *
> +	 * Reverse the effects of the driver load callback.  Ideally,
> +	 * the clean up performed by the driver should happen in the
> +	 * reverse order of the initialization.  Similarly to the load
> +	 * hook, this handler is deprecated and its usage should be
> +	 * dropped in favor of an open-coded teardown function at the
> +	 * driver layer.  See drm_dev_unregister() and drm_dev_unref()
> +	 * for the proper way to remove a &struct drm_device.
> +	 *
> +	 * The unload() hook is called right after unregistering
> +	 * the device.
> +	 *
> +	 * Returns:
> +	 *
> +	 * The return value is ignored.

I know this is a bit more work on top, but if you type docs that say
something is ignored, it's a good excuse to fix the code. So, can you pls
do the mass refactoring (I'd just do one patch for everything) that
changesthe return type of this vfunc to void?

Applied this one here meanwhile to drm-misc, thanks a lot.
-Daniel

> +	 */
>  	int (*unload) (struct drm_device *);
>  	int (*dma_ioctl) (struct drm_device *dev, void *data, struct drm_file *file_priv);
>  	int (*dma_quiescent) (struct drm_device *);
> -- 
> 2.11.0
> 
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH v2 2/2] drm: Document deprecated load/unload hook
  2017-01-04  8:55   ` Daniel Vetter
@ 2017-01-04 17:05     ` Gabriel Krisman Bertazi
  0 siblings, 0 replies; 5+ messages in thread
From: Gabriel Krisman Bertazi @ 2017-01-04 17:05 UTC (permalink / raw)
  To: Daniel Vetter; +Cc: daniel.vetter, dri-devel

Daniel Vetter <daniel@ffwll.ch> writes:

> I know this is a bit more work on top, but if you type docs that say
> something is ignored, it's a good excuse to fix the code. So, can you pls
> do the mass refactoring (I'd just do one patch for everything) that
> changesthe return type of this vfunc to void?
>
> Applied this one here meanwhile to drm-misc, thanks a lot.

Thanks, Daniel.  sure, I can do it, it's going to be a good way for
me to learn coccinelle.

-- 
Gabriel Krisman Bertazi
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2017-01-04 17:05 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-01-02 14:20 [PATCH v2 0/2] drm documentation and clean ups Gabriel Krisman Bertazi
2017-01-02 14:20 ` [PATCH v2 1/2] exynos_drm: Clean up duplicated assignment in exynos_drm_driver Gabriel Krisman Bertazi
2017-01-02 14:20 ` [PATCH v2 2/2] drm: Document deprecated load/unload hook Gabriel Krisman Bertazi
2017-01-04  8:55   ` Daniel Vetter
2017-01-04 17:05     ` Gabriel Krisman Bertazi

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.