All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Bill O'Donnell" <billodo@redhat.com>
To: Jan Tulak <jtulak@redhat.com>
Cc: linux-xfs@vger.kernel.org
Subject: Re: [PATCH 09/22] mkfs: change conflict checks to utilize the new conflict structure
Date: Fri, 13 Jan 2017 11:08:13 -0600	[thread overview]
Message-ID: <20170113170813.GD23576@redhat.com> (raw)
In-Reply-To: <1481117249-21273-10-git-send-email-jtulak@redhat.com>

On Wed, Dec 07, 2016 at 02:27:16PM +0100, Jan Tulak wrote:
> Bring the conflicts detection up to date with conflicts declaration.
> 
> Signed-off-by: Jan Tulak <jtulak@redhat.com>

There's a missing definition for check_subopt()
FWIW, I see the call gets removed in patch10.

> ---
>  mkfs/xfs_mkfs.c | 37 +++++++++++++++++++++++++++++++------
>  1 file changed, 31 insertions(+), 6 deletions(-)
> 
> diff --git a/mkfs/xfs_mkfs.c b/mkfs/xfs_mkfs.c
> index 30618ff..d11fad6 100644
> --- a/mkfs/xfs_mkfs.c
> +++ b/mkfs/xfs_mkfs.c
> @@ -1372,7 +1372,7 @@ illegal_option(
>   * Check for conflicts and option respecification.
>   */
>  static void
> -check_opt(
> +check_subopt_conflicts(
>  	struct opt_params	*opt,
>  	int			index,
>  	bool			str_seen)
> @@ -1424,7 +1424,7 @@ check_opt(
>   * Check for conflict values between options.
>   */
>  static void
> -check_opt_value(
> +check_subopt_value(
>  	struct opt_params	*opt,
>  	int			index,
>  	long long 		value)
> @@ -1450,6 +1450,32 @@ check_opt_value(
>  	}
>  }
>  
> +/**
> + * Go through entire opt_params table and check every option for valid values
> + * and for conflicts.
> + */
> +static void
> +check_opt(
> +	struct opt_params *opts,
> +	int opti)
> +{
> +	int index;
> +	struct opt_params *opt = &opts[opti];
> +	for (index = 0; index < MAX_SUBOPTS; index++) {
> +		struct subopt_param *sp = &opt->subopt_params[index];
> +		check_subopt_conflicts(opt, index, false);
> +		check_subopt_value(opt, index, sp->value);
> +	}
> +}
> +static void
> +check_all_opts(struct opt_params *opts)
> +{
> +	int opti;
> +	for (opti = 0; opti < MAX_OPTS; opti++) {
> +		check_opt(opts, opti);
> +	}
> +}
> +
>  static long long
>  getnum(
>  	const char		*str,
> @@ -1459,7 +1485,6 @@ getnum(
>  	struct subopt_param	*sp = &opts->subopt_params[index];
>  	long long		c;
>  
> -	check_opt(opts, index, false);
>  	/* empty strings might just return a default value */
>  	if (!str || *str == '\0') {
>  		if (sp->defaultval == SUBOPT_NEEDS_VAL)
> @@ -1493,8 +1518,6 @@ getnum(
>  			illegal_option(str, opts, index, NULL);
>  	}
>  
> -	check_opt_value(opts, index, c);
> -
>  	/* Validity check the result. */
>  	if (c < sp->minval)
>  		illegal_option(str, opts, index, _("value is too small"));
> @@ -1517,7 +1540,7 @@ getstr(
>  	struct opt_params	*opts,
>  	int			index)
>  {
> -	check_opt(opts, index, true);
> +	check_subopt(opts, index, true);

check_subopt is undefined. ^^^

>  
>  	/* empty strings for string options are not valid */
>  	if (!str || *str == '\0')
> @@ -2213,6 +2236,8 @@ main(
>  	} else
>  		dfile = xi.dname;
>  
> +	check_all_opts(opts);
> +
>  	/*
>  	 * Blocksize and sectorsize first, other things depend on them
>  	 * For RAID4/5/6 we want to align sector size and block size,
> -- 
> 2.8.1
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-xfs" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

  reply	other threads:[~2017-01-13 17:08 UTC|newest]

Thread overview: 55+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-12-07 13:27 [RFC PATCH 00/22] mkfs.xfs: Make stronger conflict checks Jan Tulak
2016-12-07 13:27 ` [PATCH 01/22] mkfs: remove intermediate getstr followed by getnum Jan Tulak
2017-01-13 16:56   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 02/22] mkfs: merge tables for opts parsing into one table Jan Tulak
2017-01-13 16:57   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 03/22] mkfs: extend opt_params with a value field Jan Tulak
2017-01-13 16:55   ` Bill O'Donnell
2017-01-16 12:42     ` Jan Tulak
2016-12-07 13:27 ` [PATCH 04/22] mkfs: change conflicts array into a table capable of cross-option addressing Jan Tulak
2017-01-13 17:56   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 05/22] mkfs: add a check for conflicting values Jan Tulak
2017-01-13 17:58   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 06/22] mkfs: add cross-section conflict checks Jan Tulak
2017-01-13 21:18   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 07/22] mkfs: Move opts related #define to one place Jan Tulak
2017-01-13 21:19   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 08/22] mkfs: move conflicts into the table Jan Tulak
2017-01-13 21:20   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 09/22] mkfs: change conflict checks to utilize the new conflict structure Jan Tulak
2017-01-13 17:08   ` Bill O'Donnell [this message]
2017-01-16 12:42     ` Jan Tulak
2016-12-07 13:27 ` [PATCH 10/22] mkfs: change when to mark an option as seen Jan Tulak
2017-01-13 21:20   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 11/22] mkfs: add test_default_value into conflict struct Jan Tulak
2017-01-13 21:21   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 12/22] mkfs: expand conflicts declarations to named declaration Jan Tulak
2017-01-13 17:21   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 13/22] mkfs: remove zeroed items from conflicts declaration Jan Tulak
2017-01-16 14:13   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 14/22] mkfs: rename defaultval to flagval in opts Jan Tulak
2017-01-16 14:14   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 15/22] mkfs: replace SUBOPT_NEEDS_VAL for a flag Jan Tulak
2017-01-16 14:14   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 16/22] mkfs: Change all value fields in opt structures into unions Jan Tulak
2017-01-13 17:36   ` Bill O'Donnell
2017-01-16 12:44     ` Jan Tulak
2016-12-07 13:27 ` [PATCH 17/22] mkfs: use old variables as pointers to the new opts struct values Jan Tulak
2017-01-13 17:43   ` Bill O'Donnell
2017-01-16 12:45     ` Jan Tulak
2016-12-07 13:27 ` [PATCH 18/22] mkfs: prevent sector/blocksize to be specified as a number of blocks Jan Tulak
2017-01-16 14:15   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 19/22] mkfs: subopt flags should be saved as bool Jan Tulak
2017-01-16 14:16   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 20/22] mkfs: move uuid empty string test to getstr() Jan Tulak
2017-01-16 14:16   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 21/22] mkfs: remove duplicit checks Jan Tulak
2017-01-16 14:17   ` Bill O'Donnell
2016-12-07 13:27 ` [PATCH 22/22] mkfs: prevent multiple specifications of a single option Jan Tulak
2017-01-16 14:18   ` Bill O'Donnell
2017-01-06 11:42 ` [RFC PATCH 00/22] mkfs.xfs: Make stronger conflict checks Jan Tulak
2017-01-09 19:43 ` Eric Sandeen
2017-01-10  9:47   ` Jan Tulak
2017-01-12 15:46 ` Bill O'Donnell
2017-01-16 20:14 ` Bill O'Donnell
2017-03-15 15:59 [PATCH " Jan Tulak
2017-03-15 16:00 ` [PATCH 09/22] mkfs: change conflict checks to utilize the new conflict structure Jan Tulak

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170113170813.GD23576@redhat.com \
    --to=billodo@redhat.com \
    --cc=jtulak@redhat.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.