From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jerin Jacob Subject: Re: [PATCH v2 15/15] app/test: add unit tests for SW eventdev driver Date: Sat, 11 Feb 2017 14:43:47 +0530 Message-ID: <20170211091346.GA17533@localhost.localdomain> References: <1484580885-148524-1-git-send-email-harry.van.haaren@intel.com> <1485879273-86228-1-git-send-email-harry.van.haaren@intel.com> <1485879273-86228-16-git-send-email-harry.van.haaren@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: dev@dpdk.org, Bruce Richardson , David Hunt To: Harry van Haaren Return-path: Received: from NAM03-DM3-obe.outbound.protection.outlook.com (mail-dm3nam03on0078.outbound.protection.outlook.com [104.47.41.78]) by dpdk.org (Postfix) with ESMTP id 332EBF60E for ; Sat, 11 Feb 2017 10:14:13 +0100 (CET) Content-Disposition: inline In-Reply-To: <1485879273-86228-16-git-send-email-harry.van.haaren@intel.com> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Tue, Jan 31, 2017 at 04:14:33PM +0000, Harry van Haaren wrote: > From: Bruce Richardson > > Since the sw driver is a standalone lookaside device that has no HW > requirements, we can provide a set of unit tests that test its > functionality across the different queue types and with different input > scenarios. > > This also adds the tests to be automatically run by autotest.py > > Signed-off-by: Bruce Richardson > Signed-off-by: David Hunt > Signed-off-by: Harry van Haaren > --- > app/test/Makefile | 5 +- > app/test/autotest_data.py | 26 + > app/test/test_sw_eventdev.c | 2071 +++++++++++++++++++++++++++++++++++++++++++ > 3 files changed, 2101 insertions(+), 1 deletion(-) > create mode 100644 app/test/test_sw_eventdev.c > > diff --git a/app/test/Makefile b/app/test/Makefile > index e28c079..1770c09 100644 > --- a/app/test/Makefile > +++ b/app/test/Makefile > @@ -197,7 +197,10 @@ SRCS-$(CONFIG_RTE_LIBRTE_CRYPTODEV) += test_cryptodev_blockcipher.c > SRCS-$(CONFIG_RTE_LIBRTE_CRYPTODEV) += test_cryptodev_perf.c > SRCS-$(CONFIG_RTE_LIBRTE_CRYPTODEV) += test_cryptodev.c > > -SRCS-$(CONFIG_RTE_LIBRTE_EVENTDEV) += test_eventdev.c > +ifeq ($(CONFIG_RTE_LIBRTE_EVENTDEV),y) > +SRCS-y += test_eventdev.c > +SRCS-$(CONFIG_RTE_LIBRTE_PMD_SW_EVENTDEV) += test_sw_eventdev.c IMO, In order to make symmetrical with cryptodev test cases, We need to change the name to test_eventdev_sw.c Another open question is, Should we allow driver specific test cases? I think, It is OK till we have mature generic unit test cases. Once we have driver specific test case from multiple implementations then we can think of converging all. What you think? > +endif > > SRCS-$(CONFIG_RTE_LIBRTE_KVARGS) += test_kvargs.c