From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753495AbdBNJ7n (ORCPT ); Tue, 14 Feb 2017 04:59:43 -0500 Received: from mga09.intel.com ([134.134.136.24]:6205 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752310AbdBNJ7j (ORCPT ); Tue, 14 Feb 2017 04:59:39 -0500 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.35,160,1484035200"; d="scan'208";a="933665311" Date: Tue, 14 Feb 2017 11:57:25 +0200 From: Mika Westerberg To: Marek Vasut Cc: Nicholas Mc Guire , Cyrille Pitchen , David Woodhouse , Brian Norris , Boris Brezillon , Richard Weinberger , linux-mtd@lists.infradead.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH V2] mtd: spi-nor: intel: use true/false for boolean Message-ID: <20170214095725.GD15721@lahna.fi.intel.com> References: <1486973636-1117-1-git-send-email-der.herr@hofr.at> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: Organization: Intel Finland Oy - BIC 0357606-4 - Westendinkatu 7, 02160 Espoo User-Agent: Mutt/1.7.1 (2016-10-04) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Feb 14, 2017 at 05:52:48AM +0100, Marek Vasut wrote: > On 02/13/2017 09:13 AM, Nicholas Mc Guire wrote: > > writeable in struct intel_spi is a boolean and assignment should be to > > true/false not 1/0 as recommended by boolinit.cocci. > > > > Signed-off-by: Nicholas Mc Guire > > --- > > > > make coccicheck complained with: > > ./drivers/mtd/spi-nor/intel-spi.c:707:3-18: WARNING: Assignment of bool to 0/1 > > > > Patch was compile tested with: multi_v7_defconfig (implies CONFIG_MTD_SPI_NOR=y) > > > > Patch is against 4.10-rc7 (localversion-next is next-20170213) > > > > drivers/mtd/spi-nor/intel-spi.c | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/drivers/mtd/spi-nor/intel-spi.c b/drivers/mtd/spi-nor/intel-spi.c > > index 4630716..2956f2c 100644 > > --- a/drivers/mtd/spi-nor/intel-spi.c > > +++ b/drivers/mtd/spi-nor/intel-spi.c > > @@ -704,7 +704,7 @@ static void intel_spi_fill_partition(struct intel_spi *ispi, > > * whole partition read-only to be on the safe side. > > */ > > if (intel_spi_is_protected(ispi, base, limit)) > > - ispi->writeable = 0; > > + ispi->writeable = false; > > > > end = (limit << 12) + 4096; > > if (end > part->size) > > > > Looks OK, also this is the only place in the driver where writeable is > assigned to an explicit true/false value. > > Acked-by: Marek Vasut Also Acked-by: Mika Westerberg > btw the variable should be renamed from writeable to writable ;-) It is named like that because it follows MTD_WRITEABLE flag.