From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail-it0-f50.google.com ([209.85.214.50]:35561 "EHLO mail-it0-f50.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751362AbdBSVIh (ORCPT ); Sun, 19 Feb 2017 16:08:37 -0500 Received: by mail-it0-f50.google.com with SMTP id 203so59493064ith.0 for ; Sun, 19 Feb 2017 13:08:37 -0800 (PST) From: Trond Myklebust To: Anna Schumaker , Chuck Lever Cc: linux-nfs@vger.kernel.org Subject: [PATCH v5 0/8] XDR cleanups for NFSv4 Date: Sun, 19 Feb 2017 16:08:24 -0500 Message-Id: <20170219210832.61213-1-trond.myklebust@primarydata.com> Sender: linux-nfs-owner@vger.kernel.org List-ID: Various cleanups and bugfixes for the NFSv4 client XDR code. v2: Add documentation to the generic helpers v3: Fix a bug in xdr_stream_encode_opaque (Whoops!) v4: Add a "maxlen" argument to xdr_stream_decode_opaque_inline() to perform size sanity checking on all objects coming from the server. Replace the string decoder in the callback XDR Add cleanups for the owner/group attribute decoding v5: Use EMSGSIZE to denote encode errors, and destination buffer size issues. Use EBADMSG to denote errors due to truncated RPC calls. Trond Myklebust (8): SUNRPC: Add generic helpers for xdr_stream encode/decode NFSv4: Replace ad-hoc xdr encode/decode helpers with xdr_stream_* generics NFSv4: Replace the open coded decode_opaque_inline() with the new generic NFSv4: Replace callback string decode function with a generic NFSv4: Fix the underestimation of delegation XDR space reservation NFSv4: Remove bogus "struct nfs_client" argument from decode_ace() SUNRPC: Add a helper function xdr_stream_decode_string_dup() NFSv4: Clean up owner/group attribute decode fs/nfs/callback_xdr.c | 38 ++----- fs/nfs/flexfilelayout/flexfilelayout.c | 5 +- fs/nfs/nfs4xdr.c | 185 ++++++++++++++------------------- include/linux/sunrpc/xdr.h | 179 +++++++++++++++++++++++++++++++ net/sunrpc/xdr.c | 34 ++++++ 5 files changed, 302 insertions(+), 139 deletions(-) -- 2.9.3