All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bruce Richardson <bruce.richardson@intel.com>
To: Zhiyong Yang <zhiyong.yang@intel.com>
Cc: dev@dpdk.org, Jing Chen <jing.d.chen@intel.com>
Subject: Re: [PATCH 1/5] net/fm10k: remove limit of fm10k_xmit_pkts_vec burst size
Date: Fri, 24 Feb 2017 09:36:29 +0000	[thread overview]
Message-ID: <20170224093629.GB87688@bricha3-MOBL3.ger.corp.intel.com> (raw)
In-Reply-To: <20170224093256.GA87688@bricha3-MOBL3.ger.corp.intel.com>

On Fri, Feb 24, 2017 at 09:32:56AM +0000, Bruce Richardson wrote:
> On Fri, Feb 24, 2017 at 04:48:17PM +0800, Zhiyong Yang wrote:
> > To add a wrapper function fm10k_xmit_pkts_vec_simple to remove
> > the limit of tx burst size. The patch makes fm10k vec function
> > an best effort to transmit the pkts in the consistent behavior
> > like fm10k_xmit_pkts does that.
> > 
> > Cc: Jing Chen <jing.d.chen@intel.com>
> > 
> > Signed-off-by: Zhiyong Yang <zhiyong.yang@intel.com>
> > ---
> >  drivers/net/fm10k/fm10k_ethdev.c | 27 ++++++++++++++++++++++++++-
> >  1 file changed, 26 insertions(+), 1 deletion(-)
> > 
> > diff --git a/drivers/net/fm10k/fm10k_ethdev.c b/drivers/net/fm10k/fm10k_ethdev.c
> > index c4fe746..e9b6254 100644
> > --- a/drivers/net/fm10k/fm10k_ethdev.c
> > +++ b/drivers/net/fm10k/fm10k_ethdev.c
> > @@ -2741,6 +2741,31 @@ fm10k_check_ftag(struct rte_devargs *devargs)
> >  	return 1;
> >  }
> >  
> > +static uint16_t
> > +fm10k_xmit_pkts_vec_simple(void *tx_queue, struct rte_mbuf **tx_pkts,
> > +			   uint16_t nb_pkts)
> > +{
> > +	uint16_t nb_tx = 0;
> > +	struct fm10k_tx_queue *txq = (struct fm10k_tx_queue *)tx_queue;
> > +
> > +	if (likely(nb_pkts <= txq->rs_thresh))
> > +		return fm10k_xmit_pkts_vec(tx_queue, tx_pkts, nb_pkts);
> > +
> > +	/* transmit in chunks of at least txq->rs_thresh */
> > +	while (nb_pkts) {
> > +		uint16_t ret, num;
> > +
> > +		num = (uint16_t)RTE_MIN(nb_pkts, txq->rs_thresh);
> > +		ret = fm10k_xmit_pkts_vec(tx_queue, &tx_pkts[nb_tx], num);
> > +		nb_tx += ret;
> > +		nb_pkts -= ret;
> > +		if (ret < num)
> > +			break;
> > +	}
> > +
> > +	return nb_tx;
> > +}
> > +
> >  static void __attribute__((cold))
> >  fm10k_set_tx_function(struct rte_eth_dev *dev)
> >  {
> > @@ -2766,7 +2791,7 @@ fm10k_set_tx_function(struct rte_eth_dev *dev)
> >  			txq = dev->data->tx_queues[i];
> >  			fm10k_txq_vec_setup(txq);
> >  		}
> > -		dev->tx_pkt_burst = fm10k_xmit_pkts_vec;
> > +		dev->tx_pkt_burst = fm10k_xmit_pkts_vec_simple;
> >  		dev->tx_pkt_prepare = NULL;
> >  	} else {
> 
> The names of the functions do not look right to me. I don't think the
> suffic "_simple" is suitable for describing the functionality of the
> wrapper function vs the original function. I think instead that the
> original function should be renamed to indicate that it is only handles
> a fixed size burst of pkts, and the new wrapper function takes the
> original name. For example:
> 
> 	fm10k_xmit_fixed_burst_vec (original fn)
> 	fm10k_xmit_pkts_vec (new fn)
>
This comment applies for the other patches in the set too.

/Bruce

  reply	other threads:[~2017-02-24  9:36 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-02-24  8:48 [PATCH 0/5] consistent PMD batching behaviour Zhiyong Yang
2017-02-24  8:48 ` [PATCH 1/5] net/fm10k: remove limit of fm10k_xmit_pkts_vec burst size Zhiyong Yang
2017-02-24  9:32   ` Bruce Richardson
2017-02-24  9:36     ` Bruce Richardson [this message]
2017-02-24  9:48       ` Yang, Zhiyong
2017-03-03 11:17   ` [PATCH v2 0/5] consistent PMD batching behaviour Zhiyong Yang
2017-03-03 11:17     ` [PATCH v2 1/5] net/fm10k: remove limit of fm10k_xmit_pkts_vec burst size Zhiyong Yang
2017-03-29  7:16       ` [PATCH v3 0/5] consistent PMD batching behaviour Zhiyong Yang
2017-03-29  7:16         ` [PATCH v3 1/5] net/fm10k: remove limit of fm10k_xmit_pkts_vec burst size Zhiyong Yang
2017-03-29  7:16         ` [PATCH v3 2/5] net/i40e: remove limit of i40e_xmit_pkts_vec " Zhiyong Yang
2017-03-29  7:16         ` [PATCH v3 3/5] net/ixgbe: remove limit of ixgbe_xmit_pkts_vec " Zhiyong Yang
2017-03-29  7:16         ` [PATCH v3 4/5] net/vhost: remove limit of vhost TX " Zhiyong Yang
2017-03-29  7:16         ` [PATCH v3 5/5] net/vhost: remove limit of vhost RX " Zhiyong Yang
2017-03-30 12:54         ` [PATCH v3 0/5] consistent PMD batching behaviour Ferruh Yigit
2017-03-31  7:00           ` Yao, Lei A
2017-03-03 11:17     ` [PATCH v2 2/5] net/i40e: remove limit of i40e_xmit_pkts_vec burst size Zhiyong Yang
2017-03-24 14:03       ` Ferruh Yigit
2017-03-03 11:17     ` [PATCH v2 3/5] net/ixgbe: remove limit of ixgbe_xmit_pkts_vec " Zhiyong Yang
2017-03-03 11:17     ` [PATCH v2 4/5] net/vhost: remove limit of vhost TX " Zhiyong Yang
2017-03-03 11:17     ` [PATCH v2 5/5] net/vhost: remove limit of vhost RX " Zhiyong Yang
2017-03-05 13:02     ` [PATCH v2 0/5] consistent PMD batching behaviour Ananyev, Konstantin
2017-03-06  2:13       ` Yang, Zhiyong
2017-03-24 14:02     ` Ferruh Yigit
2017-03-25  6:29       ` Yang, Zhiyong
2017-03-28 10:00       ` Yang, Zhiyong
2017-03-28 10:05         ` Ferruh Yigit
2017-02-24  8:48 ` [PATCH 2/5] net/i40e: remove limit of i40e_xmit_pkts_vec burst size Zhiyong Yang
2017-02-24  8:48 ` [PATCH 3/5] net/ixgbe: remove limit of ixgbe_xmit_pkts_vec " Zhiyong Yang
2017-02-24  8:48 ` [PATCH 4/5] net/vhost: remove limit of vhost TX " Zhiyong Yang
2017-02-24 11:08   ` Kevin Traynor
2017-02-24 13:04     ` Bruce Richardson
2017-02-24 13:33       ` Kevin Traynor
2017-03-01  9:44   ` Maxime Coquelin
2017-03-01 13:24     ` Yang, Zhiyong
2017-02-24  8:48 ` [PATCH 5/5] net/vhost: remove limit of vhost RX " Zhiyong Yang
2017-02-24 11:41   ` Kevin Traynor

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170224093629.GB87688@bricha3-MOBL3.ger.corp.intel.com \
    --to=bruce.richardson@intel.com \
    --cc=dev@dpdk.org \
    --cc=jing.d.chen@intel.com \
    --cc=zhiyong.yang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.