From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753429AbdCMNqj (ORCPT ); Mon, 13 Mar 2017 09:46:39 -0400 Received: from fllnx210.ext.ti.com ([198.47.19.17]:51258 "EHLO fllnx210.ext.ti.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752228AbdCMNoQ (ORCPT ); Mon, 13 Mar 2017 09:44:16 -0400 From: Kishon Vijay Abraham I To: Bjorn Helgaas , Joao Pinto , Niklas Cassel , , , , CC: , Subject: [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups Date: Mon, 13 Mar 2017 19:13:21 +0530 Message-ID: <20170313134328.1588-1-kishon@ti.com> X-Mailer: git-send-email 2.11.0 MIME-Version: 1.0 Content-Type: text/plain Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This should be the final set of cleanups/fixes before endpoint support can be merged. Keerthy's patch is a general fix in dra7xx driver and is not directly related to endpoint mode. This v1 of this series was previously sent with a different cover letter $subject [1] Changes from v3: *) instead of changing all the callers of dbi accessors (taking dbi_base and size), manage it using static inline as suggested by Niklas (used static inline instead of macros because of checkpatch error). Changes from v2: *) Kconfig changes that was spilled into a patch is removed. *) In addition to renaming _unroll() to _ob_unroll(), all the _unroll configurations is also moved a separate function. Changes from v1: *) included a patch to rename _unroll() to _ob_unroll() as similar thing has to be done for inbound window in the case of EP mode. *) used 'size_t' instead of 'int' for specifying the size in read_dbi/write_dbi function arguments. *) Populate cpu_addr_fixup ops for artpec6 as suggested by Niklas This series is based on 4.11-rc1 [1] -> https://lkml.org/lkml/2017/2/16/270 Keerthy (1): PCI: dwc: dra7xx: Push request_irq call to the bottom of probe Kishon Vijay Abraham I (6): PCI: dwc: designware: Add new *ops* for cpu addr fixup PCI: dwc: dra7xx: Populate cpu_addr_fixup ops PCI: dwc: artpec6: Populate cpu_addr_fixup ops PCI: dwc: all: Modify dbi accessors to take dbi_base as argument PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes PCI: dwc: designware: Move _unroll configurations to a separate function drivers/pci/dwc/pci-dra7xx.c | 25 +++---- drivers/pci/dwc/pci-exynos.c | 14 ++-- drivers/pci/dwc/pcie-artpec6.c | 15 +++-- drivers/pci/dwc/pcie-designware.c | 133 ++++++++++++++++++++++++-------------- drivers/pci/dwc/pcie-designware.h | 23 +++++-- 5 files changed, 135 insertions(+), 75 deletions(-) -- 2.11.0 From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Return-Path: From: Kishon Vijay Abraham I To: Bjorn Helgaas , Joao Pinto , Niklas Cassel , , , , Subject: [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups Date: Mon, 13 Mar 2017 19:13:21 +0530 Message-ID: <20170313134328.1588-1-kishon@ti.com> MIME-Version: 1.0 List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: nsekhar@ti.com, kishon@ti.com Content-Type: text/plain; charset="us-ascii" Sender: "linux-arm-kernel" Errors-To: linux-arm-kernel-bounces+bjorn=helgaas.com@lists.infradead.org List-ID: This should be the final set of cleanups/fixes before endpoint support can be merged. Keerthy's patch is a general fix in dra7xx driver and is not directly related to endpoint mode. This v1 of this series was previously sent with a different cover letter $subject [1] Changes from v3: *) instead of changing all the callers of dbi accessors (taking dbi_base and size), manage it using static inline as suggested by Niklas (used static inline instead of macros because of checkpatch error). Changes from v2: *) Kconfig changes that was spilled into a patch is removed. *) In addition to renaming _unroll() to _ob_unroll(), all the _unroll configurations is also moved a separate function. Changes from v1: *) included a patch to rename _unroll() to _ob_unroll() as similar thing has to be done for inbound window in the case of EP mode. *) used 'size_t' instead of 'int' for specifying the size in read_dbi/write_dbi function arguments. *) Populate cpu_addr_fixup ops for artpec6 as suggested by Niklas This series is based on 4.11-rc1 [1] -> https://lkml.org/lkml/2017/2/16/270 Keerthy (1): PCI: dwc: dra7xx: Push request_irq call to the bottom of probe Kishon Vijay Abraham I (6): PCI: dwc: designware: Add new *ops* for cpu addr fixup PCI: dwc: dra7xx: Populate cpu_addr_fixup ops PCI: dwc: artpec6: Populate cpu_addr_fixup ops PCI: dwc: all: Modify dbi accessors to take dbi_base as argument PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes PCI: dwc: designware: Move _unroll configurations to a separate function drivers/pci/dwc/pci-dra7xx.c | 25 +++---- drivers/pci/dwc/pci-exynos.c | 14 ++-- drivers/pci/dwc/pcie-artpec6.c | 15 +++-- drivers/pci/dwc/pcie-designware.c | 133 ++++++++++++++++++++++++-------------- drivers/pci/dwc/pcie-designware.h | 23 +++++-- 5 files changed, 135 insertions(+), 75 deletions(-) -- 2.11.0 _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel From mboxrd@z Thu Jan 1 00:00:00 1970 From: Kishon Vijay Abraham I Subject: [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups Date: Mon, 13 Mar 2017 19:13:21 +0530 Message-ID: <20170313134328.1588-1-kishon@ti.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: "linux-arm-kernel" Errors-To: linux-arm-kernel-bounces+linux-arm-kernel=m.gmane.org@lists.infradead.org To: Bjorn Helgaas , Joao Pinto , Niklas Cassel , linux-omap@vger.kernel.org, linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org Cc: nsekhar@ti.com, kishon@ti.com List-Id: linux-omap@vger.kernel.org This should be the final set of cleanups/fixes before endpoint support can be merged. Keerthy's patch is a general fix in dra7xx driver and is not directly related to endpoint mode. This v1 of this series was previously sent with a different cover letter $subject [1] Changes from v3: *) instead of changing all the callers of dbi accessors (taking dbi_base and size), manage it using static inline as suggested by Niklas (used static inline instead of macros because of checkpatch error). Changes from v2: *) Kconfig changes that was spilled into a patch is removed. *) In addition to renaming _unroll() to _ob_unroll(), all the _unroll configurations is also moved a separate function. Changes from v1: *) included a patch to rename _unroll() to _ob_unroll() as similar thing has to be done for inbound window in the case of EP mode. *) used 'size_t' instead of 'int' for specifying the size in read_dbi/write_dbi function arguments. *) Populate cpu_addr_fixup ops for artpec6 as suggested by Niklas This series is based on 4.11-rc1 [1] -> https://lkml.org/lkml/2017/2/16/270 Keerthy (1): PCI: dwc: dra7xx: Push request_irq call to the bottom of probe Kishon Vijay Abraham I (6): PCI: dwc: designware: Add new *ops* for cpu addr fixup PCI: dwc: dra7xx: Populate cpu_addr_fixup ops PCI: dwc: artpec6: Populate cpu_addr_fixup ops PCI: dwc: all: Modify dbi accessors to take dbi_base as argument PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes PCI: dwc: designware: Move _unroll configurations to a separate function drivers/pci/dwc/pci-dra7xx.c | 25 +++---- drivers/pci/dwc/pci-exynos.c | 14 ++-- drivers/pci/dwc/pcie-artpec6.c | 15 +++-- drivers/pci/dwc/pcie-designware.c | 133 ++++++++++++++++++++++++-------------- drivers/pci/dwc/pcie-designware.h | 23 +++++-- 5 files changed, 135 insertions(+), 75 deletions(-) -- 2.11.0 From mboxrd@z Thu Jan 1 00:00:00 1970 From: kishon@ti.com (Kishon Vijay Abraham I) Date: Mon, 13 Mar 2017 19:13:21 +0530 Subject: [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups Message-ID: <20170313134328.1588-1-kishon@ti.com> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org This should be the final set of cleanups/fixes before endpoint support can be merged. Keerthy's patch is a general fix in dra7xx driver and is not directly related to endpoint mode. This v1 of this series was previously sent with a different cover letter $subject [1] Changes from v3: *) instead of changing all the callers of dbi accessors (taking dbi_base and size), manage it using static inline as suggested by Niklas (used static inline instead of macros because of checkpatch error). Changes from v2: *) Kconfig changes that was spilled into a patch is removed. *) In addition to renaming _unroll() to _ob_unroll(), all the _unroll configurations is also moved a separate function. Changes from v1: *) included a patch to rename _unroll() to _ob_unroll() as similar thing has to be done for inbound window in the case of EP mode. *) used 'size_t' instead of 'int' for specifying the size in read_dbi/write_dbi function arguments. *) Populate cpu_addr_fixup ops for artpec6 as suggested by Niklas This series is based on 4.11-rc1 [1] -> https://lkml.org/lkml/2017/2/16/270 Keerthy (1): PCI: dwc: dra7xx: Push request_irq call to the bottom of probe Kishon Vijay Abraham I (6): PCI: dwc: designware: Add new *ops* for cpu addr fixup PCI: dwc: dra7xx: Populate cpu_addr_fixup ops PCI: dwc: artpec6: Populate cpu_addr_fixup ops PCI: dwc: all: Modify dbi accessors to take dbi_base as argument PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes PCI: dwc: designware: Move _unroll configurations to a separate function drivers/pci/dwc/pci-dra7xx.c | 25 +++---- drivers/pci/dwc/pci-exynos.c | 14 ++-- drivers/pci/dwc/pcie-artpec6.c | 15 +++-- drivers/pci/dwc/pcie-designware.c | 133 ++++++++++++++++++++++++-------------- drivers/pci/dwc/pcie-designware.h | 23 +++++-- 5 files changed, 135 insertions(+), 75 deletions(-) -- 2.11.0