From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753250AbdCOKPG (ORCPT ); Wed, 15 Mar 2017 06:15:06 -0400 Received: from userp1040.oracle.com ([156.151.31.81]:31490 "EHLO userp1040.oracle.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753076AbdCOKPF (ORCPT ); Wed, 15 Mar 2017 06:15:05 -0400 Date: Wed, 15 Mar 2017 13:14:42 +0300 From: Dan Carpenter To: sunil.m@techveda.org Cc: gregkh@linuxfoundation.org, devel@driverdev.osuosl.org, karthiknishu@yahoo.com, linux-kernel@vger.kernel.org Subject: Re: [PATCH v3 2/8] staging: rtl8192e: Fix coding style Message-ID: <20170315101442.GZ4136@mwanda> References: <20170312134112.GF27791@kroah.com> <1489571517-3332-1-git-send-email-sunil.m@techveda.org> <1489571517-3332-3-git-send-email-sunil.m@techveda.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1489571517-3332-3-git-send-email-sunil.m@techveda.org> User-Agent: Mutt/1.5.21 (2010-09-15) X-Source-IP: aserv0021.oracle.com [141.146.126.233] Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Mar 15, 2017 at 03:21:51PM +0530, sunil.m@techveda.org wrote: > @@ -1796,7 +1796,7 @@ static short _rtl92e_alloc_rx_ring(struct net_device *dev) > > for (rx_queue_idx = 0; rx_queue_idx < MAX_RX_QUEUE; rx_queue_idx++) { > priv->rx_ring[rx_queue_idx] = pci_zalloc_consistent(priv->pdev, > - sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount, > + sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount, > &priv->rx_ring_dma[rx_queue_idx]); No, don't do that. The original was easier to read. Ignore checkpatch.pl if it gives you bad advice. > if (!priv->rx_ring[rx_queue_idx] || > (unsigned long)priv->rx_ring[rx_queue_idx] & 0xFF) { > @@ -2272,7 +2272,8 @@ static int _rtl92e_ioctl(struct net_device *dev, struct ifreq *rq, int cmd) > int ret = -1; > struct rtllib_device *ieee = priv->rtllib; > u32 key[4]; > - const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff, 0xff}; > + const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff, > + 0xff}; Just drop this patch... The original is better. regards, dan carpenter