From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753695AbdCOLQt (ORCPT ); Wed, 15 Mar 2017 07:16:49 -0400 Received: from userp1040.oracle.com ([156.151.31.81]:28572 "EHLO userp1040.oracle.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751611AbdCOLQD (ORCPT ); Wed, 15 Mar 2017 07:16:03 -0400 Date: Wed, 15 Mar 2017 14:15:47 +0300 From: Dan Carpenter To: Suniel Mahesh Cc: devel@driverdev.osuosl.org, gregkh@linuxfoundation.org, karthiknishu@yahoo.com, linux-kernel@vger.kernel.org Subject: Re: [PATCH v3 2/8] staging: rtl8192e: Fix coding style Message-ID: <20170315111547.GC4136@mwanda> References: <20170312134112.GF27791@kroah.com> <1489571517-3332-1-git-send-email-sunil.m@techveda.org> <1489571517-3332-3-git-send-email-sunil.m@techveda.org> <20170315101442.GZ4136@mwanda> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.5.21 (2010-09-15) X-Source-IP: userv0021.oracle.com [156.151.31.71] Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Mar 15, 2017 at 04:39:20PM +0530, Suniel Mahesh wrote: > On Wednesday 15 March 2017 03:44 PM, Dan Carpenter wrote: > >On Wed, Mar 15, 2017 at 03:21:51PM +0530, sunil.m@techveda.org wrote: > >>@@ -1796,7 +1796,7 @@ static short _rtl92e_alloc_rx_ring(struct net_device *dev) > >> > >> for (rx_queue_idx = 0; rx_queue_idx < MAX_RX_QUEUE; rx_queue_idx++) { > >> priv->rx_ring[rx_queue_idx] = pci_zalloc_consistent(priv->pdev, > >>- sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount, > >>+ sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount, > >> &priv->rx_ring_dma[rx_queue_idx]); > > > >No, don't do that. The original was easier to read. Ignore > >checkpatch.pl if it gives you bad advice. > > > >> if (!priv->rx_ring[rx_queue_idx] || > >> (unsigned long)priv->rx_ring[rx_queue_idx] & 0xFF) { > >>@@ -2272,7 +2272,8 @@ static int _rtl92e_ioctl(struct net_device *dev, struct ifreq *rq, int cmd) > >> int ret = -1; > >> struct rtllib_device *ieee = priv->rtllib; > >> u32 key[4]; > >>- const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff, 0xff}; > >>+ const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff, > >>+ 0xff}; > > > >Just drop this patch... The original is better. > > > >regards, > >dan carpenter > > > hi, when you say drop this patch, should I send the entire patch set > as PATCH v4 with this particular patch dropped ? Just drop [PATCH 2/8]... Hopefully you can see why the original was more readable? We don't really care about checkpatch.pl except as a tool to make the code more readable to human beings. regards, dan carpenter