All of lore.kernel.org
 help / color / mirror / Atom feed
* cleanup UUID types V2
@ 2017-05-15 15:42 ` Christoph Hellwig
  0 siblings, 0 replies; 82+ messages in thread
From: Christoph Hellwig @ 2017-05-15 15:42 UTC (permalink / raw)
  To: Andy Shevchenko, Amir Goldstein, linux-fsdevel
  Cc: linux-xfs, linux-raid, linux-nvdimm, Shaohua Li, linux-kernel,
	David Howells, Mimi Zohar, Steven Whitehouse

Hi all,

this series, which is a combined effort from Amir, Andy and me introduces
new uuid_t and guid_t type names that are less confusing than the existing
types, adds new helpers for them and starts switching the fs code over to
it.  Andy has additional patches on top to convert many of the users
that use char arrays for UUIDs and GUIDs to these (or rather a predecessor
for now until updated).

Changes since V2:
 - various cleanups
_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

^ permalink raw reply	[flat|nested] 82+ messages in thread

end of thread, other threads:[~2017-05-16 15:53 UTC | newest]

Thread overview: 82+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-05-15 15:42 cleanup UUID types V2 Christoph Hellwig
2017-05-15 15:42 ` Christoph Hellwig
2017-05-15 15:42 ` Christoph Hellwig
2017-05-15 15:42 ` Christoph Hellwig
2017-05-15 15:42 ` [PATCH 01/17] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42 ` [PATCH 02/17] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42 ` [PATCH 03/17] uuid: rename uuid types Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42 ` [PATCH 04/17] uuid: don't export guid_index and uuid_index Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42 ` [PATCH 05/17] uuid: add the v1 layout to uuid_t Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42 ` [PATCH 06/17] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42 ` [PATCH 07/17] uuid: remove the now unused uuid_be_cmp helper Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42 ` [PATCH 08/17] uuid: hoist uuid_is_null() helper from libnvdimm Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 15:42   ` Christoph Hellwig
2017-05-15 17:48   ` Dan Williams
2017-05-15 17:48     ` Dan Williams
2017-05-15 17:48     ` Dan Williams
2017-05-15 15:43 ` [PATCH 09/17] s390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43 ` [PATCH 10/17] afs: switch to use uuid_t and uuid_gen Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43 ` [PATCH 11/17] uuid: remove struct uuid_v1 Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43 ` [PATCH 12/17] xfs: remove uuid_getnodeuniq and xfs_uu_t Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43 ` [PATCH 13/17] md: namespace private helper names Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43 ` [PATCH 14/17] xfs: use the common helper uuid_is_null() Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43 ` [PATCH 15/17] block: remove blk_part_pack_uuid Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43 ` [PATCH 16/17] ima/policy: switch to use uuid_t Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43 ` [PATCH 17/17] fs: switch ->s_uuid to uuid_t Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 15:43   ` Christoph Hellwig
2017-05-15 19:38   ` Amir Goldstein
2017-05-15 19:38     ` Amir Goldstein
2017-05-15 19:38     ` Amir Goldstein
2017-05-15 19:38     ` Amir Goldstein
2017-05-16 15:53     ` Christoph Hellwig
2017-05-16 15:53       ` Christoph Hellwig
2017-05-16 15:53       ` Christoph Hellwig

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.