All of lore.kernel.org
 help / color / mirror / Atom feed
From: Fam Zheng <famz@redhat.com>
To: Peter Xu <peterx@redhat.com>
Cc: Stefan Hajnoczi <stefanha@redhat.com>,
	Laurent Vivier <lvivier@redhat.com>,
	Juan Quintela <quintela@redhat.com>,
	Markus Armbruster <armbru@redhat.com>,
	qemu-devel@nongnu.org, mdroth@linux.vnet.ibm.com,
	marcandre.lureau@redhat.com,
	Stefan Hajnoczi <shajnocz@redhat.com>,
	Paolo Bonzini <pbonzini@redhat.com>,
	"Dr . David Alan Gilbert" <dgilbert@redhat.com>
Subject: Re: [Qemu-devel] [RFC v5 11/26] qmp: introduce QMPCapability
Date: Fri, 15 Dec 2017 17:38:03 +0800	[thread overview]
Message-ID: <20171215093803.GA15187@lemon> (raw)
In-Reply-To: <20171215091403.GQ7780@xz-mi>

On Fri, 12/15 17:14, Peter Xu wrote:
> On Wed, Dec 13, 2017 at 04:56:51PM +0000, Stefan Hajnoczi wrote:
> > On Tue, Dec 05, 2017 at 01:51:45PM +0800, Peter Xu wrote:
> > > There was no QMP capabilities defined.  Define the first "oob" as
> > > capability to allow out-of-band messages.
> > > 
> > > Also, touch up qmp-test.c to test the new bits.
> > > 
> > > Signed-off-by: Peter Xu <peterx@redhat.com>
> > > ---
> > >  monitor.c        | 15 +++++++++++++--
> > >  qapi-schema.json | 13 +++++++++++++
> > >  tests/qmp-test.c | 10 +++++++++-
> > >  3 files changed, 35 insertions(+), 3 deletions(-)
> > > 
> > > diff --git a/monitor.c b/monitor.c
> > > index e8f5a586e4..bad6ee8dd1 100644
> > > --- a/monitor.c
> > > +++ b/monitor.c
> > > @@ -3944,12 +3944,23 @@ void monitor_resume(Monitor *mon)
> > >  
> > >  static QObject *get_qmp_greeting(void)
> > >  {
> > > +    QDict *result = qdict_new(), *qmp = qdict_new();
> > > +    QList *cap_list = qlist_new();
> > >      QObject *ver = NULL;
> > > +    QMPCapability cap;
> > > +
> > > +    qdict_put(result, "QMP", qmp);
> > >  
> > >      qmp_marshal_query_version(NULL, &ver, NULL);
> > > +    qdict_put_obj(qmp, "version", ver);
> > > +
> > > +    for (cap = 0; cap < QMP_CAPABILITY__MAX; cap++) {
> > > +        qlist_append(cap_list, qstring_from_str(
> > > +                         QMPCapability_str(cap)));
> > > +    }
> > > +    qdict_put(qmp, "capabilities", cap_list);
> > >  
> > > -    return qobject_from_jsonf("{'QMP': {'version': %p, 'capabilities': []}}",
> > > -                              ver);
> > > +    return QOBJECT(result);
> > >  }
> > 
> > Why did you replace qobject_from_jsonf() with manual qdict_*() calls?
> > 
> > I was expecting this (it's shorter and easier to read):
> > 
> >   static QObject *get_qmp_greeting(void)
> >   {
> >       QList *cap_list = qlist_new();
> >       QObject *ver = NULL;
> >       QMPCapability cap;
> > 
> >       qmp_marshal_query_version(NULL, &ver, NULL);
> > 
> >       for (cap = 0; cap < QMP_CAPABILITY__MAX; cap++) {
> >           qlist_append(cap_list, qstring_from_str(
> >                            QMPCapability_str(cap)));

And aligning the parameters would be even nicer.

> >       }
> > 
> >       return qobject_from_jsonf("{'QMP': {'version': %p, 'capabilities': %p}}",
> >                                 ver, cap);
> 
> (I believe you mean s/cap/cap_list/ here?)
> 
> >   }
> 
> Oh I just didn't notice that "%p" magic at all... :(
> 
> I think for me it's fine in either way.  Frankly speaking creating the
> objects explicitly would be even easier to understand for me instead
> of using a mixture of two ways... But just let me know if you want me
> to do it your way.  I can switch.  Thanks,

I agree with Stefan here. (Readability is not judged based on how low level the
code goes when there is a higher level interface available, it's exactly the
opposite, and this doesn't change even when you happen to not know it.)

Fam

  reply	other threads:[~2017-12-15  9:38 UTC|newest]

Thread overview: 113+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-12-05  5:51 [Qemu-devel] [RFC v5 00/26] QMP: out-of-band (OOB) execution support Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 01/26] qobject: introduce qstring_get_try_str() Peter Xu
2017-12-13 15:25   ` Stefan Hajnoczi
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 02/26] qobject: introduce qobject_get_try_str() Peter Xu
2017-12-13 15:25   ` Stefan Hajnoczi
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 03/26] qobject: let object_property_get_str() use new API Peter Xu
2017-12-13 15:27   ` Stefan Hajnoczi
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 04/26] monitor: move skip_flush into monitor_data_init Peter Xu
2017-12-13 15:28   ` Stefan Hajnoczi
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 05/26] qjson: add "opaque" field to JSONMessageParser Peter Xu
2017-12-13 15:37   ` Stefan Hajnoczi
2017-12-15  7:55     ` Peter Xu
2017-12-15 12:45       ` Stefan Hajnoczi
2017-12-16  3:28         ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 06/26] monitor: move the cur_mon hack deeper for QMP Peter Xu
2017-12-13 15:41   ` Stefan Hajnoczi
2017-12-15  8:02     ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 07/26] monitor: unify global init Peter Xu
2017-12-13 15:48   ` Stefan Hajnoczi
2017-12-15  8:11     ` Peter Xu
2017-12-15 12:47       ` Stefan Hajnoczi
2017-12-16  3:52         ` Peter Xu
2017-12-16  9:01           ` Stefan Hajnoczi
2017-12-18  3:27             ` Peter Xu
2017-12-18  9:24               ` Stefan Hajnoczi
2017-12-18 10:10                 ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 08/26] monitor: let mon_list be tail queue Peter Xu
2017-12-13 15:49   ` Stefan Hajnoczi
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 09/26] monitor: create monitor dedicate iothread Peter Xu
2017-12-13 16:20   ` Stefan Hajnoczi
2017-12-15  8:31     ` Peter Xu
2017-12-15 13:21       ` Stefan Hajnoczi
2017-12-16  4:42         ` Peter Xu
2017-12-16  4:50           ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 10/26] monitor: allow to use IO thread for parsing Peter Xu
2017-12-13 16:35   ` Stefan Hajnoczi
2017-12-15  8:50     ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 11/26] qmp: introduce QMPCapability Peter Xu
2017-12-13 16:56   ` Stefan Hajnoczi
2017-12-15  9:14     ` Peter Xu
2017-12-15  9:38       ` Fam Zheng [this message]
2017-12-16  3:58         ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 12/26] qmp: negociate QMP capabilities Peter Xu
2017-12-12 17:39   ` Dr. David Alan Gilbert
2017-12-13 17:19   ` Stefan Hajnoczi
2017-12-15  9:40     ` Fam Zheng
2017-12-15 13:26       ` Stefan Hajnoczi
2017-12-15 13:53         ` Fam Zheng
2017-12-16  5:34           ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 13/26] qmp: introduce some capability helpers Peter Xu
2017-12-12 17:44   ` Dr. David Alan Gilbert
2017-12-13 17:20   ` Stefan Hajnoczi
2017-12-15  9:42   ` Fam Zheng
2017-12-16  5:45     ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 14/26] monitor: introduce monitor_qmp_respond() Peter Xu
2017-12-13 17:35   ` Stefan Hajnoczi
2017-12-16  5:52     ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 15/26] monitor: let suspend_cnt be thread safe Peter Xu
2017-12-13 18:43   ` Stefan Hajnoczi
2017-12-16  6:12     ` Peter Xu
2017-12-16  9:11       ` Stefan Hajnoczi
2017-12-18  5:16         ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 16/26] monitor: separate QMP parser and dispatcher Peter Xu
2017-12-13 20:09   ` Stefan Hajnoczi
2017-12-16  6:37     ` Peter Xu
2017-12-16  6:46       ` Peter Xu
2017-12-16  9:23       ` Stefan Hajnoczi
2017-12-18  5:26         ` Peter Xu
2017-12-18  9:10           ` Stefan Hajnoczi
2017-12-18 10:03             ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 17/26] qmp: add new event "request-dropped" Peter Xu
2017-12-14 11:16   ` Stefan Hajnoczi
2017-12-16  6:59     ` Peter Xu
2017-12-14 11:32   ` Stefan Hajnoczi
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 18/26] monitor: send event when request queue full Peter Xu
2017-12-14 11:41   ` Stefan Hajnoczi
2017-12-16  7:17     ` Peter Xu
2017-12-16  9:28       ` Stefan Hajnoczi
2017-12-18  5:32         ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 19/26] qapi: introduce new cmd option "allow-oob" Peter Xu
2017-12-14 12:42   ` Stefan Hajnoczi
2017-12-15  9:51   ` Fam Zheng
2017-12-16  7:34     ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 20/26] qmp: support out-of-band (oob) execution Peter Xu
2017-12-14 13:16   ` Stefan Hajnoczi
2017-12-18  5:37     ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 21/26] qmp: isolate responses into io thread Peter Xu
2017-12-14 13:43   ` Stefan Hajnoczi
2017-12-18  5:52     ` Peter Xu
2017-12-18  7:32       ` Peter Xu
2017-12-18  8:40         ` Stefan Hajnoczi
2017-12-18 10:15           ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 22/26] monitor: enable IO thread for (qmp & !mux) typed Peter Xu
2017-12-14 13:44   ` Stefan Hajnoczi
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 23/26] qmp: add command "x-oob-test" Peter Xu
2017-12-14 13:45   ` Stefan Hajnoczi
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 24/26] docs: update QMP documents for OOB commands Peter Xu
2017-12-14 14:30   ` Stefan Hajnoczi
2017-12-18  9:44     ` Peter Xu
2017-12-18 14:09       ` Stefan Hajnoczi
2017-12-19  3:18         ` Peter Xu
2017-12-05  5:51 ` [Qemu-devel] [RFC v5 25/26] tests: qmp-test: verify command batching Peter Xu
2017-12-14 14:39   ` Stefan Hajnoczi
2017-12-18  9:48     ` Peter Xu
2017-12-05  5:52 ` [Qemu-devel] [RFC v5 26/26] tests: qmp-test: add oob test Peter Xu
2017-12-14 14:47   ` Stefan Hajnoczi
2017-12-18  9:51     ` Peter Xu
2017-12-18 13:59       ` Stefan Hajnoczi
2017-12-14 14:52 ` [Qemu-devel] [RFC v5 00/26] QMP: out-of-band (OOB) execution support Stefan Hajnoczi
2017-12-19  6:05   ` Peter Xu
2017-12-15 10:41 ` Fam Zheng
2017-12-15 11:43   ` Dr. David Alan Gilbert
2017-12-15 13:30   ` Stefan Hajnoczi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20171215093803.GA15187@lemon \
    --to=famz@redhat.com \
    --cc=armbru@redhat.com \
    --cc=dgilbert@redhat.com \
    --cc=lvivier@redhat.com \
    --cc=marcandre.lureau@redhat.com \
    --cc=mdroth@linux.vnet.ibm.com \
    --cc=pbonzini@redhat.com \
    --cc=peterx@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=quintela@redhat.com \
    --cc=shajnocz@redhat.com \
    --cc=stefanha@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.