From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail-db5eur01on0131.outbound.protection.outlook.com ([104.47.2.131]:20448 "EHLO EUR01-DB5-obe.outbound.protection.outlook.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1752322AbeAOHFB (ORCPT ); Mon, 15 Jan 2018 02:05:01 -0500 Date: Sun, 14 Jan 2018 23:04:41 -0800 From: Andrei Vagin To: Andrew Morton Cc: Andrei Vagin , linux-fsdevel@vger.kernel.org, Alexey Dobriyan , KAMEZAWA Hiroyuki Subject: Re: [PATCH 1/2] procfs: add seq_put_hex_ll to speed up /proc/pid/maps Message-ID: <20180115070440.GA23941@outlook.office365.com> References: <20180112185812.7710-1-avagin@openvz.org> <20180112153304.f4a7dfbae2942e3fdd93eab9@linux-foundation.org> MIME-Version: 1.0 Content-Type: text/plain; charset=koi8-r Content-Disposition: inline In-Reply-To: <20180112153304.f4a7dfbae2942e3fdd93eab9@linux-foundation.org> Sender: linux-fsdevel-owner@vger.kernel.org List-ID: On Fri, Jan 12, 2018 at 03:33:04PM -0800, Andrew Morton wrote: > On Fri, 12 Jan 2018 10:58:11 -0800 Andrei Vagin wrote: > > > seq_put_hex_ll() prints a number in hexadecimal notation and works > > faster than seq_printf(). > > > > ... > > > > --- a/fs/seq_file.c > > +++ b/fs/seq_file.c > > @@ -670,6 +670,26 @@ void seq_puts(struct seq_file *m, const char *s) > > } > > EXPORT_SYMBOL(seq_puts); > > > > +static inline void seq_put_delimeter(struct seq_file *m, const char *delimiter) > > +{ > > + int len; > > + > > + if (!delimiter || !delimiter[0]) > > + return; > > + > > + if (delimiter[1] == 0) > > + return seq_putc(m, delimiter[0]); > > + > > + len = strlen(delimiter); > > + if (m->count + len >= m->size) { > > + seq_set_overflow(m); > > + return; > > + } > > + > > + memcpy(m->buf + m->count, delimiter, len); > > + m->count += len; > > +} > > Can we please have a nice comment describing this function's role and > behaviour? seq_put_decimal_* and seq_put_hex_ll prints a string before printing a number. Originaly it was just one symbol, it is probably a reason why it is called delimeter. I added an optimization for a case when delimiter is one symbol, and found that it sinificantly affect perfomance (about 13% for /proc/pid/maps): Without this optimization: [root@fc24 ~]# time python test.py real 0m9.105s user 0m2.200s sys 0m6.901s With this optimization: [root@fc24 ~]# time python test.py real 0m8.097s user 0m1.994s sys 0m6.102s If inline is replaced by noinline [root@fc24 ~]# time python test.py real 0m8.263s user 0m2.058s sys 0m6.200s [root@fc24 ~]# cat test.py #!/usr/bin/env python2 num = 0 with open("/proc/1/maps") as f: for x in xrange(100000): data = f.read() f.seek(0, 0) Andrew, thank you for the review, I will send a fixed patch soon. > > I don't think the `inline' is needed or desirable - gcc can figure that > out, and with three callsites a `noinline' would be more justified! > > That `return seq_putc(...)' will generate a warning in some situations > - seq_putc() returns void. Let's split it into 'seq_putc(...); > return;' please. > > > +/** > > + * seq_put_hex_ll - put a number in hexadecimal notation > > + * @m: seq_file identifying the buffer to which data should be written > > + * @delimiter: a string which is printed before the number > > + * @v: the number > > + * @width: a minimum field width > > + * > > + * seq_put_hex_ll(m, "", v, 8) is equal to seq_printf(m, "0x08llx", v) > > + * > > + * This routine is very quick when you show lots of numbers. > > + * In usual cases, it will be better to use seq_printf(). It's easier to read. > > + */ > > +void seq_put_hex_ll(struct seq_file *m, const char *delimiter, > > + unsigned long long v, int width) > > +{ > > + int i, len; > > + > > + seq_put_delimeter(m, delimiter); > > + > > + len = (sizeof(v) * 8 - __builtin_clzll(v) + 3) / 4; > > + > > + if (unlikely(len == 0)) > > + len = 1; > > + > > + if (len < width) > > + len = width; > > + > > + if (m->count + len > m->size) > > + goto overflow; > > + > > + for (i = len - 1; i >= 0; i--) { > > + m->buf[m->count + i] = hex_asc[0xf & v]; > > + v = v >> 4; > > + } > > + m->count += len; > > + return; > > +overflow: > > + seq_set_overflow(m); > > +} > > I don't think we need the goto. Just do "seq_set_overflow(m); return;". >