From mboxrd@z Thu Jan 1 00:00:00 1970 From: Olivier Matz Subject: Re: [PATCH v2 3/4] eal: set name when creating a control thread Date: Mon, 23 Apr 2018 14:49:09 +0200 Message-ID: <20180411112943.7ez3rv2jnqvdg24x@platinum> References: <20180403130439.11151-1-olivier.matz@6wind.com> <20180403130439.11151-4-olivier.matz@6wind.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: dev@dpdk.org To: "Burakov, Anatoly" Return-path: Received: from mail.droids-corp.org (zoll.droids-corp.org [94.23.50.67]) by dpdk.org (Postfix) with ESMTP id 3D73C569B for ; Mon, 23 Apr 2018 14:49:16 +0200 (CEST) Content-Disposition: inline In-Reply-To: List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Tue, Apr 10, 2018 at 05:34:36PM +0100, Burakov, Anatoly wrote: > On 03-Apr-18 2:04 PM, Olivier Matz wrote: > > To avoid code duplication, add a parameter to rte_ctrl_thread_create() > > to specify the name of the thread. > > > > This requires to add a wrapper for the thread start routine in > > rte_thread_init(), which will first wait that the thread is configured. > > > > Signed-off-by: Olivier Matz > > --- > > <...> > > > + > > + pthread_barrier_wait(¶ms.configured); > > + > > + return 0; > > + > > +fail: > > + pthread_kill(*thread, SIGTERM); > > This may be wrong, but perhaps instead of killing the thread outright, a > better approach would be pthread_cancel? I'm always uneasy about mixing > signals and pthreads... Indeed, pthread_cancel() seems to be a better approach. I'll update the patchset. Thanks for the review.