All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mark Rutland <mark.rutland@arm.com>
To: linux-kernel@vger.kernel.org, will.deacon@arm.com,
	peterz@infradead.org, boqun.feng@gmail.com
Cc: mingo@kernel.org, Arnd Bergmann <arnd@arndb.de>,
	Richard Henderson <rth@twiddle.net>,
	Ivan Kokshaysky <ink@jurassic.park.msu.ru>,
	Matt Turner <mattst88@gmail.com>,
	Vineet Gupta <vgupta@synopsys.com>,
	Russell King <linux@armlinux.org.uk>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Palmer Dabbelt <palmer@sifive.com>, Albert Ou <albert@sifive.com>
Subject: Re: [PATCHv3 07/18] atomics: prepare for atomic64_fetch_add_unless()
Date: Mon, 18 Jun 2018 17:10:55 +0100	[thread overview]
Message-ID: <20180618161054.nez5trvedaz5qk7h@lakrids.cambridge.arm.com> (raw)
In-Reply-To: <20180618101919.51973-8-mark.rutland@arm.com>

On Mon, Jun 18, 2018 at 11:19:08AM +0100, Mark Rutland wrote:
> Currently architecture must implement atomic_fetch_add_unless(), with
> common code providing atomic_add_unless(). Architectures must also
> implement atmic64_add_unless() directly, with no corresponding
> atomic64_fetch_add_unless().
> 
> This divergenece is unfortunate, and means that the APIs for atomic_t,
> atomic64_t, and atomic_long_t differ.
> 
> In preparation for unifying things, with architectures providing
> atomic64_fetch_add_unless, this patch adds a generic
> atomic64_add_unless() which will use atomic64_fetch_add_unless(). The
> instrumented atomics are updated to take this case into account.

> +#ifdef arch_atomic64_fetch_add_unless
> +#define atomic64_fetch_add_unless atomic64_fetch_add_unless
> +static __always_inline int atomic64_fetch_add_unless(atomic64_t *v, s64 a, s64 u)

Whoops: s/int/s64/ here

I've fixed that up in my branch.

Thanks,
Mark.

  reply	other threads:[~2018-06-18 16:11 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-06-18 10:19 [PATCHv3 00/18] atomics: API cleanups Mark Rutland
2018-06-18 10:19 ` [PATCHv3 01/18] atomics/treewide: s/__atomic_add_unless/atomic_fetch_add_unless/ Mark Rutland
2018-06-18 10:19 ` [PATCHv3 02/18] atomics/treewide: remove redundant atomic_inc_not_zero() definitions Mark Rutland
2018-06-18 10:19 ` [PATCHv3 03/18] atomics/treewide: remove atomic_inc_not_zero_hint() Mark Rutland
2018-06-18 10:19 ` [PATCHv3 04/18] atomics: make conditional ops return bool Mark Rutland
2018-06-18 10:19 ` [PATCHv3 05/18] atomics/treewide: make atomic64_inc_not_zero() optional Mark Rutland
2018-06-18 10:19 ` [PATCHv3 06/18] atomics/treewide: make atomic_fetch_add_unless() optional Mark Rutland
2018-06-18 10:19 ` [PATCHv3 07/18] atomics: prepare for atomic64_fetch_add_unless() Mark Rutland
2018-06-18 16:10   ` Mark Rutland [this message]
2018-06-18 10:19 ` [PATCHv3 08/18] atomics/generic: define atomic64_fetch_add_unless() Mark Rutland
2018-06-18 10:19 ` [PATCHv3 09/18] atomics/alpha: " Mark Rutland
2018-06-18 15:54   ` Will Deacon
2018-06-18 16:08     ` Mark Rutland
2018-06-21 11:00       ` Ingo Molnar
2018-06-18 10:19 ` [PATCHv3 10/18] atomics/arc: " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 11/18] atomics/arm: " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 12/18] atomics/powerpc: " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 13/18] atomics/riscv: " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 14/18] atomics/treewide: make atomic64_fetch_add_unless() optional Mark Rutland
2018-06-18 10:19 ` [PATCHv3 15/18] atomics/treewide: make test ops optional Mark Rutland
2018-06-18 10:19 ` [PATCHv3 16/18] atomics/treewide: make unconditional inc/dec " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 17/18] atomics/treewide: make conditional " Mark Rutland
2018-06-18 10:19 ` [PATCHv3 18/18] atomics/treewide: clean up andnot ifdeffery Mark Rutland
2018-06-18 16:38 ` [PATCHv3 00/18] atomics: API cleanups Will Deacon
2018-06-18 19:21   ` Mark Rutland
2018-06-19 10:18     ` Mark Rutland
2018-06-19 10:20       ` Will Deacon
2018-06-19 10:38         ` Mark Rutland

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180618161054.nez5trvedaz5qk7h@lakrids.cambridge.arm.com \
    --to=mark.rutland@arm.com \
    --cc=albert@sifive.com \
    --cc=arnd@arndb.de \
    --cc=benh@kernel.crashing.org \
    --cc=boqun.feng@gmail.com \
    --cc=ink@jurassic.park.msu.ru \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=mattst88@gmail.com \
    --cc=mingo@kernel.org \
    --cc=mpe@ellerman.id.au \
    --cc=palmer@sifive.com \
    --cc=paulus@samba.org \
    --cc=peterz@infradead.org \
    --cc=rth@twiddle.net \
    --cc=vgupta@synopsys.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.