From mboxrd@z Thu Jan 1 00:00:00 1970 From: Naveen M Subject: Re: [PATCH] ASoC: Intel: Boards: Add GLK Realtek Maxim I2S machine driver Date: Mon, 18 Jun 2018 21:57:40 +0530 Message-ID: <20180618162731.GA9141@intel.com> References: <1529336788-6835-1-git-send-email-naveen.m@intel.com> <3593ad31-ca5d-432b-5d68-2c7b2ba42914@linux.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mga17.intel.com (mga17.intel.com [192.55.52.151]) by alsa0.perex.cz (Postfix) with ESMTP id 03084266D4C for ; Mon, 18 Jun 2018 18:28:01 +0200 (CEST) Content-Disposition: inline In-Reply-To: <3593ad31-ca5d-432b-5d68-2c7b2ba42914@linux.intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: alsa-devel-bounces@alsa-project.org Sender: alsa-devel-bounces@alsa-project.org To: Pierre-Louis Bossart Cc: Harsha Priya , alsa-devel@alsa-project.org, broonie@kernel.org, pierre-louis.bossart@intel.com List-Id: alsa-devel@alsa-project.org On Mon, Jun 18, 2018 at 11:08:22AM -0500, Pierre-Louis Bossart wrote: > > > On 06/18/2018 10:46 AM, Naveen Manohar wrote: > >Patch adds Geminilake I2S machine driver which uses following codecs: > >RT5682 and MAX98357A. > Thanks Naveen. Looks good to me, just 4 nit-picks below on style (reverse > x-mas tree order for variable definitions) > if you can fix, add my tag below and resubmit it'd nice. > > Acked-by: Pierre-Louis Bossart > Sure, I will do that. Thanks for pointing this out and this Ack. > >+static int platform_clock_control(struct snd_soc_dapm_widget *w, > >+ struct snd_kcontrol *k, int event) > >+{ > >+ int ret = 0; > >+ struct snd_soc_dapm_context *dapm = w->dapm; > >+ struct snd_soc_card *card = dapm->card; > >+ struct snd_soc_dai *codec_dai; > here.. > >+static int geminilake_rt5682_codec_init(struct snd_soc_pcm_runtime *rtd) > >+{ > >+ int ret; > >+ struct snd_soc_jack *jack; > >+ struct snd_soc_dai *codec_dai = rtd->codec_dai; > >+ struct snd_soc_component *component = rtd->codec_dai->component; > >+ struct glk_card_private *ctx = snd_soc_card_get_drvdata(rtd->card); > and here > >+static int geminilake_rt5682_fe_init(struct snd_soc_pcm_runtime *rtd) > >+{ > >+ int ret; > >+ struct snd_soc_dapm_context *dapm; > >+ struct snd_soc_component *component = rtd->cpu_dai->component; > and here > >+static int glk_card_late_probe(struct snd_soc_card *card) > >+{ > >+ struct glk_card_private *ctx = snd_soc_card_get_drvdata(card); > >+ struct snd_soc_component *component = NULL; > >+ char jack_name[NAME_SIZE]; > >+ struct glk_hdmi_pcm *pcm; > >+ int err, i = 0; > one last, i find it more readable to have one assignment per line. > Sure. --