All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/7] amd-iommu: cleanup and add lookup_page method
@ 2018-09-20 14:11 Paul Durrant
  2018-09-20 14:11 ` [PATCH 1/7] amd-iommu: don't domain_crash() inside map/unmap_page() Paul Durrant
                   ` (6 more replies)
  0 siblings, 7 replies; 15+ messages in thread
From: Paul Durrant @ 2018-09-20 14:11 UTC (permalink / raw)
  To: xen-devel
  Cc: Kevin Tian, Wei Liu, Jan Beulich, Andrew Cooper, Paul Durrant,
	Suravee Suthikulpanit, Brian Woods

The aim of this series is to add a lookup_page method for AMD IOMMU
analogous to that recently added for VT-d. That is done by the last
patch. The first five patches are cleanup of the AMD IOMMU code, and
patch six modifies the VT-d code to remove a semantic problem.

Paul Durrant (7):
  amd-iommu: don't domain_crash() inside map/unmap_page()
  amd-iommu: re-name u8/16/32/64 to uint8/16/32/64_t
  amd-iommu: convert all bool_t to bool
  amd-iommu: reduce code duplication...
  amd-iommu: introduce new get/set_iommu_pde_info() functions...
  vtd: change lookup_page failure semantics
  amd-iommu: add lookup_page method to iommu_ops

 xen/drivers/passthrough/amd/iommu_map.c       | 551 +++++++++++++++-----------
 xen/drivers/passthrough/amd/pci_amd_iommu.c   |   1 +
 xen/drivers/passthrough/vtd/iommu.c           |   5 +-
 xen/include/asm-x86/hvm/svm/amd-iommu-proto.h |   2 +
 4 files changed, 317 insertions(+), 242 deletions(-)
---
Cc: Andrew Cooper <andrew.cooper3@citrix.com>
Cc: Brian Woods <brian.woods@amd.com>
Cc: Jan Beulich <jbeulich@suse.com>
Cc: Kevin Tian <kevin.tian@intel.com>
Cc: Suravee Suthikulpanit <suravee.suthikulpanit@amd.com>
Cc: Wei Liu <wei.liu2@citrix.com>
-- 
2.11.0


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xenproject.org
https://lists.xenproject.org/mailman/listinfo/xen-devel

^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2018-09-21 10:31 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-09-20 14:11 [PATCH 0/7] amd-iommu: cleanup and add lookup_page method Paul Durrant
2018-09-20 14:11 ` [PATCH 1/7] amd-iommu: don't domain_crash() inside map/unmap_page() Paul Durrant
2018-09-20 14:11 ` [PATCH 2/7] amd-iommu: re-name u8/16/32/64 to uint8/16/32/64_t Paul Durrant
2018-09-20 14:11 ` [PATCH 3/7] amd-iommu: convert all bool_t to bool Paul Durrant
2018-09-20 14:11 ` [PATCH 4/7] amd-iommu: reduce code duplication Paul Durrant
2018-09-20 14:11 ` [PATCH 5/7] amd-iommu: introduce new get/set_iommu_pde_info() functions Paul Durrant
2018-09-20 14:11 ` [PATCH 6/7] vtd: change lookup_page failure semantics Paul Durrant
2018-09-21  0:58   ` Tian, Kevin
2018-09-21 10:16   ` Jan Beulich
2018-09-21 10:18     ` Paul Durrant
2018-09-21 10:27       ` Jan Beulich
2018-09-21 10:31         ` Paul Durrant
2018-09-20 14:11 ` [PATCH 7/7] amd-iommu: add lookup_page method to iommu_ops Paul Durrant
2018-09-20 15:03   ` Jan Beulich
2018-09-20 15:41     ` Paul Durrant

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.