From mboxrd@z Thu Jan 1 00:00:00 1970 From: =?iso-8859-1?Q?Ga=EBtan?= Rivet Subject: Re: [PATCH v5 01/13] eal: add param register infrastructure Date: Wed, 17 Oct 2018 13:45:50 +0200 Message-ID: <20181017114550.kugn4tzo6h2svur3@bidouze.vm.6wind.com> References: <20181011165837.81030-1-kevin.laatz@intel.com> <20181016155802.2067-1-kevin.laatz@intel.com> <20181016155802.2067-2-kevin.laatz@intel.com> <25255353.InYxgXp6IK@xps> Mime-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Transfer-Encoding: 8bit Cc: Kevin Laatz , dev@dpdk.org, harry.van.haaren@intel.com, stephen@networkplumber.org, shreyansh.jain@nxp.com, mattias.ronnblom@ericsson.com, bruce.richardson@intel.com To: Thomas Monjalon Return-path: Received: from mail-wm1-f66.google.com (mail-wm1-f66.google.com [209.85.128.66]) by dpdk.org (Postfix) with ESMTP id 3AA905F12 for ; Wed, 17 Oct 2018 13:46:10 +0200 (CEST) Received: by mail-wm1-f66.google.com with SMTP id 189-v6so1692506wmw.2 for ; Wed, 17 Oct 2018 04:46:10 -0700 (PDT) Content-Disposition: inline In-Reply-To: <25255353.InYxgXp6IK@xps> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Hi Thomas, On Wed, Oct 17, 2018 at 11:41:53AM +0200, Thomas Monjalon wrote: > I still think all the wording is incorrect. > Please start by describing what is "param", "flag" and "option" in your mind. > They are all mentioned in this file. > Are you sure rte_param is the right name? > I suggested the name rte_param, I think the original proposal was rte_lib_init, which to me unduly diminished the intent of these structures. I think rte_param seems proper, this is a generic parameter object description. The integer "enabled" is described as a flag in the structure, as it is used to flag the init routine down the road to trigger the init callback associated with this parameter. eal_option is reminiscent of optarg / optind of getopt() family, which seems fitting. I don't mean to overstep Kevin's role defending his work, but given that I proposed some of this naming and pushed for this direction to be taken in the first place, I feel I should help explain my propositions. rte_param could become rte_parameter or rte_option instead, eal_option could become opt_string or opt_str, and so on, do you have specific ideas about proper names? > > 16/10/2018 17:57, Kevin Laatz: > > --- /dev/null > > +++ b/lib/librte_eal/common/include/rte_param.h > > @@ -0,0 +1,91 @@ > > +/* SPDX-License-Identifier: BSD-3-Clause > > + * Copyright(c) 2018 Intel Corporation. > > + */ > > + > > +#ifndef __INCLUDE_RTE_PARAM_H__ > > +#define __INCLUDE_RTE_PARAM_H__ > > + > > +/** > > + * @file > > + * > > + * This API introduces the ability to register callbacks with EAL. When > > + * registering a callback, the application also provides an option as part > > + * of the struct used to register. If the option is passed to EAL when > > + * running a DPDK application, the relevant callback will be called at the > > + * end of EAL init. For example, passing --telemetry will make the > > + * telemetry init be called at the end of EAL init. > > + * Citing --telemetry here is a bad idea, this file is lib-agnostic, --telemetry is not assured to be relevant. > > + * The register API can be used to resolve circular dependency issues > > + * between EAL and the library. The library uses EAL but is also initialized by > > + * EAL. Hence, EAL depends on the init function of the library. The API > > + * introduced in rte_param allows us to register the library init with EAL > > + * (passing a function pointer) and avoid the circular dependency. > > + */ -- Gaëtan Rivet 6WIND