All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sergio Paracuellos <sergio.paracuellos@gmail.com>
To: Frans Klaver <fransklaver@gmail.com>
Cc: neil@brown.name, Greg KH <gregkh@linuxfoundation.org>,
	driverdev-devel@linuxdriverproject.org
Subject: Re: [PATCH v6 33/33] staging: mt7621-pci: replace 'mdelay()' with 'msleep()'
Date: Wed, 7 Nov 2018 14:11:40 +0100	[thread overview]
Message-ID: <20181107131140.GA22887@foobar> (raw)
In-Reply-To: <CAH6sp9NHSxNuH34QFRHDa-idW_UfuaBzZwCHjkS3U=j6rv2R5g@mail.gmail.com>

On Mon, Nov 05, 2018 at 09:09:39AM +0100, Frans Klaver wrote:
> On Sun, Nov 4, 2018 at 11:51 AM Sergio Paracuellos
> <sergio.paracuellos@gmail.com> wrote:
> >
> > Function 'mt7621_pcie_init_ports' is never called in atomic context.
> > It calls mdelay() to busily wait, which is not necessary. mdelay()
> > can be replaced with msleep().
> >
> > Signed-off-by: Sergio Paracuellos <sergio.paracuellos@gmail.com>
> > ---
> >  drivers/staging/mt7621-pci/pci-mt7621.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c b/drivers/staging/mt7621-pci/pci-mt7621.c
> > index fb9aa6b..14cec23 100644
> > --- a/drivers/staging/mt7621-pci/pci-mt7621.c
> > +++ b/drivers/staging/mt7621-pci/pci-mt7621.c
> > @@ -632,7 +632,7 @@ static void mt7621_pcie_init_ports(struct mt7621_pcie *pcie)
> >         rt_sysc_m32(PCIE_CLK_GEN_EN, PCIE_CLK_GEN_DIS, RALINK_PCIE_CLK_GEN);
> >         rt_sysc_m32(PCIE_CLK_GEN1_DIS, PCIE_CLK_GEN1_EN, RALINK_PCIE_CLK_GEN1);
> >         rt_sysc_m32(PCIE_CLK_GEN_DIS, PCIE_CLK_GEN_EN, RALINK_PCIE_CLK_GEN);
> > -       mdelay(50);
> > +       msleep(50);
> >         rt_sysc_m32(RALINK_PCIE_RST, 0, RALINK_RSTCTRL);

Hi Frans,
> 
> From a software point of view it makes sense to remove the busy-wait.
> From a hardware perspective it may still make sense to keep it. Can
> you guarantee that the PCIE_RST is done at the correct time. I haven't
> looked thoroughly at the datasheet yet, but I can imagine the level
> has to shift within a certain time frame? Or doesn't that make too
> much of a difference? Perhaps mention that in your commit message?

Thanks for the feedback. I agree with you that from a hardware point of
view keep this could make sense. The fact is that after reading the 
datasheet for me is not clear at all that in this concrete case it make
sense. I cannot also test this because I don't have the hardware to be able
to do (all the patches, as I said are only compile-tested). This is also
a reason to keep this patch as the last in this series to just skip it if
this fails when is tested.

Best regards,
    Sergio Paracuellos
_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

  reply	other threads:[~2018-11-07 13:11 UTC|newest]

Thread overview: 46+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-11-04 10:49 [PATCH v6 00/33] staging: mt7621-pci: Parse ports info from DT and other minor cleanups Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 01/33] staging: mt7621-pci: parse and init port data from device tree Sergio Paracuellos
2018-11-18 21:51   ` NeilBrown
2018-11-19  4:44     ` Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 02/33] staging: mt7621-pci: replace return value if devm_pci_alloc_host_bridge call fails Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 03/33] staging: mt7621-pci: add two helpers for read and write pcie register ports Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 04/33] staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function Sergio Paracuellos
2018-11-23 22:44   ` NeilBrown
2018-11-04 10:49 ` [PATCH v6 05/33] staging: mt7621-pci: remove [ASSERT|DEASSERT]_SYSRST_PCIE macros Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 06/33] staging: mt7621-pci: remove GPL2+ text from license header Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 07/33] staging: mt7621-pci: remove two commented code lines Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 08/33] staging: mt7621-pci: remove reset related unused macros Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 09/33] staging: mt7621-pci: reagroup reset related macros all together Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 10/33] staging: mt7621-pci: rewrite pcie phy related functions Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 11/33] staging: mt7621-pci: factor out 'mt7621_enable_phy' function Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 12/33] staging: mt7621-pci: debug port N_FTS inside 'mt7621_pcie_enable_port' Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 13/33] staging: mt7621-pci: rename 'mt7621_pcie_enable_port' into 'mt7621_pcie_init_port' Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 14/33] staging: mt7621-dts: add sysctl registers base address to pcie Sergio Paracuellos
2018-11-23 23:07   ` NeilBrown
2018-11-24  7:22     ` Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 15/33] staging: mt7621-pci: remap and use sysctl from device tree Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 16/33] staging: mt7621-pci: use a trailing */ on a separate line Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 17/33] staging: mt7621-pci: use dev_* functions instead of printk Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 18/33] staging: mt7621-pci: factor out 'mt7621_pcie_enable_ports' function Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 19/33] staging: mt7621-pci: avoid use of global variable 'pcie_link_status' Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 20/33] staging: mt7621-pci: factor out 'mt7621_pcie_init_ports' function Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 21/33] staging: mt7621-pci: remove unused preprocessor definitions Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 22/33] staging: mt7621-pci: reorder " Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 23/33] staging: mt7621-pci: remove non sense comment Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 24/33] staging: mt7621-pci: align function definition style along the code Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 25/33] staging: mt7621-pci: rewrite RC FTS configuration Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 26/33] staging: mt7621-pci: rewrite hardcoded code for enabling ports Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 27/33] staging: mt7621-pci: add some definitions for enabling and disabling GEN and GEN1 clocks Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 28/33] staging: mt7621-pci: use PERST_N instead of gpio control Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 29/33] staging: mt7621-pci: use PCIE_PORT_LINKUP instead of hardcode value Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 30/33] staging: mt7621-pci: enable interrupt when port is being enabled Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 31/33] staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 32/33] staging: mt7621-pci: move some code into 'mt7621_pcie_init_ports' Sergio Paracuellos
2018-11-04 10:49 ` [PATCH v6 33/33] staging: mt7621-pci: replace 'mdelay()' with 'msleep()' Sergio Paracuellos
2018-11-05  8:09   ` Frans Klaver
2018-11-07 13:11     ` Sergio Paracuellos [this message]
2018-11-11 19:35 ` [PATCH v6 00/33] staging: mt7621-pci: Parse ports info from DT and other minor cleanups Greg KH
2018-11-11 21:40   ` NeilBrown
2018-11-12  5:44     ` Sergio Paracuellos
2018-11-24  0:21       ` NeilBrown
2018-11-24  7:38         ` Sergio Paracuellos

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181107131140.GA22887@foobar \
    --to=sergio.paracuellos@gmail.com \
    --cc=driverdev-devel@linuxdriverproject.org \
    --cc=fransklaver@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=neil@brown.name \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.