On Sun, Nov 25, 2018 at 11:47:37PM -1000, Joey Pabalinas wrote: > > + if ((mode & IDLE_WRITEBACK && > > + !zram_test_flag(zram, index, ZRAM_IDLE)) && > > + (mode & HUGE_WRITEBACK && > > + !zram_test_flag(zram, index, ZRAM_HUGE))) > > + goto next; > > Wouldn't writing this as `mode & (IDLE_WRITEBACK | HUGE_WRITEBACK)` > be a bit easier to read as well as slightly more compact? Scratch this comment, it just dawned on me that this is not an equivalent expression, heh. -- Cheers, Joey Pabalinas