All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mark Brown <broonie@kernel.org>
To: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
Cc: alsa-devel@alsa-project.org, Mark Brown <broonie@kernel.org>
Subject: Applied "ASoC: simple-card: rename simple_get_conversion() to simple_parse_convert()" to the asoc tree
Date: Mon, 18 Mar 2019 14:51:00 +0000 (GMT)	[thread overview]
Message-ID: <20190318145100.D41A4112887B@debutante.sirena.org.uk> (raw)
In-Reply-To: <874l80ztkm.wl-kuninori.morimoto.gx@renesas.com>

The patch

   ASoC: simple-card: rename simple_get_conversion() to simple_parse_convert()

has been applied to the asoc tree at

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git 

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.  

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark

>From cdc444721b0eea6817d1003add2f99414dc8028d Mon Sep 17 00:00:00 2001
From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
Date: Mon, 18 Mar 2019 13:50:08 +0900
Subject: [PATCH] ASoC: simple-card: rename simple_get_conversion() to
 simple_parse_convert()

use same naming rule

Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
---
 sound/soc/generic/simple-card.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/sound/soc/generic/simple-card.c b/sound/soc/generic/simple-card.c
index 7147bba45a2a..5238c912cecd 100644
--- a/sound/soc/generic/simple-card.c
+++ b/sound/soc/generic/simple-card.c
@@ -172,9 +172,9 @@ static int simple_be_hw_params_fixup(struct snd_soc_pcm_runtime *rtd,
 	return 0;
 }
 
-static void simple_get_conversion(struct device *dev,
-				  struct device_node *np,
-				  struct asoc_simple_card_data *adata)
+static void simple_parse_convert(struct device *dev,
+				 struct device_node *np,
+				 struct asoc_simple_card_data *adata)
 {
 	struct device_node *top = dev->of_node;
 	struct device_node *node = of_get_parent(np);
@@ -295,7 +295,7 @@ static int simple_dai_link_of_dpcm(struct simple_priv *priv,
 					     "prefix");
 	}
 
-	simple_get_conversion(dev, np, &dai_props->adata);
+	simple_parse_convert(dev, np, &dai_props->adata);
 
 	asoc_simple_card_canonicalize_platform(dai_link);
 
@@ -471,7 +471,7 @@ static int simple_for_each_link(struct simple_priv *priv,
 		/* get convert-xxx property */
 		memset(&adata, 0, sizeof(adata));
 		for_each_child_of_node(node, np)
-			simple_get_conversion(dev, np, &adata);
+			simple_parse_convert(dev, np, &adata);
 
 		/* loop for all CPU/Codec node */
 		for_each_child_of_node(node, np) {
-- 
2.20.1

  reply	other threads:[~2019-03-18 14:51 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-03-18  4:49 [PATCH 00/15] ASoC: simple-card: share similar function Kuninori Morimoto
2019-03-18  4:50 ` [PATCH 01/15] ASoC: simple-card: rename simple_get_conversion() to simple_parse_convert() Kuninori Morimoto
2019-03-18 14:51   ` Mark Brown [this message]
2019-03-18  4:50 ` [PATCH 02/15] ASoC: simple-card: add simple_parse_mclk_fs() Kuninori Morimoto
2019-03-18 14:50   ` Applied "ASoC: simple-card: add simple_parse_mclk_fs()" to the asoc tree Mark Brown
2019-03-18  4:50 ` [PATCH 03/15] ASoC: audio-graph: rename graph_get_conversion() to graph_parse_convert() Kuninori Morimoto
2019-03-18 14:50   ` Applied "ASoC: audio-graph: rename graph_get_conversion() to graph_parse_convert()" to the asoc tree Mark Brown
2019-03-18  4:50 ` [PATCH 04/15] ASoC: audio-graph: add graph_parse_mclk_fs() Kuninori Morimoto
2019-03-18 14:50   ` Applied "ASoC: audio-graph: add graph_parse_mclk_fs()" to the asoc tree Mark Brown
2019-03-18  4:53 ` [PATCH 05/15] ASoC: simple-card-utils: add asoc_simple_debug_info() Kuninori Morimoto
2019-03-18  4:53 ` [PATCH 06/15] ASoC: simple_card_utils: share common priv for simple-card/audio-graph Kuninori Morimoto
2019-03-18  4:53 ` [PATCH 07/15] ASoC: simple-card-utils: share asoc_simple_startup() Kuninori Morimoto
2019-03-18  4:53 ` [PATCH 08/15] ASoC: simple-card-utils: share asoc_simple_shutdown() Kuninori Morimoto
2019-03-18  4:53 ` [PATCH 09/15] ASoC: simple-card-utils: share asoc_simple_hw_param() Kuninori Morimoto
2019-03-18  4:54 ` [PATCH 10/15] ASoC: simple-card-utils: share asoc_simple_dai_init() Kuninori Morimoto
2019-03-18  4:54 ` [PATCH 11/15] ASoC: simple-card-utils: share asoc_simple_be_hw_params_fixup() Kuninori Morimoto
2019-03-18  4:54 ` [PATCH 12/15] ASoC: simple-card-utils: share asoc_simple_card_init_priv() Kuninori Morimoto
2019-03-18  4:55 ` [PATCH 13/15] ASoC: simple-card-utils: separate asoc_simple_card_parse_dai() Kuninori Morimoto
2019-03-18  4:55 ` [PATCH 14/15] ASoC: simple-card-utils: rename asoc_simple_card_xxx() to asoc_simple_() Kuninori Morimoto
2019-03-18  4:55 ` [PATCH 15/15] ASoC: simple-card-utils: test memory allocation Kuninori Morimoto
2019-03-20  4:49 ` [PATCH 00/15] ASoC: simple-card: share similar function Kuninori Morimoto

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190318145100.D41A4112887B@debutante.sirena.org.uk \
    --to=broonie@kernel.org \
    --cc=alsa-devel@alsa-project.org \
    --cc=kuninori.morimoto.gx@renesas.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.