All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sicilia Cristian <sicilia.cristian@gmail.com>
To: Jonathan Cameron <jic23@kernel.org>
Cc: Lars-Peter Clausen <lars@metafoo.de>,
	Michael Hennerich <Michael.Hennerich@analog.com>,
	Hartmut Knaack <knaack.h@gmx.de>,
	Peter Meerwald-Stadler <pmeerw@pmeerw.net>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-iio@vger.kernel.org, devel@driverdev.osuosl.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 2/5] staging: iio: adc: Converted bool to bitfield format
Date: Sun, 24 Mar 2019 17:33:45 +0100	[thread overview]
Message-ID: <20190324163345.GA791@peano> (raw)
In-Reply-To: <20190324123452.66b81183@archlinux>

On Sun, Mar 24, 2019 at 12:34:52PM +0000, Jonathan Cameron wrote:
> On Sat, 23 Mar 2019 20:21:39 +0100
> Cristian Sicilia <sicilia.cristian@gmail.com> wrote:
> 
 > > Changed bool format to bitfield format to save space.
> > 
> > Signed-off-by: Cristian Sicilia <sicilia.cristian@gmail.com>
> > 
> > ---
> > The strange thing is that this struct seems not populated
> > using a DTS binding function.
> Indeed and that should have definitely been a warning sign ;)
> We are looking at traditional platform data here (pre device
> tree) and generally we will want to drop it entirely for old
> drivers that we are looking to move out of staging.
> 
> I don't mind improving it prior to dropping (as it avoids
> setting bad precedence in the code base in the meantime) but
> one comment inline...
> 

Thanks for comment

> > ---
> >  drivers/staging/iio/adc/ad7192.h | 16 ++++++++--------
> >  1 file changed, 8 insertions(+), 8 deletions(-)
> > 
> > diff --git a/drivers/staging/iio/adc/ad7192.h b/drivers/staging/iio/adc/ad7192.h
> > index 7433a43..87891ba 100644
> > --- a/drivers/staging/iio/adc/ad7192.h
> > +++ b/drivers/staging/iio/adc/ad7192.h
> > @@ -35,13 +35,13 @@ struct ad7192_platform_data {
> >  	u16		vref_mv;
> >  	u8		clock_source_sel;
> >  	u32		ext_clk_hz;
> > -	bool		refin2_en;
> > -	bool		rej60_en;
> > -	bool		sinc3_en;
> > -	bool		chop_en;
> > -	bool		buf_en;
> > -	bool		unipolar_en;
> > -	bool		burnout_curr_en;
> > -};
> > +	u8		refin2_en:1;
> > +	u8		rej60_en:1;
> > +	u8		sinc3_en:1;
> > +	u8		chop_en:1;
> > +	u8		buf_en:1;
> > +	u8		unipolar_en:1;
> > +	u8		burnout_curr_en:1;
> > +} __attribute__((__packed__));
> Please don't use packed for anything without a very very good reason.
> it may result in data layouts that are much harder to read from.
> That obviously doesn't matter here as I doubt it's read in a fast path.

Ok, I remove it, thanks

> 
> >  
> >  #endif /* IIO_ADC_AD7192_H_ */
> 

  reply	other threads:[~2019-03-24 16:33 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-03-23 12:53 [PATCH 0/5] *** SUBJECT HERE *** Cristian Sicilia
2019-03-23 12:53 ` [PATCH 3/5] staging: iio: adc: Avoid precedence issues in macro Cristian Sicilia
2019-03-23 12:53 ` [PATCH 4/5] staging: iio: adc: Adding temp var to improve readability Cristian Sicilia
2019-03-23 12:54 ` [PATCH 2/5] staging: iio: adc: Converted bool to bitfield format Cristian Sicilia
2019-03-23 12:54 ` [PATCH 5/5] staging: iio: adc: Remove CamelCase notation Cristian Sicilia
2019-03-23 12:58 ` [PATCH 1/5] staging: iio: adc: Tab alignment Cristian Sicilia
2019-03-23 19:21 ` [PATCH v2 0/5] staging: iio: adc: Code refactoring and bool to bitfield change Cristian Sicilia
2019-03-23 19:21   ` [PATCH v2 1/5] staging: iio: adc: Tab alignment Cristian Sicilia
2019-03-24 12:35     ` Jonathan Cameron
2019-03-24 16:34       ` Cristian Sicilia
2019-03-23 19:21   ` [PATCH v2 2/5] staging: iio: adc: Converted bool to bitfield format Cristian Sicilia
2019-03-24 12:34     ` Jonathan Cameron
2019-03-24 16:33       ` Sicilia Cristian [this message]
2019-03-23 19:21   ` [PATCH v2 3/5] staging: iio: adc: Avoid precedence issues in macro Cristian Sicilia
2019-03-24 12:37     ` Jonathan Cameron
2019-03-23 19:21   ` [PATCH v2 4/5] staging: iio: adc: Adding temp var to improve readability Cristian Sicilia
2019-03-24 12:41     ` Jonathan Cameron
2019-03-23 19:21   ` [PATCH v2 5/5] staging: iio: adc: Remove CamelCase notation Cristian Sicilia
2019-03-24 14:56     ` Jonathan Cameron
2019-03-24 17:23   ` [PATCH v2 0/5] staging: iio: adc: Code refactoring and bool to bitfield change Cristian Sicilia
2019-03-24 17:27     ` [PATCH v3 " Cristian Sicilia
2019-03-24 17:23     ` [PATCH v3 1/5] staging: iio: adc: ad7280a: Tab alignment Cristian Sicilia
2019-03-31  9:29       ` Jonathan Cameron
2019-03-24 17:23     ` [PATCH v3 2/5] staging: iio: adc: ad7192: Converted bool to bitfield format Cristian Sicilia
2019-03-31  9:32       ` Jonathan Cameron
2019-03-24 17:23     ` [PATCH v3 3/5] staging: iio: adc: ad7280a: Avoid precedence issues in macro Cristian Sicilia
2019-03-31  9:34       ` Jonathan Cameron
2019-03-24 17:23     ` [PATCH v3 4/5] staging: iio: adc: ad7280a: Adding temp var to improve readability Cristian Sicilia
2019-03-31  9:35       ` Jonathan Cameron
2019-03-31  9:35       ` Jonathan Cameron
2019-03-24 17:23     ` [PATCH v3 5/5] staging: iio: adc: ad7280a: Remove CamelCase notation Cristian Sicilia
2019-03-31  9:37       ` Jonathan Cameron
2019-03-23 19:24 ` [PATCH 0/5] *** SUBJECT HERE *** Matt Ranostay

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190324163345.GA791@peano \
    --to=sicilia.cristian@gmail.com \
    --cc=Michael.Hennerich@analog.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=jic23@kernel.org \
    --cc=knaack.h@gmx.de \
    --cc=lars@metafoo.de \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pmeerw@pmeerw.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.