All of lore.kernel.org
 help / color / mirror / Atom feed
From: Michal Hocko <mhocko@kernel.org>
To: Baoquan He <bhe@redhat.com>
Cc: linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	rafael@kernel.org, akpm@linux-foundation.org, osalvador@suse.de,
	rppt@linux.ibm.com, willy@infradead.org,
	fanc.fnst@cn.fujitsu.com
Subject: Re: [PATCH v3 2/2] drivers/base/memory.c: Rename the misleading parameter
Date: Fri, 29 Mar 2019 10:13:25 +0100	[thread overview]
Message-ID: <20190329091325.GD28616@dhcp22.suse.cz> (raw)
In-Reply-To: <20190329082915.19763-2-bhe@redhat.com>

On Fri 29-03-19 16:29:15, Baoquan He wrote:
> The input parameter 'phys_index' of memory_block_action() is actually
> the section number, but not the phys_index of memory_block. Fix it.

I have tried to explain that the naming is mostly a relict from the past
than really a misleading name http://lkml.kernel.org/r/20190326093315.GL28406@dhcp22.suse.cz
Maybe it would be good to reflect that in the changelog
 
> Signed-off-by: Baoquan He <bhe@redhat.com>

btw. I've acked the previous version as well.

> ---
> v2->v3:
>   Rename the parameter to 'start_section_nr' from 'sec'.
> 
>  drivers/base/memory.c | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/base/memory.c b/drivers/base/memory.c
> index cb8347500ce2..9ea972b2ae79 100644
> --- a/drivers/base/memory.c
> +++ b/drivers/base/memory.c
> @@ -231,13 +231,14 @@ static bool pages_correctly_probed(unsigned long start_pfn)
>   * OK to have direct references to sparsemem variables in here.
>   */
>  static int
> -memory_block_action(unsigned long phys_index, unsigned long action, int online_type)
> +memory_block_action(unsigned long start_section_nr, unsigned long action,
> +		    int online_type)
>  {
>  	unsigned long start_pfn;
>  	unsigned long nr_pages = PAGES_PER_SECTION * sections_per_block;
>  	int ret;
>  
> -	start_pfn = section_nr_to_pfn(phys_index);
> +	start_pfn = section_nr_to_pfn(start_section_nr);
>  
>  	switch (action) {
>  	case MEM_ONLINE:
> @@ -251,7 +252,7 @@ memory_block_action(unsigned long phys_index, unsigned long action, int online_t
>  		break;
>  	default:
>  		WARN(1, KERN_WARNING "%s(%ld, %ld) unknown action: "
> -		     "%ld\n", __func__, phys_index, action, action);
> +		     "%ld\n", __func__, start_section_nr, action, action);
>  		ret = -EINVAL;
>  	}
>  
> -- 
> 2.17.2
> 

-- 
Michal Hocko
SUSE Labs

  reply	other threads:[~2019-03-29  9:13 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-03-29  8:29 [PATCH v3 1/2] mm/sparse: Clean up the obsolete code comment Baoquan He
2019-03-29  8:29 ` [PATCH v3 2/2] drivers/base/memory.c: Rename the misleading parameter Baoquan He
2019-03-29  9:13   ` Michal Hocko [this message]
2019-03-29  9:19     ` Baoquan He
2019-03-29  9:37     ` Oscar Salvador
2019-03-29 12:55       ` Baoquan He
2019-03-29  9:36   ` [PATCH v4 " Baoquan He
2019-03-29 10:32     ` Oscar Salvador
2019-03-29 10:43     ` Mukesh Ojha
2019-03-29  9:14 ` [PATCH v3 1/2] mm/sparse: Clean up the obsolete code comment Michal Hocko
2019-03-29 10:36 ` Oscar Salvador
2019-03-29 13:59   ` Baoquan He
2019-03-29 10:40 ` Mukesh Ojha
2019-03-30  9:50 ` Mike Rapoport

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190329091325.GD28616@dhcp22.suse.cz \
    --to=mhocko@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=bhe@redhat.com \
    --cc=fanc.fnst@cn.fujitsu.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=osalvador@suse.de \
    --cc=rafael@kernel.org \
    --cc=rppt@linux.ibm.com \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.