All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Andrey Abramov <st5pub@yandex.ru>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 0/5] simple sort swap function improvements
Date: Mon, 1 Apr 2019 12:25:54 +0300	[thread overview]
Message-ID: <20190401092554.GC9224@smile.fi.intel.com> (raw)
In-Reply-To: <19606671554056883@myt3-1179f584969c.qloud-c.yandex.net>

On Sun, Mar 31, 2019 at 09:28:03PM +0300, Andrey Abramov wrote:
> This is the logical continuation of the "lib/sort & lib/list_sort:
> faster and smaller" series by George Spelvin (added to linux-next
> recently).
> 
> Since Spectre mitigations have made indirect function calls more
> expensive, and the previous patch series implements the default
> simple byte copies without them, an "optimized" custom swap
> function is now a waste of time as well as code.
> 
> Patches 1 to 4 replace trivial swap functions with the built-in
> (which is now much faster) and are grouped by subsystem.
> Being pure code deletion patches, they are sure to bring joy to
> Linus's heart.
> 
> Having reviewed all call sites, only three non-trivial swap
> functions remain:  arch/x86/kernel/unwind_orc.c,
> kernel/jump_label.c and lib/extable.c.
> 
> Patch #5 takes the opportunity to clean up a long-standing
> interface wart: the swap function's size parameter was an int,
> which doesn't match the size_t element size passed to sort()
> function itself.  So change it to size_t.
> 
> v1->v2: Only commit messages have changed to better explain
> 	the purpose of commits. (Thanks to George Spelvin and Greg KH)


Thanks for an update.

Hint:
scripts/get_maintainer.pl --git --git-min-percent=67 ...

(Note 67% magic value)

> 
> Andrey Abramov (5):
>   arch/arc: unwind.c: replace swap function with built-in one
>   powerpc: module_[32|64].c: replace swap function with built-in one
>   ocfs2: dir,refcounttree,xattr: replace swap functions with built-in
>     one
>   ubifs: find.c: replace swap function with built-in one
>   Lib: sort.h: replace int size with size_t size in the swap function
> 
>  arch/arc/kernel/unwind.c        | 20 ++------------------
>  arch/powerpc/kernel/module_32.c | 17 +----------------
>  arch/powerpc/kernel/module_64.c | 17 +----------------
>  arch/x86/kernel/unwind_orc.c    |  2 +-
>  fs/ocfs2/dir.c                  | 13 +------------
>  fs/ocfs2/refcounttree.c         | 13 +++----------
>  fs/ocfs2/xattr.c                | 15 +++------------
>  fs/ubifs/find.c                 |  9 +--------
>  include/linux/sort.h            |  2 +-
>  kernel/jump_label.c             |  2 +-
>  lib/extable.c                   |  2 +-
>  lib/sort.c                      |  6 +++---
>  12 files changed, 19 insertions(+), 99 deletions(-)
> 
> -- 
> 2.21.0
> 
> 

-- 
With Best Regards,
Andy Shevchenko



      parent reply	other threads:[~2019-04-01  9:25 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-03-31 18:28 [PATCH v2 0/5] simple sort swap function improvements Andrey Abramov
2019-03-31 18:28 ` Andrey Abramov
2019-03-31 18:28 ` Andrey Abramov
2019-03-31 18:31 ` [PATCH v2 1/5] arch/arc: unwind.c: replace swap function with built-in one Andrey Abramov
2019-03-31 18:31   ` Andrey Abramov
2019-03-31 18:31   ` Andrey Abramov
2019-04-01 17:53   ` Vineet Gupta
2019-04-01 17:53     ` Vineet Gupta
2019-04-01 17:53     ` Vineet Gupta
2019-03-31 18:35 ` [PATCH v2 2/5] powerpc: module_[32|64].c: " Andrey Abramov
2019-03-31 18:35   ` Andrey Abramov
2019-03-31 18:35   ` Andrey Abramov
2019-04-01 11:08   ` Michael Ellerman
2019-04-01 11:08     ` Michael Ellerman
2019-04-01 11:08     ` Michael Ellerman
2019-04-01 11:08     ` Michael Ellerman
2019-03-31 18:42 ` [PATCH v2 3/5] ocfs2: dir, refcounttree, xattr: replace swap functions " Andrey Abramov
2019-03-31 18:42   ` Andrey Abramov
2019-03-31 18:42   ` Andrey Abramov
2019-03-31 18:47 ` [PATCH v2 4/5] ubifs: find.c: replace swap function " Andrey Abramov
2019-03-31 18:47   ` Andrey Abramov
2019-03-31 18:47   ` Andrey Abramov
2019-03-31 18:52 ` [PATCH v2 5/5] Lib: sort.h: replace int size with size_t size in the swap function Andrey Abramov
2019-03-31 18:52   ` Andrey Abramov
2019-03-31 18:52   ` Andrey Abramov
2019-04-01  9:35   ` Andy Shevchenko
2019-04-01  9:35     ` Andy Shevchenko
2019-04-01  9:35     ` Andy Shevchenko
2019-04-01  9:35     ` Andy Shevchenko
2019-04-01  9:56     ` George Spelvin
2019-04-01  9:56       ` George Spelvin
2019-04-01  9:56       ` George Spelvin
2019-04-01  9:56       ` George Spelvin
2019-04-01 10:28       ` Andy Shevchenko
2019-04-01 10:28         ` Andy Shevchenko
2019-04-01 10:28         ` Andy Shevchenko
2019-04-01 10:28         ` Andy Shevchenko
2019-04-01  9:25 ` Andy Shevchenko [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190401092554.GC9224@smile.fi.intel.com \
    --to=andriy.shevchenko@linux.intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=st5pub@yandex.ru \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.