All of lore.kernel.org
 help / color / mirror / Atom feed
From: John Stultz <john.stultz@linaro.org>
To: lkml <linux-kernel@vger.kernel.org>
Cc: John Stultz <john.stultz@linaro.org>,
	Rongrong Zou <zourongrong@gmail.com>,
	Xinliang Liu <z.liuxinliang@hisilicon.com>,
	David Airlie <airlied@linux.ie>, Daniel Vetter <daniel@ffwll.ch>,
	dri-devel <dri-devel@lists.freedesktop.org>,
	Sam Ravnborg <sam@ravnborg.org>
Subject: [PATCH v4 02/25] drm: kirin: Remove HISI_KIRIN_DW_DSI config option
Date: Mon, 19 Aug 2019 23:02:58 +0000	[thread overview]
Message-ID: <20190819230321.56480-3-john.stultz@linaro.org> (raw)
In-Reply-To: <20190819230321.56480-1-john.stultz@linaro.org>

The CONFIG_HISI_KIRIN_DW_DSI option is only used w/ kirin
driver, so cut out the middleman and condense the config
logic down.

Cc: Rongrong Zou <zourongrong@gmail.com>
Cc: Xinliang Liu <z.liuxinliang@hisilicon.com>
Cc: David Airlie <airlied@linux.ie>
Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: dri-devel <dri-devel@lists.freedesktop.org>
Cc: Sam Ravnborg <sam@ravnborg.org>
Acked-by: Xinliang Liu <z.liuxinliang@hisilicon.com>
Reviewed-by: Sam Ravnborg <sam@ravnborg.org>
Signed-off-by: John Stultz <john.stultz@linaro.org>
---
 drivers/gpu/drm/hisilicon/kirin/Kconfig  | 10 +---------
 drivers/gpu/drm/hisilicon/kirin/Makefile |  4 ++--
 2 files changed, 3 insertions(+), 11 deletions(-)

diff --git a/drivers/gpu/drm/hisilicon/kirin/Kconfig b/drivers/gpu/drm/hisilicon/kirin/Kconfig
index 0fa29af08ad0..290553e2f6b4 100644
--- a/drivers/gpu/drm/hisilicon/kirin/Kconfig
+++ b/drivers/gpu/drm/hisilicon/kirin/Kconfig
@@ -5,16 +5,8 @@ config DRM_HISI_KIRIN
 	select DRM_KMS_HELPER
 	select DRM_GEM_CMA_HELPER
 	select DRM_KMS_CMA_HELPER
-	select HISI_KIRIN_DW_DSI
+	select DRM_MIPI_DSI
 	help
 	  Choose this option if you have a hisilicon Kirin chipsets(hi6220).
 	  If M is selected the module will be called kirin-drm.
 
-config HISI_KIRIN_DW_DSI
-	tristate "HiSilicon Kirin specific extensions for Synopsys DW MIPI DSI"
-	depends on DRM_HISI_KIRIN
-	select DRM_MIPI_DSI
-	help
-	 This selects support for HiSilicon Kirin SoC specific extensions for
-	 the Synopsys DesignWare DSI driver. If you want to enable MIPI DSI on
-	 hi6220 based SoC, you should selet this option.
diff --git a/drivers/gpu/drm/hisilicon/kirin/Makefile b/drivers/gpu/drm/hisilicon/kirin/Makefile
index c0501fa3fe53..c50606cfbbdb 100644
--- a/drivers/gpu/drm/hisilicon/kirin/Makefile
+++ b/drivers/gpu/drm/hisilicon/kirin/Makefile
@@ -1,7 +1,7 @@
 # SPDX-License-Identifier: GPL-2.0-only
 kirin-drm-y := kirin_drm_drv.o \
-	       kirin_drm_ade.o
+	       kirin_drm_ade.o \
+	       dw_drm_dsi.o
 
 obj-$(CONFIG_DRM_HISI_KIRIN) += kirin-drm.o
 
-obj-$(CONFIG_HISI_KIRIN_DW_DSI) += dw_drm_dsi.o
-- 
2.17.1


  parent reply	other threads:[~2019-08-19 23:03 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-19 23:02 [PATCH v4 00/25] drm: Kirin driver cleanups to prep for Kirin960 support John Stultz
2019-08-19 23:02 ` [PATCH v4 01/25] drm: kirin: Fix for hikey620 display offset problem John Stultz
2019-08-19 23:02 ` John Stultz [this message]
2019-08-19 23:02 ` [PATCH v4 03/25] drm: kirin: Remove unreachable return John Stultz
2019-08-19 23:02   ` John Stultz
2019-08-19 23:03 ` [PATCH v4 04/25] drm: kirin: Remove uncessary parameter indirection John Stultz
2019-08-19 23:03 ` [PATCH v4 05/25] drm: kirin: Remove out_format from ade_crtc John Stultz
2019-08-19 23:03 ` [PATCH v4 06/25] drm: kirin: Rename ade_plane to kirin_plane John Stultz
2019-08-19 23:03 ` [PATCH v4 07/25] drm: kirin: Rename ade_crtc to kirin_crtc John Stultz
2019-08-19 23:03 ` [PATCH v4 08/25] drm: kirin: Dynamically allocate the hw_ctx John Stultz
2019-08-19 23:03 ` [PATCH v4 09/25] drm: kirin: Move request irq handle in ade hw ctx alloc John Stultz
2019-08-19 23:03 ` [PATCH v4 10/25] drm: kirin: Move workqueue to ade_hw_ctx structure John Stultz
2019-08-19 23:03   ` John Stultz
2019-08-19 23:03 ` [PATCH v4 11/25] drm: kirin: Move kirin_crtc, kirin_plane, kirin_format to kirin_drm_drv.h John Stultz
2019-08-19 23:03   ` John Stultz
2019-08-19 23:03 ` [PATCH v4 12/25] drm: kirin: Reanme dc_ops to kirin_drm_data John Stultz
2019-08-19 23:03 ` [PATCH v4 13/25] drm: kirin: Move ade crtc/plane help functions to driver_data John Stultz
2019-08-19 23:03 ` [PATCH v4 14/25] drm: kirin: Move channel formats to driver data John Stultz
2019-08-19 23:03 ` [PATCH v4 15/25] drm: kirin: Move mode config function to driver_data John Stultz
2019-08-19 23:03   ` John Stultz
2019-08-19 23:03 ` [PATCH v4 16/25] drm: kirin: Move plane number and primay plane in driver data John Stultz
2019-08-19 23:03   ` John Stultz
2019-08-19 23:03 ` [PATCH v4 17/25] drm: kirin: Move config max_width and max_height to " John Stultz
2019-08-19 23:03 ` [PATCH v4 18/25] drm: kirin: Move drm driver " John Stultz
2019-08-19 23:03   ` John Stultz
2019-08-19 23:03 ` [PATCH v4 19/25] drm: kirin: Add register connect helper functions in drm init John Stultz
2019-08-19 23:03 ` [PATCH v4 20/25] drm: kirin: Rename plane_init and crtc_init John Stultz
2019-08-19 23:03 ` [PATCH v4 21/25] drm: kirin: Fix dev->driver_data setting John Stultz
2019-08-19 23:03 ` [PATCH v4 22/25] drm: kirin: Make driver_data variable non-global John Stultz
2019-08-19 23:03 ` [PATCH v4 23/25] drm: kirin: Add alloc_hw_ctx/clean_hw_ctx ops in driver data John Stultz
2019-08-19 23:03 ` [PATCH v4 24/25] drm: kirin: Pass driver data to crtc init and plane init John Stultz
2019-08-19 23:03 ` [PATCH v4 25/25] drm: kirin: Move ade drm init to kirin drm drv John Stultz
2019-08-20 20:01 ` [PATCH v4 00/25] drm: Kirin driver cleanups to prep for Kirin960 support Sam Ravnborg
2019-08-20 20:01   ` Sam Ravnborg
2019-08-20 20:38   ` John Stultz
2019-08-20 20:38     ` John Stultz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190819230321.56480-3-john.stultz@linaro.org \
    --to=john.stultz@linaro.org \
    --cc=airlied@linux.ie \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sam@ravnborg.org \
    --cc=z.liuxinliang@hisilicon.com \
    --cc=zourongrong@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.