From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-5.2 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, INCLUDES_PATCH,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS,USER_AGENT_SANE_1 autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 814F4C4CED1 for ; Fri, 4 Oct 2019 19:45:58 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 65AE4222C0 for ; Fri, 4 Oct 2019 19:45:58 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1730340AbfJDTp5 (ORCPT ); Fri, 4 Oct 2019 15:45:57 -0400 Received: from mx2.suse.de ([195.135.220.15]:51634 "EHLO mx1.suse.de" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1729586AbfJDTp5 (ORCPT ); Fri, 4 Oct 2019 15:45:57 -0400 X-Virus-Scanned: by amavisd-new at test-mx.suse.de Received: from relay2.suse.de (unknown [195.135.220.254]) by mx1.suse.de (Postfix) with ESMTP id 95809AC2E; Fri, 4 Oct 2019 19:45:55 +0000 (UTC) Date: Fri, 4 Oct 2019 12:44:46 -0700 From: Davidlohr Bueso To: Michel Lespinasse Cc: akpm@linux-foundation.org, peterz@infradead.org, linux-kernel@vger.kernel.org, linux-mm@kvack.org, dri-devel@lists.freedesktop.org, linux-rdma@vger.kernel.org, Michael@google.com, Jason Wang , virtualization@lists.linux-foundation.org, Davidlohr Bueso Subject: Re: [PATCH 07/11] vhost: convert vhost_umem_interval_tree to half closed intervals Message-ID: <20191004194446.tomd55ll4nlkelb6@linux-p48b> Mail-Followup-To: Michel Lespinasse , akpm@linux-foundation.org, peterz@infradead.org, linux-kernel@vger.kernel.org, linux-mm@kvack.org, dri-devel@lists.freedesktop.org, linux-rdma@vger.kernel.org, Michael@google.com, Jason Wang , virtualization@lists.linux-foundation.org, Davidlohr Bueso References: <20191003201858.11666-1-dave@stgolabs.net> <20191003201858.11666-8-dave@stgolabs.net> <20191004121021.GA4541@google.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii; format=flowed Content-Disposition: inline In-Reply-To: <20191004121021.GA4541@google.com> User-Agent: NeoMutt/20180716 Sender: linux-rdma-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-rdma@vger.kernel.org On Fri, 04 Oct 2019, Michel Lespinasse wrote: >On Thu, Oct 03, 2019 at 01:18:54PM -0700, Davidlohr Bueso wrote: >> @@ -1320,15 +1320,14 @@ static bool iotlb_access_ok(struct vhost_virtqueue *vq, >> { >> const struct vhost_umem_node *node; >> struct vhost_umem *umem = vq->iotlb; >> - u64 s = 0, size, orig_addr = addr, last = addr + len - 1; >> + u64 s = 0, size, orig_addr = addr, last = addr + len; > >maybe "end" or "end_addr" instead of "last". > >> diff --git a/drivers/vhost/vhost.h b/drivers/vhost/vhost.h >> index e9ed2722b633..bb36cb9ed5ec 100644 >> --- a/drivers/vhost/vhost.h >> +++ b/drivers/vhost/vhost.h >> @@ -53,13 +53,13 @@ struct vhost_log { >> }; >> >> #define START(node) ((node)->start) >> -#define LAST(node) ((node)->last) >> +#define END(node) ((node)->end) >> >> struct vhost_umem_node { >> struct rb_node rb; >> struct list_head link; >> __u64 start; >> - __u64 last; >> + __u64 end; >> __u64 size; >> __u64 userspace_addr; >> __u32 perm; > >Preferably also rename __subtree_last to __subtree_end Yes, this was was another one that I had in mind renaming, but didn't want to grow the series -- all custom interval trees name _last for the subtree iirc. Like my previous reply, I'd rather leave this stuff for a followup series. Thanks, Davidlohr From mboxrd@z Thu Jan 1 00:00:00 1970 From: Davidlohr Bueso Subject: Re: [PATCH 07/11] vhost: convert vhost_umem_interval_tree to half closed intervals Date: Fri, 4 Oct 2019 12:44:46 -0700 Message-ID: <20191004194446.tomd55ll4nlkelb6@linux-p48b> References: <20191003201858.11666-1-dave@stgolabs.net> <20191003201858.11666-8-dave@stgolabs.net> <20191004121021.GA4541@google.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii"; Format="flowed" Content-Transfer-Encoding: 7bit Return-path: Content-Disposition: inline In-Reply-To: <20191004121021.GA4541@google.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: virtualization-bounces@lists.linux-foundation.org Errors-To: virtualization-bounces@lists.linux-foundation.org To: Michel Lespinasse Cc: Michael@google.com, peterz@infradead.org, Davidlohr Bueso , linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org, virtualization@lists.linux-foundation.org, linux-mm@kvack.org, akpm@linux-foundation.org, linux-rdma@vger.kernel.org List-Id: virtualization@lists.linuxfoundation.org On Fri, 04 Oct 2019, Michel Lespinasse wrote: >On Thu, Oct 03, 2019 at 01:18:54PM -0700, Davidlohr Bueso wrote: >> @@ -1320,15 +1320,14 @@ static bool iotlb_access_ok(struct vhost_virtqueue *vq, >> { >> const struct vhost_umem_node *node; >> struct vhost_umem *umem = vq->iotlb; >> - u64 s = 0, size, orig_addr = addr, last = addr + len - 1; >> + u64 s = 0, size, orig_addr = addr, last = addr + len; > >maybe "end" or "end_addr" instead of "last". > >> diff --git a/drivers/vhost/vhost.h b/drivers/vhost/vhost.h >> index e9ed2722b633..bb36cb9ed5ec 100644 >> --- a/drivers/vhost/vhost.h >> +++ b/drivers/vhost/vhost.h >> @@ -53,13 +53,13 @@ struct vhost_log { >> }; >> >> #define START(node) ((node)->start) >> -#define LAST(node) ((node)->last) >> +#define END(node) ((node)->end) >> >> struct vhost_umem_node { >> struct rb_node rb; >> struct list_head link; >> __u64 start; >> - __u64 last; >> + __u64 end; >> __u64 size; >> __u64 userspace_addr; >> __u32 perm; > >Preferably also rename __subtree_last to __subtree_end Yes, this was was another one that I had in mind renaming, but didn't want to grow the series -- all custom interval trees name _last for the subtree iirc. Like my previous reply, I'd rather leave this stuff for a followup series. Thanks, Davidlohr