From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-8.2 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, INCLUDES_PATCH,MAILING_LIST_MULTI,SIGNED_OFF_BY,SPF_HELO_NONE,SPF_PASS, USER_AGENT_SANE_1 autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id E69F5CA9EAF for ; Thu, 24 Oct 2019 15:36:41 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id C33A621872 for ; Thu, 24 Oct 2019 15:36:41 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S2503308AbfJXPgl (ORCPT ); Thu, 24 Oct 2019 11:36:41 -0400 Received: from foss.arm.com ([217.140.110.172]:54640 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S2503224AbfJXPgl (ORCPT ); Thu, 24 Oct 2019 11:36:41 -0400 Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 1A6EB31F; Thu, 24 Oct 2019 08:36:25 -0700 (PDT) Received: from bogus (e107155-lin.cambridge.arm.com [10.1.196.42]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id 2B1A03F71F; Thu, 24 Oct 2019 08:36:23 -0700 (PDT) Date: Thu, 24 Oct 2019 16:36:21 +0100 From: Sudeep Holla To: Ulf Hansson Cc: "Rafael J . Wysocki" , Daniel Lezcano , Lorenzo Pieralisi , Mark Rutland , Lina Iyer , linux-pm@vger.kernel.org, Rob Herring , Vincent Guittot , Stephen Boyd , Bjorn Andersson , Sudeep Holla , Kevin Hilman , linux-arm-kernel@lists.infradead.org, linux-arm-msm@vger.kernel.org Subject: Re: [PATCH 06/13] cpuidle: psci: Simplify OF parsing of CPU idle state nodes Message-ID: <20191024153621.GE11467@bogus> References: <20191010113937.15962-1-ulf.hansson@linaro.org> <20191010113937.15962-7-ulf.hansson@linaro.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20191010113937.15962-7-ulf.hansson@linaro.org> User-Agent: Mutt/1.9.4 (2018-02-28) Sender: linux-arm-msm-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-arm-msm@vger.kernel.org On Thu, Oct 10, 2019 at 01:39:30PM +0200, Ulf Hansson wrote: > Iterating through the idle state nodes in DT, to find out the number of > states that needs to be allocated is unnecessary, as it has already been > done from dt_init_idle_driver(). Therefore, drop the iteration and use the > number we already have at hand. > > Signed-off-by: Ulf Hansson > --- > drivers/cpuidle/cpuidle-psci.c | 33 ++++++++++++++++----------------- > 1 file changed, 16 insertions(+), 17 deletions(-) > > diff --git a/drivers/cpuidle/cpuidle-psci.c b/drivers/cpuidle/cpuidle-psci.c > index 2e91c8d6c211..1195a1056139 100644 > --- a/drivers/cpuidle/cpuidle-psci.c > +++ b/drivers/cpuidle/cpuidle-psci.c > @@ -73,28 +73,22 @@ static int __init psci_dt_parse_state_node(struct device_node *np, u32 *state) > return 0; > } > > -static int __init psci_dt_cpu_init_idle(struct device_node *cpu_node, int cpu) > +static int __init psci_dt_cpu_init_idle(struct device_node *cpu_node, > + unsigned int state_nodes, int cpu) [super nit] Too much in the beginning of the patch to not notice this ;) May need some '(' alignment here and other places in general. > { > - int i, ret = 0, count = 0; > + int i, ret = 0; > u32 *psci_states; > struct device_node *state_node; > > - /* Count idle states */ > - while ((state_node = of_parse_phandle(cpu_node, "cpu-idle-states", > - count))) { > - count++; > - of_node_put(state_node); > - } > - > - if (!count) > - return -ENODEV; > - > - psci_states = kcalloc(count, sizeof(*psci_states), GFP_KERNEL); > + psci_states = kcalloc(state_nodes, sizeof(*psci_states), GFP_KERNEL); > if (!psci_states) > return -ENOMEM; > > - for (i = 0; i < count; i++) { > + for (i = 0; i < state_nodes; i++) { > state_node = of_parse_phandle(cpu_node, "cpu-idle-states", i); Can we move above to use of_get_cpu_state_node ? Since it also handles domain-idle-states. > + if (!state_node) > + break; > + > ret = psci_dt_parse_state_node(state_node, &psci_states[i]); > of_node_put(state_node); > > @@ -104,6 +98,11 @@ static int __init psci_dt_cpu_init_idle(struct device_node *cpu_node, int cpu) > pr_debug("psci-power-state %#x index %d\n", psci_states[i], i); > } > > + if (i != state_nodes) { > + ret = -ENODEV; > + goto free_mem; > + } > + > /* Idle states parsed correctly, initialize per-cpu pointer */ > per_cpu(psci_power_state, cpu) = psci_states; > return 0; > @@ -113,7 +112,7 @@ static int __init psci_dt_cpu_init_idle(struct device_node *cpu_node, int cpu) > return ret; > } > > -static __init int psci_cpu_init_idle(unsigned int cpu) > +static __init int psci_cpu_init_idle(unsigned int cpu, unsigned int state_nodes) Does it make sense to rename it as state_count or something similar ? And it may need + 1 once we add wfi also as entry as suggested by Lorenzo. -- Regards, Sudeep From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-8.3 required=3.0 tests=DKIMWL_WL_HIGH,DKIM_SIGNED, DKIM_VALID,HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_PATCH,MAILING_LIST_MULTI, SIGNED_OFF_BY,SPF_HELO_NONE,SPF_PASS,USER_AGENT_SANE_1 autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 4738CCA9EBC for ; Thu, 24 Oct 2019 15:36:46 +0000 (UTC) Received: from bombadil.infradead.org (bombadil.infradead.org [198.137.202.133]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPS id 0CF3921655 for ; Thu, 24 Oct 2019 15:36:46 +0000 (UTC) Authentication-Results: mail.kernel.org; dkim=pass (2048-bit key) header.d=lists.infradead.org header.i=@lists.infradead.org header.b="nVXBxFVO" DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 0CF3921655 Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=arm.com Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=linux-arm-kernel-bounces+infradead-linux-arm-kernel=archiver.kernel.org@lists.infradead.org DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lists.infradead.org; s=bombadil.20170209; h=Sender: Content-Transfer-Encoding:Content-Type:Cc:List-Subscribe:List-Help:List-Post: List-Archive:List-Unsubscribe:List-Id:In-Reply-To:MIME-Version:References: Message-ID:Subject:To:From:Date:Reply-To:Content-ID:Content-Description: Resent-Date:Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID: List-Owner; bh=xMy+U1O/z/mt0uKfhV2Ti4Oz3pim9sGkWYqwD4jAAPw=; b=nVXBxFVOM06EwI sxtr++0gbNUHUcLKgwy3TkCe1QTzeGFQMd52Hy7Q1BqgJEFGJOd5Iyb6gp2QfaRvLXrAMLOQGX9Vy 70r8cpqvpaWIPnSQY1gar5NTa5XAV3hmE0nLvux7wEEj0SR0PLB/xIlC1i12c4rr2QfXuZS/daYZV gnwTKrWNrqZqDDtJVM/1s1Cn70a5FnF42tsgRCo1xuF6x8jjjnR3urqCRIUToKAFCl6neMdJI6CSX unsiymgn6Wc1VzLTWvyekEO7e+BXqhnOhbYT3+rIHW/6OmeS0Nk1oxDzDO6aV2j4v2jchaC2rFEIU OH/ndTJlHHCrnFM0rtaw==; Received: from localhost ([127.0.0.1] helo=bombadil.infradead.org) by bombadil.infradead.org with esmtp (Exim 4.92.3 #3 (Red Hat Linux)) id 1iNfAE-00055K-Cl; Thu, 24 Oct 2019 15:36:38 +0000 Received: from [217.140.110.172] (helo=foss.arm.com) by bombadil.infradead.org with esmtp (Exim 4.92.3 #3 (Red Hat Linux)) id 1iNfAB-00053z-Qy for linux-arm-kernel@lists.infradead.org; Thu, 24 Oct 2019 15:36:37 +0000 Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 1A6EB31F; Thu, 24 Oct 2019 08:36:25 -0700 (PDT) Received: from bogus (e107155-lin.cambridge.arm.com [10.1.196.42]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id 2B1A03F71F; Thu, 24 Oct 2019 08:36:23 -0700 (PDT) Date: Thu, 24 Oct 2019 16:36:21 +0100 From: Sudeep Holla To: Ulf Hansson Subject: Re: [PATCH 06/13] cpuidle: psci: Simplify OF parsing of CPU idle state nodes Message-ID: <20191024153621.GE11467@bogus> References: <20191010113937.15962-1-ulf.hansson@linaro.org> <20191010113937.15962-7-ulf.hansson@linaro.org> MIME-Version: 1.0 Content-Disposition: inline In-Reply-To: <20191010113937.15962-7-ulf.hansson@linaro.org> User-Agent: Mutt/1.9.4 (2018-02-28) X-CRM114-Version: 20100106-BlameMichelson ( TRE 0.8.0 (BSD) ) MR-646709E3 X-CRM114-CacheID: sfid-20191024_083635_964951_DD8E7352 X-CRM114-Status: GOOD ( 21.13 ) X-BeenThere: linux-arm-kernel@lists.infradead.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: Mark Rutland , Lorenzo Pieralisi , linux-pm@vger.kernel.org, Stephen Boyd , linux-arm-msm@vger.kernel.org, Daniel Lezcano , "Rafael J . Wysocki" , Lina Iyer , Bjorn Andersson , Kevin Hilman , Rob Herring , Sudeep Holla , linux-arm-kernel@lists.infradead.org Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Sender: "linux-arm-kernel" Errors-To: linux-arm-kernel-bounces+infradead-linux-arm-kernel=archiver.kernel.org@lists.infradead.org On Thu, Oct 10, 2019 at 01:39:30PM +0200, Ulf Hansson wrote: > Iterating through the idle state nodes in DT, to find out the number of > states that needs to be allocated is unnecessary, as it has already been > done from dt_init_idle_driver(). Therefore, drop the iteration and use the > number we already have at hand. > > Signed-off-by: Ulf Hansson > --- > drivers/cpuidle/cpuidle-psci.c | 33 ++++++++++++++++----------------- > 1 file changed, 16 insertions(+), 17 deletions(-) > > diff --git a/drivers/cpuidle/cpuidle-psci.c b/drivers/cpuidle/cpuidle-psci.c > index 2e91c8d6c211..1195a1056139 100644 > --- a/drivers/cpuidle/cpuidle-psci.c > +++ b/drivers/cpuidle/cpuidle-psci.c > @@ -73,28 +73,22 @@ static int __init psci_dt_parse_state_node(struct device_node *np, u32 *state) > return 0; > } > > -static int __init psci_dt_cpu_init_idle(struct device_node *cpu_node, int cpu) > +static int __init psci_dt_cpu_init_idle(struct device_node *cpu_node, > + unsigned int state_nodes, int cpu) [super nit] Too much in the beginning of the patch to not notice this ;) May need some '(' alignment here and other places in general. > { > - int i, ret = 0, count = 0; > + int i, ret = 0; > u32 *psci_states; > struct device_node *state_node; > > - /* Count idle states */ > - while ((state_node = of_parse_phandle(cpu_node, "cpu-idle-states", > - count))) { > - count++; > - of_node_put(state_node); > - } > - > - if (!count) > - return -ENODEV; > - > - psci_states = kcalloc(count, sizeof(*psci_states), GFP_KERNEL); > + psci_states = kcalloc(state_nodes, sizeof(*psci_states), GFP_KERNEL); > if (!psci_states) > return -ENOMEM; > > - for (i = 0; i < count; i++) { > + for (i = 0; i < state_nodes; i++) { > state_node = of_parse_phandle(cpu_node, "cpu-idle-states", i); Can we move above to use of_get_cpu_state_node ? Since it also handles domain-idle-states. > + if (!state_node) > + break; > + > ret = psci_dt_parse_state_node(state_node, &psci_states[i]); > of_node_put(state_node); > > @@ -104,6 +98,11 @@ static int __init psci_dt_cpu_init_idle(struct device_node *cpu_node, int cpu) > pr_debug("psci-power-state %#x index %d\n", psci_states[i], i); > } > > + if (i != state_nodes) { > + ret = -ENODEV; > + goto free_mem; > + } > + > /* Idle states parsed correctly, initialize per-cpu pointer */ > per_cpu(psci_power_state, cpu) = psci_states; > return 0; > @@ -113,7 +112,7 @@ static int __init psci_dt_cpu_init_idle(struct device_node *cpu_node, int cpu) > return ret; > } > > -static __init int psci_cpu_init_idle(unsigned int cpu) > +static __init int psci_cpu_init_idle(unsigned int cpu, unsigned int state_nodes) Does it make sense to rename it as state_count or something similar ? And it may need + 1 once we add wfi also as entry as suggested by Lorenzo. -- Regards, Sudeep _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel