All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/2] devlink: correct misspelling of snapshot
@ 2020-01-09 19:08 Jacob Keller
  2020-01-09 19:08 ` [PATCH 2/2] doc: fix typo of snapshot in documentation Jacob Keller
                   ` (2 more replies)
  0 siblings, 3 replies; 10+ messages in thread
From: Jacob Keller @ 2020-01-09 19:08 UTC (permalink / raw)
  To: netdev; +Cc: valex, jiri, Jacob Keller

The function to obtain a unique snapshot id was mistakenly typo'd as
devlink_region_shapshot_id_get. Fix this typo by renaming the function
and all of its users.

Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>
---
 drivers/net/ethernet/mellanox/mlx4/crdump.c | 2 +-
 drivers/net/netdevsim/dev.c                 | 2 +-
 include/net/devlink.h                       | 2 +-
 net/core/devlink.c                          | 6 +++---
 4 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/net/ethernet/mellanox/mlx4/crdump.c b/drivers/net/ethernet/mellanox/mlx4/crdump.c
index eaf08f7ad128..64ed725aec28 100644
--- a/drivers/net/ethernet/mellanox/mlx4/crdump.c
+++ b/drivers/net/ethernet/mellanox/mlx4/crdump.c
@@ -182,7 +182,7 @@ int mlx4_crdump_collect(struct mlx4_dev *dev)
 	crdump_enable_crspace_access(dev, cr_space);
 
 	/* Get the available snapshot ID for the dumps */
-	id = devlink_region_shapshot_id_get(devlink);
+	id = devlink_region_snapshot_id_get(devlink);
 
 	/* Try to capture dumps */
 	mlx4_crdump_collect_crspace(dev, cr_space, id);
diff --git a/drivers/net/netdevsim/dev.c b/drivers/net/netdevsim/dev.c
index 059711edfc61..4b39aba2e9c4 100644
--- a/drivers/net/netdevsim/dev.c
+++ b/drivers/net/netdevsim/dev.c
@@ -53,7 +53,7 @@ static ssize_t nsim_dev_take_snapshot_write(struct file *file,
 
 	get_random_bytes(dummy_data, NSIM_DEV_DUMMY_REGION_SIZE);
 
-	id = devlink_region_shapshot_id_get(priv_to_devlink(nsim_dev));
+	id = devlink_region_snapshot_id_get(priv_to_devlink(nsim_dev));
 	err = devlink_region_snapshot_create(nsim_dev->dummy_region,
 					     dummy_data, id, kfree);
 	if (err) {
diff --git a/include/net/devlink.h b/include/net/devlink.h
index 47f87b2fcf63..38b4acb93f74 100644
--- a/include/net/devlink.h
+++ b/include/net/devlink.h
@@ -938,7 +938,7 @@ struct devlink_region *devlink_region_create(struct devlink *devlink,
 					     u32 region_max_snapshots,
 					     u64 region_size);
 void devlink_region_destroy(struct devlink_region *region);
-u32 devlink_region_shapshot_id_get(struct devlink *devlink);
+u32 devlink_region_snapshot_id_get(struct devlink *devlink);
 int devlink_region_snapshot_create(struct devlink_region *region,
 				   u8 *data, u32 snapshot_id,
 				   devlink_snapshot_data_dest_t *data_destructor);
diff --git a/net/core/devlink.c b/net/core/devlink.c
index 4c63c9a4c09e..b6fc67dbd612 100644
--- a/net/core/devlink.c
+++ b/net/core/devlink.c
@@ -7563,7 +7563,7 @@ void devlink_region_destroy(struct devlink_region *region)
 EXPORT_SYMBOL_GPL(devlink_region_destroy);
 
 /**
- *	devlink_region_shapshot_id_get - get snapshot ID
+ *	devlink_region_snapshot_id_get - get snapshot ID
  *
  *	This callback should be called when adding a new snapshot,
  *	Driver should use the same id for multiple snapshots taken
@@ -7571,7 +7571,7 @@ EXPORT_SYMBOL_GPL(devlink_region_destroy);
  *
  *	@devlink: devlink
  */
-u32 devlink_region_shapshot_id_get(struct devlink *devlink)
+u32 devlink_region_snapshot_id_get(struct devlink *devlink)
 {
 	u32 id;
 
@@ -7581,7 +7581,7 @@ u32 devlink_region_shapshot_id_get(struct devlink *devlink)
 
 	return id;
 }
-EXPORT_SYMBOL_GPL(devlink_region_shapshot_id_get);
+EXPORT_SYMBOL_GPL(devlink_region_snapshot_id_get);
 
 /**
  *	devlink_region_snapshot_create - create a new snapshot
-- 
2.25.0.rc1


^ permalink raw reply related	[flat|nested] 10+ messages in thread

* [PATCH 2/2] doc: fix typo of snapshot in documentation
  2020-01-09 19:08 [PATCH 1/2] devlink: correct misspelling of snapshot Jacob Keller
@ 2020-01-09 19:08 ` Jacob Keller
  2020-01-09 20:00   ` Stephen Hemminger
  2020-01-11  0:49   ` David Miller
  2020-01-10  9:36 ` [PATCH 1/2] devlink: correct misspelling of snapshot Jiri Pirko
  2020-01-11  0:49 ` David Miller
  2 siblings, 2 replies; 10+ messages in thread
From: Jacob Keller @ 2020-01-09 19:08 UTC (permalink / raw)
  To: netdev; +Cc: valex, jiri, Jacob Keller

A couple of locations accidentally misspelled snapshot as shapshot.

Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>
---
 Documentation/admin-guide/devices.txt    | 2 +-
 Documentation/media/v4l-drivers/meye.rst | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/Documentation/admin-guide/devices.txt b/Documentation/admin-guide/devices.txt
index 1c5d2281efc9..2a97aaec8b12 100644
--- a/Documentation/admin-guide/devices.txt
+++ b/Documentation/admin-guide/devices.txt
@@ -319,7 +319,7 @@
 		182 = /dev/perfctr	Performance-monitoring counters
 		183 = /dev/hwrng	Generic random number generator
 		184 = /dev/cpu/microcode CPU microcode update interface
-		186 = /dev/atomicps	Atomic shapshot of process state data
+		186 = /dev/atomicps	Atomic snapshot of process state data
 		187 = /dev/irnet	IrNET device
 		188 = /dev/smbusbios	SMBus BIOS
 		189 = /dev/ussp_ctl	User space serial port control
diff --git a/Documentation/media/v4l-drivers/meye.rst b/Documentation/media/v4l-drivers/meye.rst
index a572996cdbf6..dc57a6a91b43 100644
--- a/Documentation/media/v4l-drivers/meye.rst
+++ b/Documentation/media/v4l-drivers/meye.rst
@@ -95,7 +95,7 @@ so all video4linux tools (like xawtv) should work with this driver.
 
 Besides the video4linux interface, the driver has a private interface
 for accessing the Motion Eye extended parameters (camera sharpness,
-agc, video framerate), the shapshot and the MJPEG capture facilities.
+agc, video framerate), the snapshot and the MJPEG capture facilities.
 
 This interface consists of several ioctls (prototypes and structures
 can be found in include/linux/meye.h):
-- 
2.25.0.rc1


^ permalink raw reply related	[flat|nested] 10+ messages in thread

* Re: [PATCH 2/2] doc: fix typo of snapshot in documentation
  2020-01-09 19:08 ` [PATCH 2/2] doc: fix typo of snapshot in documentation Jacob Keller
@ 2020-01-09 20:00   ` Stephen Hemminger
  2020-01-09 20:06     ` Jacob Keller
  2020-01-11  0:49   ` David Miller
  1 sibling, 1 reply; 10+ messages in thread
From: Stephen Hemminger @ 2020-01-09 20:00 UTC (permalink / raw)
  To: Jacob Keller; +Cc: netdev, valex, jiri

On Thu,  9 Jan 2020 11:08:21 -0800
Jacob Keller <jacob.e.keller@intel.com> wrote:

> A couple of locations accidentally misspelled snapshot as shapshot.
> 
> Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>
> ---
>  Documentation/admin-guide/devices.txt    | 2 +-
>  Documentation/media/v4l-drivers/meye.rst | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/Documentation/admin-guide/devices.txt b/Documentation/admin-guide/devices.txt
> index 1c5d2281efc9..2a97aaec8b12 100644
> --- a/Documentation/admin-guide/devices.txt
> +++ b/Documentation/admin-guide/devices.txt
> @@ -319,7 +319,7 @@
>  		182 = /dev/perfctr	Performance-monitoring counters
>  		183 = /dev/hwrng	Generic random number generator
>  		184 = /dev/cpu/microcode CPU microcode update interface
> -		186 = /dev/atomicps	Atomic shapshot of process state data
> +		186 = /dev/atomicps	Atomic snapshot of process state data
>  		187 = /dev/irnet	IrNET device

Oops, irnet is part of irda which is no longer part of the kernel.

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH 2/2] doc: fix typo of snapshot in documentation
  2020-01-09 20:00   ` Stephen Hemminger
@ 2020-01-09 20:06     ` Jacob Keller
  2020-01-09 20:11       ` Jacob Keller
  0 siblings, 1 reply; 10+ messages in thread
From: Jacob Keller @ 2020-01-09 20:06 UTC (permalink / raw)
  To: Stephen Hemminger; +Cc: netdev, valex, jiri

On 1/9/2020 12:00 PM, Stephen Hemminger wrote:
> On Thu,  9 Jan 2020 11:08:21 -0800
> Jacob Keller <jacob.e.keller@intel.com> wrote:
> 
>> A couple of locations accidentally misspelled snapshot as shapshot.
>>
>> Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>
>> ---
>>  Documentation/admin-guide/devices.txt    | 2 +-
>>  Documentation/media/v4l-drivers/meye.rst | 2 +-
>>  2 files changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/Documentation/admin-guide/devices.txt b/Documentation/admin-guide/devices.txt
>> index 1c5d2281efc9..2a97aaec8b12 100644
>> --- a/Documentation/admin-guide/devices.txt
>> +++ b/Documentation/admin-guide/devices.txt
>> @@ -319,7 +319,7 @@
>>  		182 = /dev/perfctr	Performance-monitoring counters
>>  		183 = /dev/hwrng	Generic random number generator
>>  		184 = /dev/cpu/microcode CPU microcode update interface
>> -		186 = /dev/atomicps	Atomic shapshot of process state data
>> +		186 = /dev/atomicps	Atomic snapshot of process state data
>>  		187 = /dev/irnet	IrNET device
> 
> Oops, irnet is part of irda which is no longer part of the kernel.
> 

This is probably based on the wrong tree. Will rebase and re-send.

Thanks,
Jake

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH 2/2] doc: fix typo of snapshot in documentation
  2020-01-09 20:06     ` Jacob Keller
@ 2020-01-09 20:11       ` Jacob Keller
  2020-01-09 20:36         ` Stephen Hemminger
  0 siblings, 1 reply; 10+ messages in thread
From: Jacob Keller @ 2020-01-09 20:11 UTC (permalink / raw)
  To: Stephen Hemminger; +Cc: netdev, valex, jiri

On 1/9/2020 12:06 PM, Jacob Keller wrote:
> On 1/9/2020 12:00 PM, Stephen Hemminger wrote:
>> On Thu,  9 Jan 2020 11:08:21 -0800
>> Jacob Keller <jacob.e.keller@intel.com> wrote:
>>
>>> A couple of locations accidentally misspelled snapshot as shapshot.
>>>
>>> Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>
>>> ---
>>>  Documentation/admin-guide/devices.txt    | 2 +-
>>>  Documentation/media/v4l-drivers/meye.rst | 2 +-
>>>  2 files changed, 2 insertions(+), 2 deletions(-)
>>>
>>> diff --git a/Documentation/admin-guide/devices.txt b/Documentation/admin-guide/devices.txt
>>> index 1c5d2281efc9..2a97aaec8b12 100644
>>> --- a/Documentation/admin-guide/devices.txt
>>> +++ b/Documentation/admin-guide/devices.txt
>>> @@ -319,7 +319,7 @@
>>>  		182 = /dev/perfctr	Performance-monitoring counters
>>>  		183 = /dev/hwrng	Generic random number generator
>>>  		184 = /dev/cpu/microcode CPU microcode update interface
>>> -		186 = /dev/atomicps	Atomic shapshot of process state data
>>> +		186 = /dev/atomicps	Atomic snapshot of process state data
>>>  		187 = /dev/irnet	IrNET device
>>
>> Oops, irnet is part of irda which is no longer part of the kernel.
>>
> 
> This is probably based on the wrong tree. Will rebase and re-send.
> 
> Thanks,
> Jake>

Well, I did rebase the patches locally but the contents are still the
same so I'm not going to resend. I guess it's just because the
devices.txt file hasn't been updated?

-Jake

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH 2/2] doc: fix typo of snapshot in documentation
  2020-01-09 20:11       ` Jacob Keller
@ 2020-01-09 20:36         ` Stephen Hemminger
  0 siblings, 0 replies; 10+ messages in thread
From: Stephen Hemminger @ 2020-01-09 20:36 UTC (permalink / raw)
  To: Jacob Keller; +Cc: netdev, valex, jiri

On Thu, 9 Jan 2020 12:11:36 -0800
Jacob Keller <jacob.e.keller@intel.com> wrote:

> On 1/9/2020 12:06 PM, Jacob Keller wrote:
> > On 1/9/2020 12:00 PM, Stephen Hemminger wrote:  
> >> On Thu,  9 Jan 2020 11:08:21 -0800
> >> Jacob Keller <jacob.e.keller@intel.com> wrote:
> >>  
> >>> A couple of locations accidentally misspelled snapshot as shapshot.
> >>>
> >>> Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>
> >>> ---
> >>>  Documentation/admin-guide/devices.txt    | 2 +-
> >>>  Documentation/media/v4l-drivers/meye.rst | 2 +-
> >>>  2 files changed, 2 insertions(+), 2 deletions(-)
> >>>
> >>> diff --git a/Documentation/admin-guide/devices.txt b/Documentation/admin-guide/devices.txt
> >>> index 1c5d2281efc9..2a97aaec8b12 100644
> >>> --- a/Documentation/admin-guide/devices.txt
> >>> +++ b/Documentation/admin-guide/devices.txt
> >>> @@ -319,7 +319,7 @@
> >>>  		182 = /dev/perfctr	Performance-monitoring counters
> >>>  		183 = /dev/hwrng	Generic random number generator
> >>>  		184 = /dev/cpu/microcode CPU microcode update interface
> >>> -		186 = /dev/atomicps	Atomic shapshot of process state data
> >>> +		186 = /dev/atomicps	Atomic snapshot of process state data
> >>>  		187 = /dev/irnet	IrNET device  
> >>
> >> Oops, irnet is part of irda which is no longer part of the kernel.
> >>  
> > 
> > This is probably based on the wrong tree. Will rebase and re-send.
> > 
> > Thanks,  
> > Jake>  
> 
> Well, I did rebase the patches locally but the contents are still the
> same so I'm not going to resend. I guess it's just because the
> devices.txt file hasn't been updated?
> 
> -Jake

Yes, it looks like references to irnet were never deleted.

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH 1/2] devlink: correct misspelling of snapshot
  2020-01-09 19:08 [PATCH 1/2] devlink: correct misspelling of snapshot Jacob Keller
  2020-01-09 19:08 ` [PATCH 2/2] doc: fix typo of snapshot in documentation Jacob Keller
@ 2020-01-10  9:36 ` Jiri Pirko
  2020-01-10 17:47   ` Jacob Keller
  2020-01-11  0:49 ` David Miller
  2 siblings, 1 reply; 10+ messages in thread
From: Jiri Pirko @ 2020-01-10  9:36 UTC (permalink / raw)
  To: Jacob Keller; +Cc: netdev, valex

Thu, Jan 09, 2020 at 08:08:20PM CET, jacob.e.keller@intel.com wrote:
>The function to obtain a unique snapshot id was mistakenly typo'd as
>devlink_region_shapshot_id_get. Fix this typo by renaming the function
>and all of its users.
>
>Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>

If you want to send this as a patchset, please provide a cover letter.

This patch looks fine to me.

Acked-by: Jiri Pirko <jiri@mellanox.com>

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH 1/2] devlink: correct misspelling of snapshot
  2020-01-10  9:36 ` [PATCH 1/2] devlink: correct misspelling of snapshot Jiri Pirko
@ 2020-01-10 17:47   ` Jacob Keller
  0 siblings, 0 replies; 10+ messages in thread
From: Jacob Keller @ 2020-01-10 17:47 UTC (permalink / raw)
  To: Jiri Pirko; +Cc: netdev, valex

On 1/10/2020 1:36 AM, Jiri Pirko wrote:
> Thu, Jan 09, 2020 at 08:08:20PM CET, jacob.e.keller@intel.com wrote:
>> The function to obtain a unique snapshot id was mistakenly typo'd as
>> devlink_region_shapshot_id_get. Fix this typo by renaming the function
>> and all of its users.
>>
>> Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>
> 
> If you want to send this as a patchset, please provide a cover letter.
> 
> This patch looks fine to me.
> 
> Acked-by: Jiri Pirko <jiri@mellanox.com>
> 

I don't really care about it being merged as a series, I just searched
for the shapshot typo and tried to fix it everywhere.

It doesn't seem worth the effort to resend with a cover letter..

Thanks,
Jake

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH 1/2] devlink: correct misspelling of snapshot
  2020-01-09 19:08 [PATCH 1/2] devlink: correct misspelling of snapshot Jacob Keller
  2020-01-09 19:08 ` [PATCH 2/2] doc: fix typo of snapshot in documentation Jacob Keller
  2020-01-10  9:36 ` [PATCH 1/2] devlink: correct misspelling of snapshot Jiri Pirko
@ 2020-01-11  0:49 ` David Miller
  2 siblings, 0 replies; 10+ messages in thread
From: David Miller @ 2020-01-11  0:49 UTC (permalink / raw)
  To: jacob.e.keller; +Cc: netdev, valex, jiri

From: Jacob Keller <jacob.e.keller@intel.com>
Date: Thu,  9 Jan 2020 11:08:20 -0800

> The function to obtain a unique snapshot id was mistakenly typo'd as
> devlink_region_shapshot_id_get. Fix this typo by renaming the function
> and all of its users.
> 
> Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>

Applied.

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH 2/2] doc: fix typo of snapshot in documentation
  2020-01-09 19:08 ` [PATCH 2/2] doc: fix typo of snapshot in documentation Jacob Keller
  2020-01-09 20:00   ` Stephen Hemminger
@ 2020-01-11  0:49   ` David Miller
  1 sibling, 0 replies; 10+ messages in thread
From: David Miller @ 2020-01-11  0:49 UTC (permalink / raw)
  To: jacob.e.keller; +Cc: netdev, valex, jiri

From: Jacob Keller <jacob.e.keller@intel.com>
Date: Thu,  9 Jan 2020 11:08:21 -0800

> A couple of locations accidentally misspelled snapshot as shapshot.
> 
> Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>

Applied.

^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2020-01-11  0:49 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-01-09 19:08 [PATCH 1/2] devlink: correct misspelling of snapshot Jacob Keller
2020-01-09 19:08 ` [PATCH 2/2] doc: fix typo of snapshot in documentation Jacob Keller
2020-01-09 20:00   ` Stephen Hemminger
2020-01-09 20:06     ` Jacob Keller
2020-01-09 20:11       ` Jacob Keller
2020-01-09 20:36         ` Stephen Hemminger
2020-01-11  0:49   ` David Miller
2020-01-10  9:36 ` [PATCH 1/2] devlink: correct misspelling of snapshot Jiri Pirko
2020-01-10 17:47   ` Jacob Keller
2020-01-11  0:49 ` David Miller

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.