All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bean Huo <huobean@gmail.com>
To: alim.akhtar@samsung.com, avri.altman@wdc.com,
	asutoshd@codeaurora.org, jejb@linux.ibm.com,
	martin.petersen@oracle.com, stanley.chu@mediatek.com,
	beanhuo@micron.com, bvanassche@acm.org, tomas.winkler@intel.com,
	cang@codeaurora.org
Cc: linux-scsi@vger.kernel.org, linux-kernel@vger.kernel.org,
	Bean Huo <huobean@gmail.com>
Subject: [PATCH v3 0/8] Use UFS device indicated maximum LU number
Date: Sun, 19 Jan 2020 01:13:19 +0100	[thread overview]
Message-ID: <20200119001327.29155-1-huobean@gmail.com> (raw)

This series of patches is to simplify UFS driver initialization flow
and add a new parameter max_lu_supported used to specify how many LUs 
supported by the UFS device.
This series of patches being tested on my two platforms, Qualcomm SOC 
based and Hisilicon SOC based platforms.

v1-v2:
    1. Split ufshcd_probe_hba() based on its called flow                                                                                                                                                   
    2. Delete two unnecessary functions
    3. Add a fixup patch
v2-v3:
    1. Combine patches 7/9 and 8/9 of v2 to patch 7/8 of v3
    2. Change patches 1/8 and 5/8 subject
    3. Change the name of two functions in patch 7/8

Bean Huo (8):
  scsi: ufs: Fix ufshcd_probe_hba() reture value in case
    ufshcd_scsi_add_wlus() fails
  scsi: ufs: Delete struct ufs_dev_desc
  scsi: ufs: Split ufshcd_probe_hba() based on its called flow
  scsi: ufs: move ufshcd_get_max_pwr_mode() to ufs_init_params()
  scsi: ufs: Inline two functions into their callers
  scsi: ufs: Delete is_init_prefetch from struct ufs_hba
  scsi: ufs: Add max_lu_supported in struct ufs_dev_info
  scsi: ufs: Use UFS device indicated maximum LU number

 drivers/scsi/ufs/ufs-mediatek.c |   7 +-
 drivers/scsi/ufs/ufs-qcom.c     |   6 +-
 drivers/scsi/ufs/ufs-sysfs.c    |   2 +-
 drivers/scsi/ufs/ufs.h          |  25 ++-
 drivers/scsi/ufs/ufs_quirks.h   |   9 +-
 drivers/scsi/ufs/ufshcd.c       | 276 +++++++++++++++++++-------------
 drivers/scsi/ufs/ufshcd.h       |   9 +-
 7 files changed, 196 insertions(+), 138 deletions(-)

-- 
2.17.1


             reply	other threads:[~2020-01-19  0:13 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-19  0:13 Bean Huo [this message]
2020-01-19  0:13 ` [PATCH v3 1/8] scsi: ufs: Fix ufshcd_probe_hba() reture value in case ufshcd_scsi_add_wlus() fails Bean Huo
2020-01-19  1:30   ` Alim Akhtar
2020-01-19  1:33     ` Alim Akhtar
2020-01-19  9:55   ` Stanley Chu
2020-01-19  0:13 ` [PATCH v3 2/8] scsi: ufs: Delete struct ufs_dev_desc Bean Huo
2020-01-19  1:35   ` Alim Akhtar
2020-01-19  9:56   ` Stanley Chu
2020-01-19  0:13 ` [PATCH v3 3/8] scsi: ufs: Split ufshcd_probe_hba() based on its called flow Bean Huo
2020-01-19  1:40   ` Alim Akhtar
2020-01-19  0:13 ` [PATCH v3 4/8] scsi: ufs: move ufshcd_get_max_pwr_mode() to ufs_init_params() Bean Huo
2020-01-19  1:47   ` Alim Akhtar
2020-01-19 22:21     ` [EXT] " Bean Huo (beanhuo)
2020-01-19  9:57   ` Stanley Chu
2020-01-19  0:13 ` [PATCH v3 5/8] scsi: ufs: Inline two functions into their callers Bean Huo
2020-01-19  1:53   ` Alim Akhtar
2020-01-19  0:13 ` [PATCH v3 6/8] scsi: ufs: Delete is_init_prefetch from struct ufs_hba Bean Huo
2020-01-19  0:13 ` [PATCH v3 7/8] scsi: ufs: Add max_lu_supported in struct ufs_dev_info Bean Huo
2020-01-19  2:07   ` Alim Akhtar
2020-01-19  0:13 ` [PATCH v3 8/8] scsi: ufs: Use UFS device indicated maximum LU number Bean Huo
2020-01-19  2:10   ` Alim Akhtar
2020-01-19  4:39 ` [PATCH v3 0/8] " Alim Akhtar
2020-01-19 21:59   ` [EXT] " Bean Huo (beanhuo)
2020-01-20  3:25     ` Alim Akhtar
2020-01-20 13:12       ` Bean Huo (beanhuo)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200119001327.29155-1-huobean@gmail.com \
    --to=huobean@gmail.com \
    --cc=alim.akhtar@samsung.com \
    --cc=asutoshd@codeaurora.org \
    --cc=avri.altman@wdc.com \
    --cc=beanhuo@micron.com \
    --cc=bvanassche@acm.org \
    --cc=cang@codeaurora.org \
    --cc=jejb@linux.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=stanley.chu@mediatek.com \
    --cc=tomas.winkler@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.